SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Oct 25, 2020 17:23
SMSTools3 Community » Help and support Bottom

[solved] Raspberry Pi+Huawei E160 => "unknown global setting: XXX" problem

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Aug 2013
Location: Germany
Operating system name and version: Raspberry Pi -> Raspbian
Version of smsd: v3.1.14
Smsd installed from: apt-get -> package repository (arm version)
Name and model of a modem / phone: Huawei E160 labeled as Medion S4011
Interface: USB

Hi, I want to hook up the usb stick modem mentioned above to my Raspberry Pi. I checked out the config section and configured it. After sending a test SMS to the SIM card inserted and checking the log file, I had to realize that no message was received. For the project (something with home automation) I working on, I want the RPi to receive messages, so I won't need the ability to send a message.

I attached the config and log file. "dmesg | grep ttyUSB" told me the following:

, so I don't really know the modem's port.

Log:


my conf:
# # /etc/smsd.conf
# # Description: Main configuration file for the smsd
# devices = GSM1
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
logfile = /var/log/smstools/smsd.log
infofile = /var/run/smstools/smsd.working
 pidfile = /var/run/smstools/smsd.pid
 outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
stats = /var/log/smstools/smsd_stats
loglevel = 6
#delaytime = 10
#errorsleeptime = 10
#blocktime = 3600
stats = /var/log/smsd_stats
stats_interval = 3600
#stats_no_zeroes = no
#checkhandler = /usr/local/bin/smscheck
receive_before_send = no
# autosplit 0=no 1=yes 2=with text numbers 3=concatenated
autosplit = 3
# store_received_pdu 0=no, 1=unsupported, 2=unsupported and 8bit, 3=all #store_received_pdu = 1
 #validity = 255
#decode_unicode_text = no
 #internal_combine = no
# You can specify here an external program that is started whenever an alarm occurs.
# alarmhandler = /path/to/an/alarmhandler/script
 # Specifies what levels start an alarmhandler. You can use value between 2 and 5.
# alarmlevel = 4
 # eventhandler = @EVENTHANDLER@
 #blacklist = /etc/smstools/blacklist
 #whitelist = /etc/smstools/whitelist
#[queues]
# Commented lines are examples for germany
# D1 = /var/spool/sms/D1
 # D2 = /var/spool/sms/D2
# O2 = /var/spool/sms/O2
 # EPLUS = /var/spool/sms/EPLUS
# QUAM = /var/sppol/sms/QUAM
# MOBILCOM = /var/spool/sms/MOBILCOM
#OTHER = /var/spool/sms/OTHER
#[provider]
# Commented lines are examples for germany
# D1 = 49160, 49170, 49171, 49175, 49151
# D2 = 491520, 49162, 49172, 49173, 49174
# O2 = 49176, 49179, 49159
# EPLUS = 49163, 49177, 49178, 49157
 # QUAM = 49150
# MOBILCOM = 49156
#OTHER = 0,1,2,3,4,5,6,7,8,9
 #[GSM1] init = ATE0+CPMS="SM"+CNMI=2,0,0,2,1
 # # Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0 device = /dev/ttyUSB1 incoming = high
# queues = OTHER
# You don't need a PIN for mobile phones
 # pin = 1111 mode = new
# smsc = 491722270000 baudrate = 19200
# rtscts = yes cs_convert = yes
# report = no memory_start = 1
# primary_memory = memory name
# secondary_memory = memory name
# secondary_memory_max = number
# pdu_from_file = /var/spool/sms/GSM1-PDU
# sending_disabled = no
# decode_unicode_text = no
# internal_combine = no
 
 
'smsdconf' Syntax Highlight powered by GeSHi


I hope you know what to do!

Bests, McM :-)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The conf shown is not your current conf.

See the difference, this is defined:
stats = /var/log/smstools/smsd_stats
but this is the error:
smsd: Stats directory /var/log/smsd_stats cannot be opened.

Many other errors, like this:
smsd: - Unknown global setting: device
occur because those settings are modem settings, not global.

It seems that you do not have a line [GSM1] for modem section.

Member
Registered:
Aug 2013
Location: Germany
Topic owner
okay, i didn't see that. But the code posted above is saved as /etc/smsd.conf. Why does smsd a different config file and furthermore, which one did it take?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I do not know about package on your OS. On some systems /usr/local/etc or something else is used. You could try locate smsd.conf to find out the locations.

Member
Registered:
Aug 2013
Location: Germany
Topic owner
Thanks for helping!

I fixed the problem. The preinstalled config file was horriblily messed up! I just had to delete some lines, then remove the "#" in front of the [GSM1] line.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.