SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat Nov 25, 2017 11:31
SMSTools3 Community » Feature requests Bottom

sending SMS using multiple modems

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Mar 2016
Location: Ekaterinburg, Russian Federation
Good day friends, tell me there is such task:
There are three modem GSM1, GSM2 and GSM3. you need to accept messages using all three of the modem, and only be sent via GSM1.

How to implement it in the config?

Member
Registered:
Mar 2016
Location: Ekaterinburg, Russian Federation
Topic owner
config:

root@sms#cat /etc/smsd.conf


devices = GSM1

stats = /var/log/sms/stats
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
failed = /var/spool/sms/failed
sent = /var/spool/sms/sent
report = /var/spool/sms/incoming

delaytime = 2
errorsleeptime = 4
blocktime = 180
autosplit = 3
national_prefixes = 7
hangup_incoming_call = yes

checkhandler = /etc/smsd/sms_to_ucs2.sh
eventhandler = /etc/smsd/trsms3.sh

smart_logging = yes
logfile = /var/log/smsd.log
loglevel = 5


[GSM1]
device = /dev/E150-1
baudrate = 115200
incoming = yes
rtscts = no
hangup_incoming_call = yes
report = yes
init = AT+CPMS="ME","ME","ME"
check_memory_method = 2

[GSM2]
device = /dev/E1550-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
check_memory_method = 31
signal_quality_ber_ignore = yes
incoming = yes
incoming = high
hangup_incoming_call = yes

[GSM3]
device = /dev/E1550-2-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
check_memory_method = 31
signal_quality_ber_ignore = yes
incoming = yes
incoming = high
hangup_incoming_call = yes

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
This can be done with the following configuration:

[queues]
GSM1 = /var/spool/sms/GSM1
GSM2 = /var/spool/sms/GSM2
GSM3 = /var/spool/sms/GSM3

[providers]
GSM1 = 0,1,2,3,4,5,6,7,8,9,s
GSM2 = 0
GSM3 = 0

[default]
queues = modemname
 
'smsdconf' Syntax Highlight powered by GeSHi


Put this just before [GSM1] section. Create those directories and make them writable for smsd.

With the providers definition, all messages are sorted to the GSM1 queue by default, and only GSM1 modem serves that queue.

If you want to send with other modem than GSM1, use a header Queue: GSM2 in the message file.

Member
Registered:
Mar 2016
Location: Ekaterinburg, Russian Federation
Topic owner
i am write this config

Quote
!!!# cat /etc/smsd.conf
devices = GSM1,GSM2-7430,GSM3-4707
#devices = GSM1

stats = /var/log/sms/stats
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
failed = /var/spool/sms/failed
sent = /var/spool/sms/sent
report = /var/spool/sms/incoming

delaytime = 20
errorsleeptime = 4
blocktime = 180
autosplit = 3
national_prefixes = 7
hangup_incoming_call = yes

checkhandler = /etc/smsd/sms_to_ucs2.sh
eventhandler = /etc/smsd/trsms3.sh

smart_logging = yes
smart_logging = no
logfile = /var/log/smsd.log
loglevel = 5

[queues]
GSM1 = /var/spool/sms/outgoing
GSM2 = /var/spool/sms/out_mega
GSM3 = /var/spool/sms/out_mega2

[providers]
GSM1 = 0,1,2,3,4,5,6,7,8,9,s
GSM2 = 0
GSM3 = 0

[default]
queues = GSM1

[GSM1]
queues = GSM1
device = /dev/E150-1
baudrate = 115200
incoming = yes
rtscts = no
hangup_incoming_call = yes
report = yes
init = AT+CPMS="ME","ME","ME"
check_memory_method = 2

[GSM2-7430]
queues = GSM2
device = /dev/E1550-7430-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
#check_memory_method = 31
check_memory_method = 2
signal_quality_ber_ignore = yes
incoming = yes
hangup_incoming_call = yes

[GSM3-4707]
queues = GSM3
device = /dev/E1550-4707-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
check_memory_method = 31
signal_quality_ber_ignore = yes
incoming = yes
hangup_incoming_call = yes

SMS is copied to the correct folder
Quote
2016-03-14 08:44:36,5, smsd: Moved file /var/spool/sms/outgoing/out.20160314014435.0.1.446 to /var/spool/sms/outgoing

but the message never sent

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Do not use outgoing directory as queue.

Member
Registered:
Mar 2016
Location: Ekaterinburg, Russian Federation
Topic owner
I rewrote the config to your likeness now, I do not yhodyat SMS, and logs don't see sending.

cat smsd.conf
Quote
devices = GSM1,GSM2-7430,GSM3-4707
#devices = GSM1

stats = /var/log/sms/stats
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
failed = /var/spool/sms/failed
sent = /var/spool/sms/sent
report = /var/spool/sms/incoming

delaytime = 20
errorsleeptime = 4
blocktime = 180
autosplit = 3
national_prefixes = 7
hangup_incoming_call = yes

checkhandler = /etc/smsd/sms_to_ucs2.sh
eventhandler = /etc/smsd/trsms3.sh

smart_logging = yes
smart_logging = no
logfile = /var/log/smsd.log
loglevel = 5

[queues]
GSM1 = /var/spool/sms/out_gms1
GSM2 = /var/spool/sms/out_mega
GSM3 = /var/spool/sms/out_mega2

[providers]
GSM1 = 0,1,2,3,4,5,6,7,8,9,s
GSM2 = 0
GSM3 = 0

[default]
queues = GSM1

[GSM1]
queues = GSM1
device = /dev/E150-1
baudrate = 115200
incoming = yes
rtscts = no
hangup_incoming_call = yes
report = yes
init = AT+CPMS="ME","ME","ME"
check_memory_method = 2

[GSM2-7430]
queues = GSM2
device = /dev/E1550-7430-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
#check_memory_method = 31
check_memory_method = 2
signal_quality_ber_ignore = yes
incoming = yes
hangup_incoming_call = yes

[GSM3-4707]
queues = GSM3
device = /dev/E1550-4707-1
baudrate = 115200
report = yes
rtscts = no
init = AT+CPMS="SM","SM","SM"
check_memory_method = 31
signal_quality_ber_ignore = yes
incoming = yes
hangup_incoming_call = yes

this all log after restart


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
There is a problem with check_memory_method 31. Can you use the loglevel 7, and run GSM3-4707 only? Show the log here, you can protect it using Private tags if necessary.

Member
Registered:
Mar 2016
Location: Ekaterinburg, Russian Federation
Topic owner
Here is a log received, about the SMS.




It is not important, the question is, why is the configuration with the queue, not sent SMS?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
In your system there is a file /var/spool/sms/incoming/GSM3-4707-concatenated, right? I think that this file is broken, perhaps edited or something. You could just delete that file when smsd is not running.

When your current setup defines queues for each modem, there is no need for [default] section which defined queues using modemname. You could remove that section.

With a quick view I do not see the error in the current configuration. You could just enable GSM1 again, start smsd and copy a message file to the outgoing directory. With a loglevel 7 we can get the information how message is spooled and handled.

Login and Post Reply

Page:  1

SMSTools3 Community » Feature requests Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.