Raspberry Jessie:
latest:

ALDI Medion WebStick:


Hello All,

I am facing a strange problem:

After many days of proper work (followed by possible modifications, which I am not aware of today ...) SMSTOOS doesn't read any more the UMTS Stick memory areas ...:

--------------------------------------------------------------------------------
....
2016-04-25 05:59:17,6, GSM1: No SMS received
2016-04-25 05:59:27,6, GSM1: Checking device for incoming SMS
2016-04-25 05:59:27,6, GSM1: Checking if modem is ready
2016-04-25 05:59:27,7, GSM1: -> AT
2016-04-25 05:59:27,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:28,7, GSM1: <- OK
2016-04-25 05:59:28,6, GSM1: Pre-initializing modem
2016-04-25 05:59:28,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2016-04-25 05:59:28,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:28,7, GSM1: <- OK
2016-04-25 05:59:28,6, GSM1: Initializing modem
2016-04-25 05:59:28,7, GSM1: -> AT+CSCA?
2016-04-25 05:59:28,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:29,7, GSM1: <- +CSCA: "491760000443", 145 OK
2016-04-25 05:59:29,7, GSM1: -> AT+CSQ
2016-04-25 05:59:29,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:29,7, GSM1: <- +CSQ: 14, 99 OK
2016-04-25 05:59:29,6, GSM1: Signal Strength Indicator: (14,99) -85 dBm (Workable), Bit Error Rate: not known or not detectable
2016-04-25 05:59:29,6, GSM1: Checking if Modem is registered to the network
2016-04-25 05:59:29,7, GSM1: -> AT+CREG?
2016-04-25 05:59:29,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:29,7, GSM1: <- +CREG: 2,5,"9E1C","09AC68F8",6 OK
2016-04-25 05:59:29,6, GSM1: Modem is registered to a roaming partner network
2016-04-25 05:59:29,6, GSM1: Selecting PDU mode
2016-04-25 05:59:30,7, GSM1: -> AT+CMGF=0
2016-04-25 05:59:30,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:30,7, GSM1: <- OK
2016-04-25 05:59:30,6, GSM1: Checking memory size
2016-04-25 05:59:30,7, GSM1: -> AT+CPMS?
2016-04-25 05:59:30,7, GSM1: Command is sent, waiting for the answer
2016-04-25 05:59:30,7, GSM1: <- +CPMS: "ME", 0, 50, "SM", 1, 10, "SM", 1, 10 OK
2016-04-25 05:59:30,6, GSM1: Used memory is 0 of 50
2016-04-25 05:59:30,6, GSM1: No SMS received
...
-----------------------------------------------------------------------------------

As you can see, the statistic line (bolded) +CPMS: .... shows ONE of 10 possible SMS entries on the SimCard Memory, but it seems that SMSTOOS is unable to recognize that SMS and pull it into processing!
Definitely the SMS has arrived and ist readable (under windows 7).

I am not asking for your deep analysis help, but I just wanted to be advised for possibly overseen parameters in SMSTOOLS which have to be switched on for reading the UMST stick memory area(s)?

Thanks in advance!

Regards


« Last edit by USB-Stick on Mon Apr 25, 2016 04:24, 99 months ago. »