SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:53
SMSTools3 Community » Help and support Bottom

Different SIM networks gives different result

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Sep 2016
Location: Malaysia
Operating system name and version: Ubuntu 14.04
Version of smsd:
Smsd installed from: sources / package repository / from elsewhere...
Name and model of a modem / phone: HSDPA USB Stick
Interface: serial / USB / some adapter...

I would like to know why different SIM networks give me different result? Can anyone point to the right direction?

SIM#1: It works flawlessly with mobile carrier A
SIM#2: However, when I switch to mobile carrier B with another SIM, it didn't work. Below is the log.

2016-09-21 22:01:45,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_GhQjW9
2016-09-21 22:01:45,6, GSM1: Sending SMS from to 60109125880
2016-09-21 22:01:45,6, GSM1: Checking if modem is ready
2016-09-21 22:01:45,7, GSM1: -> AT
2016-09-21 22:01:45,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:45,7, GSM1: <- OK
2016-09-21 22:01:45,6, GSM1: Pre-initializing modem
2016-09-21 22:01:46,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2016-09-21 22:01:46,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:46,7, GSM1: <- ERROR
2016-09-21 22:01:46,3, GSM1: Modem did not accept the pre-init string
2016-09-21 22:01:46,6, GSM1: Checking if modem needs PIN
2016-09-21 22:01:46,7, GSM1: -> AT+CPIN?
2016-09-21 22:01:46,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:46,7, GSM1: <- +CPIN: READY OK
2016-09-21 22:01:47,7, GSM1: -> AT+CSQ
2016-09-21 22:01:47,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:47,7, GSM1: <- +CSQ: 4,99 OK
2016-09-21 22:01:47,6, GSM1: Signal Strength Indicator: (4,99) -105 dBm (Marginal), Bit Error Rate: not known or not detectable
2016-09-21 22:01:47,6, GSM1: Checking if Modem is registered to the network
2016-09-21 22:01:47,7, GSM1: -> AT+CREG?
2016-09-21 22:01:47,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:47,7, GSM1: <- +CREG: 0,1 OK
2016-09-21 22:01:47,6, GSM1: Modem is registered to the network
2016-09-21 22:01:47,6, GSM1: Selecting PDU mode
2016-09-21 22:01:48,7, GSM1: -> AT+CMGF=0
2016-09-21 22:01:48,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:48,7, GSM1: <- OK
2016-09-21 22:01:48,7, GSM1: -> AT+CIMI
2016-09-21 22:01:48,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:48,7, GSM1: <- 502196201229333 OK
2016-09-21 22:01:49,7, GSM1: -> AT+CGSN
2016-09-21 22:01:49,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:49,7, GSM1: <- +CME ERROR: 23 (memory failure)
2016-09-21 22:01:49,5, GSM1: CGSN: +CME ERROR: 23 (memory failure)
2016-09-21 22:01:49,5, GSM1: IMSI: 502196201229333
2016-09-21 22:01:49,6, GSM1: Checking if reading of messages is supported
2016-09-21 22:01:49,7, GSM1: -> AT+CPMS?
2016-09-21 22:01:49,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:49,7, GSM1: <- +CPMS: "SM",1,30,"SM",1,30,"SM",1,30 OK
2016-09-21 22:01:50,7, GSM1: -> AT+CMGS=33
2016-09-21 22:01:50,7, GSM1: Command is sent, waiting for the answer
2016-09-21 22:01:50,7, GSM1: <- >
2016-09-21 22:01:50,7, GSM1: -> 0011000B910601195288F00000FF15C8B09CFDBEB340E8F71D14969741F977FDF703
2016-09-21 22:01:50,7, GSM1: Command is sent, waiting for the answer

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
First error may be caused, because there is no semicolon after the ATE0. This will be fixed in the next version 3.1.16beta2 which is released soon. While waiting for that, you could use a modem setting pre_init = no. However, as the modem is the same and just the SIM changes, this probably is not a major problem.

Asking of IMEI (International Mobile station Equipment Identity) fails, which is strange. If this works with the SIM #1, you could try if the SIM #2 works inside the handset. Try to send some message to see if the SIM is broken or not. However, asking for the serial number should work even without the SIM inserted, so check if the result is the same with the SIM #1. If it is the same, just ignore that error.

There is one message in the SIM, but the log does not show if it can be read. Also the log does not show what is the response when you try sending. Do you have incoming = yes, and is reading of messages working properly with the SIM #1?

Member
Registered:
Sep 2016
Location: Malaysia
Topic owner
Can I make a Telegram group for SMS Server Tools? I am in there helping each other who needs real time support at http://t.me/gurulancer

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I do not recommend to create a group which has official name of this software. Some people might think that it is official support group, even when it's not.

How is your own issue resolved? Did you try 3.1.16, and did you test SIM #2 with your handset? And can you read messages from any SIM?

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.