SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:00
SMSTools3 Community » Help and support Bottom

Problem Sending SMS (Checked Folder stick)

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Jan 2017
Location: France
Hi,
I configured everything as noticed in the documentation.
I installed smstools on Ubuntu then i installed it on Windows using Cygwin.
Everything seems beeing ok even the Log file doesnt show any error.
But i cannot send a sms or receive. When i send a sms, it directly goes to Check folder then it doesnt move to the sent folder.
Here is how my sms looks like :
"To: 33643568956

Test message envoi"

-----------------------------

Here is my log file :

2017-01-10 11:58:44,2, smsd: Smsd v3.1.15 started.
2017-01-10 11:58:44,2, smsd: Running as farissi:None.
2017-01-10 11:58:44,7, smsd: Running startup_check (shell): /var/spool/sms/incoming/smsd_script.CVcetd /tmp/smsd_data.YVsutX
2017-01-10 11:58:44,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2017-01-10 11:58:44,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2017-01-10 11:58:44,5, smsd: Outgoing file checker has started. PID: 11200.
2017-01-10 11:58:44,7, smsd: All PID's: 11200,11224
2017-01-10 11:58:44,5, GSM1: Modem handler 0 has started. PID: 11224.
2017-01-10 11:58:44,5, GSM1: Using check_memory_method 1: CPMS is used.
2017-01-10 11:58:44,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_MzVLS4
2017-01-10 11:58:44,6, GSM1: Sending SMS from to 212624963575
2017-01-10 11:58:44,6, GSM1: Checking if modem is ready
2017-01-10 11:58:44,7, GSM1: -> AT
2017-01-10 11:58:44,5, smsd: No destination in file /var/spool/sms/outgoing/send_DWPEcR
2017-01-10 11:58:44,6, smsd: Deleted file /var/spool/sms/outgoing/send_DWPEcR
2017-01-10 11:58:45,5, smsd: Moved file /var/spool/sms/outgoing/send_yf96uo to /var/spool/sms/checked

-------------------------------------------------------------------

Here is my configuration :
# Example smsd.conf. Read the manual for a description

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/com1
incoming = yes
outgoing = yes
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
number = 212647216559
baudrate = 9600
SMSC = 212699790000
rtscts = no
pin = ignore
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes

-----------------------

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
First check what is the current configuration. It seems that smsd.conf shown is not the current. For example directories like failed = /var/spool/sms/failed are global settings, not a modem settings.

GSM1 started to send a file send_MzVLS4, but after the first AT command I cannot see how the modem responds. Please show little bit more log, including whole communication.

Member
Registered:
Jan 2017
Location: France
Topic owner
Hi, This is all I got on the file Logs. Is there any other log file or folder i should find? If yes what is the path?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
How did you start smsd? If you did not specify configuration, it's /etc/smsd.conf. Please show that file.

It seems that communication with modem gets stuck. You probably have rtscts = no, so comment that line out and try again.

Use a modem setting report_device_details = yes and show those details here.

Member
Registered:
Jan 2017
Location: France
Topic owner
Okay I followed your noticed and here is my smsd.conf

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/com1
incoming = yes
outgoing = yes
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
number = 212647216559
baudrate = 9600
SMSC = 212699790000
pin = ignore
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes
report_device_details = yes

------------------------

And here are the errors of smstools when i do restart

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/com1
incoming = yes
outgoing = yes
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
number = 212647216559
baudrate = 9600
SMSC = 212699790000
pin = ignore
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes
report_device_details = yes

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The configuration you have shown cannot be a valid. It has global settings in the modem section, and smsd does not start with this kind of configuration.

Lower part of your post is not a log, it's the same invalid configuration. :shock:

Member
Registered:
Jan 2017
Location: France
Topic owner
Sorry my bad : Here are the logs :

- Invalid outgoing value: /var/spool/sms/outgoing
- Unknown setting for modem GSM1: checked
- Unknown setting for modem GSM1: failed
- Invalid incoming value: /var/spool/sms/incoming
- Unknown setting for modem GSM1: sent
- Unknown setting for modem GSM1: delaytime
- Unknown setting for modem GSM1: errorsleeptime
- Unknown setting for modem GSM1: blocktime
- Unknown setting for modem GSM1: autosplit
- Unknown setting for modem GSM1: receive_before_send

----------------------
What about configuration ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes

[GSM1]
device = /dev/com1
incoming = yes
outgoing = yes
number = 212647216559
baudrate = 9600
SMSC = 212699790000
pin = ignore
report_device_details = yes
'smsdconf' Syntax Highlight powered by GeSHi


Member
Registered:
Jan 2017
Location: France
Topic owner
Is it the configuration i should try ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
It is your configuration in the corrected form, hopefully. :roll:

Member
Registered:
Jan 2017
Location: France
Topic owner
I put the configuration as you told me, i restarted smstools : no errors and i try to send an sms but i didnt receive it on my phone, here are the logs :


2017-01-10 16:56:21,2, smsd: Smsd v3.1.15 started.
2017-01-10 16:56:21,2, smsd: Running as farissi:None.
2017-01-10 16:56:21,7, smsd: Running startup_check (shell): /var/spool/sms/incoming/smsd_script.9w7mYw /tmp/smsd_data.Rb20Fq
2017-01-10 16:56:21,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2017-01-10 16:56:21,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2017-01-10 16:56:21,5, smsd: Outgoing file checker has started. PID: 51796.
2017-01-10 16:56:21,7, smsd: All PID's: 51796,52300
2017-01-10 16:56:21,5, GSM1: Modem handler 0 has started. PID: 52300.
2017-01-10 16:56:22,5, GSM1: Using check_memory_method 1: CPMS is used.
2017-01-10 16:56:22,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_MzVLS4
2017-01-10 16:56:22,6, GSM1: Checking device for incoming SMS
2017-01-10 16:56:22,6, GSM1: Checking if modem is ready
2017-01-10 16:56:22,5, smsd: Moved file /var/spool/sms/outgoing/send_c7M2N1 to /var/spool/sms/checked
2017-01-10 16:56:22,7, GSM1: -> AT
2017-01-10 16:56:22,5, smsd: Moved file /var/spool/sms/outgoing/send_sofxFD to /var/spool/sms/checked
2017-01-10 16:56:23,5, smsd: Moved file /var/spool/sms/outgoing/send_41bxi5 to /var/spool/sms/checked
2017-01-10 16:56:23,5, smsd: Moved file /var/spool/sms/outgoing/send_4raI2s to /var/spool/sms/checked
2017-01-10 16:56:24,5, smsd: Moved file /var/spool/sms/outgoing/send_ddYeYU to /var/spool/sms/checked
2017-01-10 16:56:24,5, smsd: Moved file /var/spool/sms/outgoing/send_Y1ADVe to /var/spool/sms/checked
2017-01-10 16:57:01,5, smsd: Moved file /var/spool/sms/outgoing/send_FR4fws to /var/spool/sms/checked

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You probably have a hardware issue, or your modem is not on /dev/com1.

Please check what com ports you have, and try them all, one at a time.

If nothing works, move back to Ubuntu to see if a modem works at all, and cables are not broken.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.