SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:47
SMSTools3 Community » Help and support Bottom

[answered] SMS Report

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2016
Location: New Zealand
Operating system name and version: Debian 8.7
Version of smsd: 3.1.15
Smsd installed from: package repository
Name and model of a modem / phone: Sierra Wireless AC326U
Interface: USB

Hello, this modem is working flawlessly - I am really impressed with its performance, however I am unable to receive SMS Status from it.. at least as a message from the message store..
I receive them as a 'routed' message but cant seem to get them any other way.

In my country there is only one carrier that supports reports, and only to their own network, but it would still be nice to get them if I can..

I have been playing around with at+cnmi but with some combinations I get errors, and it appears that I can only get them as routed messages.

I am not even sure if I can upgrade the firmware, as when I went to the Sierra Wireless website, even the AT command set were locked down behind a authorized users section.

But anyway - Here are the bits from the log that I know you are going to ask for :)

Please ignore the current at+cnmi setting it was just what I have been playing with.



The following is my 'modem' setting:

[GSM1]
 init = at+cpms="MT","MT","MT","MT"
 pin = ignore
 device = /dev/serial/by-id/usb-Sierra_Wireless__Incorporated_AC326U_355130040139442-if03-port0
 incoming = yes
 queues = Country
 check_network = 2
 check_memory_method = 2
 mode = new
 baudrate = 115200
 rtscts = yes
 report = yes
 routed_status_report_cnma = no
 cs_convert = yes
 loglevel_lac_ci = 8
 eventhandler = /etc/smstools/eventhandler.sh
 memory_start = 0
 sending_disabled = no
 decode_unicode_text = yes
 internal_combine = yes
 phonecalls = clip
 report_device_details = yes
 
'smsdconf' Syntax Highlight powered by GeSHi


I have tried many combinations for at+cnmi:



So while the at+cnmi=? says it supports various setup's - it seems to only work for the status messages if you have 'mode' set to 1.

Anyway thanks again for all the support you have given over the years, and I hope we can resolve this, if not, no biggie, just a bit sad :) haha

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Manual of a modem would be useful, but if it is not available, we have to guess and try.

First fix your init string, remove the fourth ,"MT" as that command usually accepts three memories only. I'm not sure if this makes a difference, but it should be tested.

Your device has SR memory. Thanks for showing details of device, without needing to ask for it. :D Reports are stored into the SR memory, and you could try the following settings:

[GSM1]
 init = AT+CNMI=1,0,0,2,0
 primary_memory = SM
 secondary_memory = SR
 
'smsdconf' Syntax Highlight powered by GeSHi


Those settings are for Wavecom devices, and if reports are not handled properly, you need to go back to the start point. Change CNMI to that value which produced routed reports, and use a modem setting using_routed_status_report = yes. It removes some warnings.

Member
Registered:
Apr 2016
Location: New Zealand
Topic owner
Hello,

Thanks for the support:

I have had to end up getting routed messages then selecting your suggested config option of :using_routed_status_report = yes

If I loose some, I am not too stressed about it, as its a nice to have..
But it appears that no matter what setting I chose to use on the at+cnmi I had to use +CNMI: 1,0,0,1,0 -which gave me routed reports.

Thanks again for the help :)

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.