SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Tue Oct 20, 2020 23:38
SMSTools3 Community » Help and support Bottom

[solved] Cannot receive SMS with Huawei E3131

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2017
Location: Germany
Operating system name and version: Raspbian Jessie
Version of smsd: 3.1.20
Smsd installed from: sources
Name and model of a modem / phone: Huawei E3131
Interface: /dev/ttyUSB0


Hi,

I'm struggling for hours with sms3 receiving sms. It worked till I had to change the SIM card.
I tried alot of Init strings, but it still says "No sms received", sending via playsms works likes a charm.

Here is my conf:



# Global configuration

#devices = modem1, modem2
devices = modem1

loglevel = 7

# logfiles
stats = /var/log/sms/stats
logfile = /var/log/sms/smsd.log

# Default queue directory = /var/spool/sms
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

# do not set report folder, let status report files saved in incoming
#report = /var/spool/sms/report

delaytime = 2
errorsleeptime = 10
blocktime = 180
autosplit = 3
#receive_before_send = yes
incoming_utf8 = yes

# Queue configurations

[queues]
modem1 = /var/spool/sms/modem1
#modem2 = /var/spool/sms/modem2

# Modem configurations

# Modem name: modem1
# Modem type: Wavecom USB
[modem1]
#init = AT+CNMI=2,2,0,1,0;+CMEE=1
#init = AT+CPMS="ME","ME","ME"
init=AT+CPMS="SM","SM","SM"
device = /dev/ttyUSB0
baudrate = 19200
incoming = yes
#pin = 3391
report = yes
queues = modem1
decode_unicode_text = yes
cs_convert = yes
 
 
'smsdconf' Syntax Highlight powered by GeSHi



Any help is appreciated :)


Thanks Dan

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
With Huawei devices a modem setting memory_start = 0 is usually required, but version 3.1.20 should handle that issue even when a setting is not used.

As your modem is connected with USB, are you sure that lower baudrate is necessary? Those devices should usually work well with 115200 which is a default, and in some cases USB devices do not work if the speed is lowered.

However, the main reason for the receiving issue is unclear. Perhaps the modem receives messages to elsewhere than SM memory. You could use a modem setting report_device_details = yes, restart smsd and show those details here.

Member
Registered:
Apr 2017
Location: Germany
Topic owner
Thanks for your quick reply.

I changed my conf as recommended by you (btw I alredy tried different baudrates).

Here's my output:



Is my init string correct ?



I sent a SMS to the device, with nothing showing up in the log.



thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Currently the SM memory is empty, so it is normal that smsd does not receive messages.

Should there be a message in the modem right now? If yes, it may be in the ME memory, but you could now send a message to your device, without changing anything, and see if it is received properly.

I need to see full details, all lines between "start" and "end".

Member
Registered:
Apr 2017
Location: Germany
Topic owner
Well, the messages are visible over the web inteface of the modem, when I stick it into my windows pc....

I just sent another SMS, here is the log, says nothing to me...



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
daniel361 wrote
Well, the messages are visible over the web inteface of the modem, when I stick it into my windows pc....

Okay, the web interface program has taken messages to it's own storage, and therefore the SIM is empty. Stay away of that windows pc if you want that smsd can receive messages. ;)

You need to test memories now. Use the stick on Linux only. Stop the smsd. With your handset send a message to the stick. With your current setting init=AT+CPMS="SM","SM","SM" start the smsd and see if a message is received. If nothing is received, change initialization to init=AT+CPMS="ME","ME","ME" and restart smsd. If still nothing is received, use a modem setting report_device_details = yes and show full details here.

Member
Registered:
Apr 2017
Location: Germany
Topic owner
Nothing changed :(

Do you mean these details ?



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Your device has SM and ME memories, and when they both are still empty, even when you have sent a message to the stick, I think that something is just broken or the message was sent to the wrong number. If the number was surely correct, try with an another SIM, or replace the modem.

Member
Registered:
Apr 2017
Location: Germany
Topic owner
I changed SIM with no luck.
Could you recommend another 3G modem that will work ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I do not usually recommend anything, but for example Huawei E313 is working well. It is very similar than your modem.

I hope that you have done all tests with your modem very carefully.

Member
Registered:
Apr 2017
Location: Germany
Topic owner
I will completely reinstall this thing. Funny thing is that it worked a short time, didn't change anything (afaik)... we will see ;)

Member
Registered:
Apr 2017
Location: Germany
Topic owner
Solved this finally with Huawei E169 UMTS stick, works out of the box.

Thanks for the support.

Member
Registered:
May 2017
Location: Wrocław, Poland
daniel361 wrote
Solved this finally with Huawei E169 UMTS stick, works out of the box.

Thanks for the support.

i have the same modem, but i cant receive sms, can u put yours config file?

Member
Registered:
Apr 2017
Location: Germany
Topic owner
helianthus wrote
daniel361 wrote
Solved this finally with Huawei E169 UMTS stick, works out of the box.

Thanks for the support.

i have the same modem, but i cant receive sms, can u put yours config file?

Sure, here we go:
# Global configuration

#devices = modem1, modem2
devices = modem1

loglevel = 7

# logfiles
stats = /var/log/sms/stats
logfile = /var/log/sms/smsd.log

# Default queue directory = /var/spool/sms
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

# do not set report folder, let status report files saved in incoming
#report = /var/spool/sms/report

delaytime = 2
errorsleeptime = 10
blocktime = 180
autosplit = 3
#receive_before_send = yes
incoming_utf8 = yes

# Queue configurations

[queues]
modem1 = /var/spool/sms
#modem2 = /var/spool/sms/modem2

# Modem configurations

# Modem name: modem1
# Modem type: Wavecom USB
[modem1]
#init=AT+CPMS="SM","SM","SM"
init=AT+CPMS="ME","ME","ME"
device = /dev/ttyUSB2
baudrate = 19200
incoming = yes
#pin = 3391
report = yes
queues = modem1
decode_unicode_text = yes
cs_convert = yes
signal_quality_ber_ignore = yes
memory_start = 0
 
 
'smsdconf' Syntax Highlight powered by GeSHi


Member
Registered:
May 2017
Location: Wrocław, Poland
daniel361 wrote
Sure, here we go:

thx, but it;s not working :(

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.