SMS Server Tools 3
This site is hosted by
Basic information:
Additional information:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

Custom Search

 Visitor locations
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:20
SMSTools3 Community » Help and support Bottom

[solved] smsd gets stuck at CLCC command

Login and Post Reply

Page:  1

Author Post
May 2017
Location: Vienna, Austria
Operating system name and version: Debian testing
Version of smsd: 3.1.20
Smsd installed from: sources
Name and model of a modem / phone: E1750
Interface: /dev/ttyUSB0

Hi, not sure if this is a bug report, a feature request or just a modem that is completely bonkers ...

Sending / receiving SMS with this modem seems to work fine.

Handling incoming voice calls also started to work after I enabled CLIP.

However outgoing calls cause a lot of trouble:
Since ATD returns OK immediatly, I first tried
voicecall_cpas = yes
however this only caused a minor delay before answering with +CPAS: 4 OK (before the call was answered at the other and), so the commands to send DTMF tones returned errrors.

Next I tried voicecall_clcc = yes, which works a bit better (smsd waits for the other side), but when the oder side either accepts or denys the call, the final CLCC command doesn't return a result and the modem stops responding like it did on incoming calls before I used CLIP. I guess it is in some call_is_active state, where normal command processing is disabled.
However in rare cases the final CLCC command does report an active call, in which case the voice call procedure is executed normally, so I guess some race is involved as well. (Only saw that once so far, so not clear how frequent this is.)

This is the relevant part of the configuration:
init = AT+CNMI=0,0,0,0,0
device = /dev/ttyUSB0
incoming = yes
pin = xxxx
baudrate = 115200
#check_memory_method = 2
report_device_details = yes
memory_start = 0
phonecalls = clip
voicecall_clcc = yes
'smsdconf' Syntax Highlight powered by GeSHi

And this is an example log of a session where the other side accepts the call, but the connection to the modem gets stuck (some boring lines in the middle omitted):

May 2009
Location: Jyväskylä, Finland
The modem gets stuck and there is no way to resolve it. Generally taken very many modems today have minor or major problems with voicecall. Some modem work partially, for example with "TIME: 15" message body, when call is not answered. User can see that smstools is calling, but no DTMF tones can be used to tell what is going on. Huawei E353 gets stuck after the first tones are played. Some modems do not see that the call is answered, and so on.

In the good old days Nokia 6210 was working very well, but today with cheap and new devices users just have to test, and hope, that the voicecall works, at least partially, and then decide whether to use the feature partially or just forget the whole thing.

May 2017
Location: Vienna, Austria
Topic owner

I have been able to fix all remaining issues with voice calls by using /dev/ttyUSB2 instead of /dev/ttyUSB0. Looks like the latter is only good for pppd, but not for smsd.

Maybe somebody else finds this information useful.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.