SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:57
SMSTools3 Community » Help and support Bottom

+CME ERROR: 14 (SIM busy) after AT+CPIN?

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2017
Location: FRANCE, France
Operating system name and version: Raspberry with SMS Serial adapter
Version of smsd: 2
Smsd installed from: sources / package repository / from elsewhere...
Name and model of a modem / phone:
Interface: serial / USB / some adapter... /dev/ttyAMA0


Hi,

My system has been working for a long time, but now I have a new message, juste after entering the pin (see above:
When I enter the commands manually using minicom, it works correctly. My feeling is that to AT+CPIN? is arriving too quickly.




Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Use a modem setting pinsleeptime = 10. Value defines seconds to wait and perhaps lower value works well too. Just test it.

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
Thanks for your suggestion, but it still doesn't work (but apparently for a different reason)

Strange, no ?

2017-06-22 14:59:05.761,7, GSM1: <- AT+CPIN? +CPIN: SIM PIN OK
2017-06-22 14:59:05.761,3, GSM1: Modem did not accept this PIN





Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
What is that modem, name and model?

It gives the answer +CPIN: SIM PIN OK, when the answer should be +CPIN: READY. This is not compatible with smsd, and you have to disable the PIN, if not already disabled, and use the setting pin = ignore.

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
I don't really remember the model (I am not on site). It's a chinese SIM adapter.
The strange thing is that it has been working for months.
But you are surely right, I have to test without a pin.
I will give you a reply ASAP.

Thanks.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could use a modem setting report_device_details = yes to get some more information about the modem.

When the PIN was asked second time, the ECHO is on. This also looks strange.

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
I already have it enabled, my complete config file is :



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, could you show the details here?

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
What details do you want me to show ? the complete log file ?

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
I have no more than that :



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
After the PIN is handled properly, there will be lines:
## Start of device details
( interesting details are here )
## End of device details

But your modem fails with the PIN, and smsd stops before details are logged.

Now it did not answer to the second query, so disable the PIN and use pin = ignore.

Member
Registered:
Apr 2017
Location: FRANCE, France
Topic owner
Ok, let me do that this evening, I will tell you tomorrow what happens.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.