SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Sep 25, 2017 18:56
SMSTools3 Community » Help and support Bottom

Modem Registration Delay Parameter

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Aug 2017
Location: Queensland, Australia
Operating system name and version: Raspian/Linux 8.0
Version of smsd: 3.1.15-1.1+deb8u1
Smsd installed from: archive.raspberrypi.org/debian/ jessie release
Name and model of a modem / phone: Telit HE910
Interface: USB

Hello,

I am trying to setup Linux to automatically restart the SMS server when a USB modem is plugged in.

I have set this up using udev rules and it seems to work fine:



My issue is that when the reset is performed, the SMS server reports that the modem is not registered and attempts to then register the modem. This is performed 3 time with a second delay between each attempt. After the 3rd failure, the system essentially seems to stop (excerpt of the log below).



If I then issue a

it kicks off again and starts working.

It would seem as though the modem is taking a finite amount of time to register on the network once it is plugged in. Is there a configurable parameter that will force the system to wait for X seconds when it starts up before looking for the modem i.e. start delay?

I have gone through the parameters and haven't found a parameter that would seem to accomplish this.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Have you tried these modem settings?
start = AT
startsleeptime = 30


For start some modem command is mandatory, and AT would be just enough. The startsleeptime defaults to 3 seconds, and some longer delay is better in your case.

Member
Registered:
Aug 2017
Location: Queensland, Australia
Topic owner
Hi Keke,

I made the modifications (using 10 seconds) to the config file and when the system is started using the "sms3 start", the process pauses for 10 seconds and continues as expected.

When I unplug and then re-plug the modem, the udev rule issues the "sms3 restart" command and the system seems to hang at the pause phase:



It never continues after the last entry.

If I then issue another "sms3 restart" command from a terminal session, the system will restart and work normally i.e. will continue after the 10 second pause.

I did also try at 30 seconds with the same result.

I tried changing the rules file to start and stop the service based on adding and removing the modem as per the below



This had no effect.

As a side note, if you unplug and then re-plug in the modem while it is stalled at the waiting stage, the service will restart and this time it will not progress past the start string phase.



As mentioned before, if I issue a restart command from a terminal session, it will work correctly. Just seems that the udev rule doesn't work correctly.

Any ideas??

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.