SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Nov 24, 2017 22:01
SMSTools3 Community » Help and support Bottom

ZTE K3571-Z > Modem is not ready to answer commands

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Sep 2017
Location: Constanta, Romania
Operating system name and version: Ubuntu 16.04
Version of smsd: Smsd v3.1.21
Smsd installed from: sources
Name and model of a modem / phone: ZTE K3571-Z
Interface: USB ( /dev/gsm2-3 -> ttyUSB2)

I have disabled the modems flashmemory interface by executing the following AT-command: AT+ZCDRUN=8
The modem is being detected as Bus 002 Device 009: ID 19d2:1010 ZTE WCDMA Technologies MSM K3571-Z


I am trying to get smstools up & running on the setup mentioned above, with the config file listed below:



This happens when I try to send a message:


The modem works on a windows machine and while connected on the Ubuntu PC I get the occasionally blinking blue light which should mean it's registered on the network. Also if I call the sim number inside modem it rings.

What should I do next? where could the problem be?


« Last edit by prxbl on Fri Sep 01, 2017 13:42, 2 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could try different baudrates, and the setting rtscts = no if it helps.

Have you tested the modem with some other program, like Minicom?

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.