SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Jun 24, 2024 13:10
SMSTools3 Community » Help and support Bottom

GSM Modem not sending anymore / chip doesn't work on phone

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Nov 2017
Location: CABA, Argentina
Linux Ubuntu Server 16.04:
Smstools 3:
Smsd installed from: package repository
Modem Huawei E1756:
Interface:USB

Hello everybody! It's my first post, sorry if I am missing something I should be pointing.

The fact is I have been dealing with the 500 error while sending messages. Modem receives and works fine but the point is this:
I have to start with a new chip, make it available and then it starts working. In a couple of days it doesn't send messages anymore.
I have tried restarting the service, and if I put the chip in a phone it doesnt send messages either.
There is no problem about the credit.

Any ideas will be preciated.

Thanks in advance.

I added a copy of .conf and .log files.



//////////////////////////// SMSD.CONF /////////////////////////////////////////////////////

#
# /etc/smsd.conf
#
# Description: Main configuration file for the smsd
#

devices = GSM1
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
logfile = /var/log/smstools/smsd.log
infofile = /var/run/smstools/smsd.working
pidfile = /var/run/smstools/smsd.pid
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
stats = /var/log/smstools/smsd_stats
loglevel = 7
#delaytime = 10
#errorsleeptime = 10
#blocktime = 3600
#stats = /var/log/smsd_stats
#stats_interval = 3600
#stats_no_zeroes = no
#checkhandler = /usr/local/bin/smscheck
# receive_before_send = yes
# autosplit 0=no 1=yes 2=with text numbers 3=concatenated
# autosplit = 3
# store_received_pdu 0=no, 1=unsupported, 2=unsupported and 8bit, 3=all
# store_received_pdu = 3
#validity = 255
#decode_unicode_text = no
#internal_combine = no
# You can specify here an external program that is started whenever an alarm occurs.
# alarmhandler = /path/to/an/alarmhandler/script
# Specifies what levels start an alarmhandler. You can use value between 2 and 5.
# alarmlevel = 4
# eventhandler = @EVENTHANDLER@
#blacklist = /etc/smstools/blacklist
#whitelist = /etc/smstools/whitelist

#[queues]
# Commented lines are examples for germany
# D1 = /var/spool/sms/D1
# D2 = /var/spool/sms/D2
# O2 = /var/spool/sms/O2
# EPLUS = /var/spool/sms/EPLUS
# QUAM = /var/sppol/sms/QUAM
# MOBILCOM = /var/spool/sms/MOBILCOM
#OTHER = /var/spool/sms/OTHER

#[provider]
# Commented lines are examples for germany
# D1 = 49160, 49170, 49171, 49175, 49151
# D2 = 491520, 49162, 49172, 49173, 49174
# O2 = 49176, 49179, 49159
# EPLUS = 49163, 49177, 49178, 49157
# QUAM = 49150
# MOBILCOM = 49156
#OTHER = 0,1,2,3,4,5,6,7,8,9

[GSM1]
device = /dev/ttyUSB0
init = AT+CPMS="SM","SM","SM"
#init = AT+CPMS="ME","ME","ME"
incoming = yes
#mode=new
baudrate = 19200
# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0
#device = /dev/ttyUSB0
# incoming = yes
# queues = OTHER
# You don't need a PIN for mobile phones
# pin = 1234
# mode = new
smsc = 541131703035
# baudrate = 19200
# rtscts = yes
# hangup_incoming_call=yes
# check_network=0
# cs_convert = yes
# report = no
memory_start = 1
# primary_memory = memory name


////////////////////////////// LOG ////////////////////////////////////////
2017-11-23 17:29:32,7, GSM1: -> AT+CMGS=33
2017-11-23 17:29:32,7, GSM1: Command is sent, waiting for the answer
2017-11-23 17:29:32,7, GSM1: <- >
2017-11-23 17:29:32,7, GSM1: -> 0011000C9145111319XXXX0000FF15E6343E2683CD6133585BA552B963B5198C0603
2017-11-23 17:29:32,7, GSM1: Command is sent, waiting for the answer
2017-11-23 17:30:02,7, GSM1: <- +CMS ERROR: 500 (Unknown error)
2017-11-23 17:30:02,3, GSM1: The modem answer was not OK: +CMS ERROR: 500 (Unknown error)
2017-11-23 17:30:02,5, GSM1: Waiting 10 sec. before retrying
2017-11-23 17:30:12,6, GSM1: Checking if modem is ready
2017-11-23 17:30:13,7, GSM1: -> AT
2017-11-23 17:30:13,7, GSM1: Command is sent, waiting for the answer
2017-11-23 17:30:13,7, GSM1: <- OK
2017-11-23 17:30:13,6, GSM1: Pre-initializing modem
2017-11-23 17:30:13,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2017-11-23 17:30:13,7, GSM1: Command is sent, waiting for the answer
2017-11-23 17:30:13,7, GSM1: <- OK
2017-11-23 17:30:13,6, GSM1: Initializing modem

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
juliogdiaz wrote
I have to start with a new chip, make it available and then it starts working. In a couple of days it doesn't send messages anymore.
I have tried restarting the service, and if I put the chip in a phone it doesnt send messages either.
There is no problem about the credit.

When you have this SIM in your phone, can you make a call with it? If it's prepaid SIM, perhaps the call says something interesting?

Probably the SIM got broken, or telephone company in Argentina detected the M2M communication and blocked the SIM. I have no other idea.

Member
Registered:
Nov 2017
Location: CABA, Argentina
Topic owner
Chip is working fine for talking.

The problem is for sending sms.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.