SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Oct 30, 2020 03:52
SMSTools3 Community » Help and support Bottom

Can send but cannot receive SMS with Huawei MS2131i-8

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Mar 2019
Location: France
OpenWrt 18.06.1 r7258-5eb055306f :
smstools3 - 3.1.21-2:
Smsd installed from: package repository
Modem Huawei MS2131i-8:
Interface: USB
Platform: Raspberry Pi 3B
Huawei MS2131i-8 AT Commands Specifications: ftp://www.eurocomposant.fr/huawei/MS2131/HUAWEI_MS2131_AT_Command_Interface_Specification(V200R001,%20English).pdf


Hi,

I'm struggling for a while trying to receive SMS with the Huawei MS2131i-8 usb modem. I have tried many suggestions found with Google, including a couple similar posts on this support forum. I had no problems with sending. Any help would be appreciated, so many thanks by advance.

Here we go with the data, the lines after "## End of device details" appear when I send an SMS to the device. Thanks gain for any tip I could work on.

# GLOBAL SETTINGS

devices = MS2131

sent = /var/spool/sms/sent
failed = /var/spool/sms/failed
checked = /var/spool/sms/checked
outgoing = /var/spool/sms/outgoing
incoming = /var/spool/sms/incoming

loglevel = 5
#loglevel = 7
logfile = /var/log/smsd.log
infofile = /tmp/smsd.working
#stats = /var/log/sms/stats.d

autosplit = 3
incoming_utf8 = yes
receive_before_send = no
hangup_incoming_call = yes
eventhandler = /root/test/sms_test.sh

# MODEM SETTINGS
# Huawei MS2131i-8
[MS2131]
init = AT+CPMS="ME","ME","ME"
#init = AT+CPMS="SM","SM","SM"
device = /dev/ttyUSB2
#pin = 1234
incoming = yes
memory_start = 0
baudrate = 115200
report_device_details = yes
#detect_unexpected_input = no
 
 
'smsdconf' Syntax Highlight powered by GeSHi




Member
Registered:
Mar 2019
Location: France
Topic owner
Replying to myself.

The issue is not solved yet, but it looks like the SMS are received but don't get moved to /var/spool/sms/incoming/.

Open the modem in communication mode, then send 2 SMS:



But /var/spool/sms/incoming/ remains empty :(

I'm comfortable with Unix and Linux, but new to this communication stuff. So, any help will be highly appreciated. Thanks a lot.

Member
Registered:
Mar 2019
Location: France
Topic owner
Replying to myself again. I will mark this post as "solved" because in fact the SMS are received: the exact problem seems to be that they aren't moved to the /var/spool/sms/incoming/ directory. And they are not handled by the eventhandler script neither. So, I mark this issue as "solved" and I open a new one about the file move not being done. Hope all this stuff will contribute to help someone in the future.



Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.