SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 20:14
SMSTools3 Community » Help and support Bottom

[solved] + CMS ERROR: 38 (Network out of order)

  This topic is locked

Page:  1

Author Post
Member
Registered:
Oct 2009
Location: Bauru, Brazil
Good afternoon

I am Brazilian, sorry for the English ...

I'm trying to configure the SMS3 to send sms, I am using win 2003 with cygwin, installation was sucessedida and apparently everything is correct.

The modem is connected properly with a SIM card, the incoming SMS are being lowered by the system correctly, but when I try to send a SMS I get an error + CMS ERROR: 38 (Network out of order), what may be happening is wrong?

Some example file smsd.conf to resolve this situation?

Another test was done using the SIM card in phone and even sent a message without problems, I believe the problem is in configuration (smsd.conf).

Thanks

Att

Paul Comora

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
First, I assume that you are using the latest version (3.1.5) of smsd, right? Also, in many cases it is useful to know what type and model of a modem is used.

You could try to define smsc = <number of Service Center> in the modem section of smsd.conf. Store this number using international format and without the + sign. For example the format is: smsc = 358447654321.

After any change to the configuration, restart the daemon. When running on Windows, you should locate the script sms3 in the scripts directory, and copy it to some place from where you do want to use it. The installation script said that too, because on Cygwin it cannot locate any destination like on *nix systems.

Member
Registered:
Oct 2009
Location: Bauru, Brazil
Topic owner
After making the changes indicated it did not work, still the same error, I sent my smsd.conf and the words of the file. Log:

SMSD.CONF

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
autosplit = 3

[GSM1]
init = AT+CNMI=2,0,0,2,1
#init = ATE0+CPMS="SM"+CNMI=2,0,0,2,1
device = /dev/com1
incoming = yes
#queues = OTHER
#pin = 1010
pin = ignore
#mode = new
smsc = 551481676710
baudrate = 9600
'smsdconf' Syntax Highlight powered by GeSHi


SMSD.LOG



PDU:
Hidden private text.




« Last edit by keke on Tue Oct 06, 2009 09:32, 177 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You are using national format of a destination number. By default, international format should always be used.

With smsd 3.1.5 you can use the header To_TOA: National with national numbers, but it's not recommended because delivery reports will use international format anyways.

You have also a conflict with .LOCK file. This is because you are using the same name of an outgoing message file, and previous file was not yet sent. Usually a random unique filename should be created, but you can also define in the smsd.conf: keep_filename = no. With this setting an unique filename is created each time when a message file is moved from directory to another directory.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.