Operating system name and version: Debian Linux 10
Version of smsd: 3.1.21
Smsd installed from: package repository
Name and model of a modem / phone: USB730L
Interface: USB

I have been able to get this modem to receive text, after some effort. First issue is smstools reported the SIM as "denied":

+CREG: 2,3 OK

I set:
check_network = 0

in /etc/smsd.conf and am able to send text messages as expected.

However, I have been unable to receive messages and have sent at least 4. If I plug the modem into a Windows computer and connect to the embedded webserver you can see the messages have been received.

The smsd.log file shows:

2020-09-17 09:10:17,7, GSM1: -> AT+CPMS?
2020-09-17 09:10:17,7, GSM1: Command is sent, waiting for the answer. (5)
2020-09-17 09:10:17,7, GSM1: <- +CPMS: "ME",0,23,"ME",0,23,"SM",0,0 OK
2020-09-17 09:10:17,6, GSM1: Used memory is 0 of 23
2020-09-17 09:10:17,6, GSM1: No SMS received

If I turn-off smstools and use minicom and send a text message, the following will appear:

$QCMTI: ,0

If I understand correctly, this means a message was received but the memory location is blank. If I immediate run CPMS? I get:

+CPMS: "SM",0,0,"SM",0,0,"SM",0,0

I did read the FAQ and I have tried both the AT+CPMS="SM" and AT+CPMS="ME" and I get the same result.

Any other suggestions?