SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu May 19, 2022 23:58
SMSTools3 Community » Help and support Bottom

Foxbox SMS delivery report

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2021
Location: Belgium
Operating system name and version: Linux foxbox 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64
Version of smsd: Version 3.1.21
Smsd installed from: built in with distro
Name and model of a modem / phone: FoxBox 8Pool https://www.smsfoxbox.it/en/foxbox-8pool.html/
Interface: USB

Hello,

I have a Foxbox GT2 and a Foxbox 8 Pool modems.
I'd like to activate sms delivery report but just adding "report = yes" in smsd.conf doesn't help.

I've try to do the following guide from Foxbox support but I have the following error "Modem did not accept the init string".
https://www.smsfoxbox.it/sms_foxbox_documentation/doku.php/delivery_notifications?s[]=delivery

Can you help me please ?

Thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Add the line report_device_details = yes to the global part of the configuration. Restart smsd and show the log of those lines here. Also show the modem part of smsd.conf.

It would also be useful if you had a modem manual that tells you what the parameters of the CNMI command are, because these are often different with different modems.

Member
Registered:
Apr 2021
Location: Belgium
Topic owner
I'm focusing on GSM2 so here is the conf and the log.

[GSM2]
device = /dev/ttyACM1
report = yes
#uncomment these 3 lines if report yes
#using_routed_status_report = yes
#detect_message_routing = yes
#routed_status_report_cnma = no
signal_quality_ber_ignore = yes
sending_disabled = no
memory_start = 0
send_delay = 0
check_network = 0
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 60
#regular_run_cmd = AT+CSQ
regular_run_logfile = /var/ramlog/smsd_run_GSM2.log
regular_run_loglevel = 7
#init=AT
#init = at+cmms=2
pin = ignore
status_signal_quality = no
detect_unexpected_input = yes
pre_init = no
incoming = 2
mode = new
queues = ALL,GSM2
baudrate = 115200
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
eventhandler = /etc/sms/scripts/eventhandlerGSM2
report_device_details = yes
 
 
'smsdconf' Syntax Highlight powered by GeSHi





Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Try with this:

init = AT+CNMI=2,1,0,1,0

Member
Registered:
Apr 2021
Location: Belgium
Topic owner
Same error : "GSM2: Modem did not accept the init string"

[GSM2]
device = /dev/ttyACM1
report = yes
#uncomment these 3 lines if report yes
#using_routed_status_report = yes
#detect_message_routing = yes
routed_status_report_cnma = no
signal_quality_ber_ignore = yes
sending_disabled = no
memory_start = 0
send_delay = 0
check_network = 0
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 60
#regular_run_cmd = AT+CSQ
regular_run_logfile = /var/ramlog/smsd_run_GSM2.log
regular_run_loglevel = 7
#init=AT
#init = at+cmms=2
pin = ignore
status_signal_quality = no
detect_unexpected_input = yes
pre_init = no
incoming = 2
mode = new
queues = ALL,GSM2
baudrate = 115200
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
eventhandler = /etc/sms/scripts/eventhandlerGSM2
report_device_details = yes
init = AT+CNMI=2,1,0,1,0
 
 
'smsdconf' Syntax Highlight powered by GeSHi


Member
Registered:
Apr 2021
Location: Belgium
Topic owner
Any other suggestions ?

Thanks

Member
Registered:
Apr 2021
Location: Belgium
Topic owner
I found out it seems to work (sometimes) with this line.

init = AT+CNMI=1,2,2,1,0
'smsdconf' Syntax Highlight powered by GeSHi


But I have logs with the message "2021-05-04 13:37:27.283,3, GSM1: Saved routed status report for later handling. However, you MUST DISABLE status report routing with modem settings."

What do I have to change ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Setting using_routed_status_report = yes removes the notification when the routing procedure is forced to be used.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.