SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Jun 14, 2024 18:33
SMSTools3 Community » Help and support Bottom

Sometimes when I send sms, the sendsms program does not send SMS

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Oct 2021
Location: Kaz, Russian Federation
Operating system name and version: Linux
Version of smsd: 3.1.21
Smsd installed from: sources
Name and model of a modem / phone: Huawei E303
Interface: USB

Hello everyone!
Sometimes when I send sms, the sendsms program does not send SMS, but creates a file in the outgoing/ folder. The sending process is not displayed in the log. When smsd restarts, sms messages are sent immediately. How to fix it?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The only thing that comes to mind now would be that for some reason the .lock file was not deleted when the message was created. But at least the sensms included in the package does not use the .lock file at all.

Since this problem has apparently happened more than once, I would like to see a listing (ls -l) of the outgoing directory at the moment when the problem is on and smsd has not yet been restarted.

Also the full configuration (smsd.conf) would be useful to see.

If you want to limit the view of the data, you can do it with the Private tag.

Member
Registered:
Oct 2021
Location: Kaz, Russian Federation
Topic owner
My pc: banana pi zero m2
My OS: Linux armbian 5.15.48-sunxi #22.05.3 SMP Wed Jun 22 07:35:10 UTC 2022 armv7l GNU/Linux
All programs run as root.
My config file:
devices = E303
logfile = /var/log/smsd.log
log level = 7
phonecalls = /var/spool/sms/phonecalls

[E303]
device = /dev/ttyUSB1
baudrate = 115200
rtscts=no
init = at+cpms="sm","sm","sm"
memory_start = 1
#init = at+cpms="sm","sm","sm"
incoming = yes
incoming = high
hangup_incoming_call = yes
phonecalls = clip
eventhandler = /usr/local/sbin/smshandler
regular_run_cmd = AT+CUSD=1,"AA58ADA6828D1A",$
regular_run_interval = 86400
ussd_convert = 1
eventhandler_ussd = /usr/local/sbin/smshandler

I tried changing memory_start, storing sms from the sim card to the modem's memory, but that didn't help. I tried to change the modem to another model, but it did not help either. On Rasberian OS, these modems work correctly with sendsms.

During the use of armbian, I noticed the following:
1. Sometimes, right after rebooting the PC, the sendsms program puts a file in the ougoing/ directory and this file remains there. I don't see any errors in the smsd.log and dmesg logs. If you restart sms3, then the sms is immediately sent and it works correctly for several hours or a maximum of 1 day.
2. Sometimes, immediately after restarting the PC, the sendsms program works correctly, but after a few hours the files accumulate in the outboxing / folder and SMS is not sent. This is fixed by the sms3 restart command for a few hours.

I think that the smsd service at some point cannot access the files in the outboxing/ folder because the OS is blocking access to the files.
I changed the owner of the /var/spool/sms folder from root to root user. # chown -r $USER:$USER /var/spool/sms and it helped, for the second day the sendsms program has been working correctly, so I can’t send the result of the ls -l outgoing/ command now.
As the problem repeats, I will immediately send the result of ls -l.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.