SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Jun 14, 2024 19:43
SMSTools3 Community » Help and support Bottom

Unable to receive SMS on Siemens SG75

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Nov 2022
Location: Japan
Operating system name and version: Debian GNU/Linux 9 (stretch) (on Docker)
Version of smsd: Debian GNU/Linux 9 (stretch)
Smsd installed from: package repository
Name and model of a modem / phone: Siemens SG75
Interface: USB

Checking the led, the device seems connected to the Network, but from Linux it's unable to receive and process any SMS.
Putting the dongle on Windows, it's definitely fine.

Here is my config (the most relevant settings):


The "smsc" value has been taken from official Vodafone Italy documentation.

Here is smsd.log:


I have also installed and run "wvdial", ran it and added the following lines to smsd.conf:


But the result didn't change, here is the new smsd.log:


I have taken a look at this forum for similar issues but all the workarounds were not useful. There is an existing topic for the same device, but there are no updates so far. Is there someone successful with this GSM dongle?

Thanks in advance!

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Version of smsd: v3.1.15

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Please stop wvdial and any other processes that may be using the modem. Smstools must be the one and only process which uses the modem.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
keke wrote
Please stop wvdial and any other processes that may be using the modem. Smstools must be the one and only process which uses the modem.

Hello @keke, thank you for your update.
Well, I had installed "wvdial" only for the purpose of getting the values for "init", and as now the system is running in a Docker container it's basically just "smstools" and the OS :D :-)
Also it works with an HUAWEI E176 USB dongle, but as the device has some issue I am trying to switch to this new one.
Any help or suggestions will be very appreciated!

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Sorry guys, any idea/suggestions?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I don't have any new ideas for this.

The log you showed earlier shows some strange things. Smsd wants to make sure that the modem responds to the command AT, and receives a serial number in response. It is the answer to the AT+CGSN command that smsd sometimes asks, but not now. It seems that some other process is asking for the serial number at the same time, possibly another smsd that shouldn't be running at the same time. Then smsd does the initialization, the modem responds with the quality of the signal. The answer is clearly wrong. Then smsd asks about the quality of the signal and gets information about the memory locations of the modem. The same inconsistency is repeated many times in the logs you show.

It strongly seems that the modem is shared by too many processes, or Docker is somehow messing up the communication. All I can do is ask you to do a new test after you have made sure that the modem is not used by any other process (for example, another smsd).

You can also test the modem with the smsd communication feature. First kill all smsd processes and make sure they are killed. Then start smsd with smsd -C GSM0 and send an AT command to the modem. The answer should be OK and nothing else. Then wait with your hands in the air. If the modem reports various things even though they have not been asked in this terminal, it should be clear that there is some other process that is asking them somewhere.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
keke wrote
.....
It strongly seems that the modem is shared by too many processes, or Docker is somehow messing up the communication. All I can do is ask you to do a new test after you have made sure that the modem is not used by any other process (for example, another smsd).

You can also test the modem with the smsd communication feature. First kill all smsd processes and make sure they are killed. Then start smsd with smsd -C GSM0 and send an AT command to the modem. The answer should be OK and nothing else. Then wait with your hands in the air. If the modem reports various things even though they have not been asked in this terminal, it should be clear that there is some other process that is asking them somewhere.

Hello @keke,
First of all, thank you for your assistance. I have just proceeded as you have suggested, and here is the result:


After some minutes, no new lines have been added to the output, so I am assuming that no other process(es) are actually using the device.

Then, I have seen another post for the same device (with no updates) here:
http://smstools3.kekekasvi.com/topic.php?id=1620

At the issue is still ongoing, if there are no idea/suggestions for this, I am wondering to buy another modem but of course I'd prefer to keep this one if someone cal help!

Regards,

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Just posting the last content of smsd.log here:


If I run the same commands on smsd -C GSM0 I get similar results as below:


I will appreciate any suggestions here!

Regards,

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Other information:




Regards,

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Sorry for the additional update. After recreating the container (ideally with a newer Linux image) all the errors seems to be solved as below:


The issue now is that it doesn't receive receive (or process) any SMS that I have sent to the SIM card but there are no useful messages to troubleshoot the reason.
Then, adding the initialization strings (obtained by vwdial) to /etc/smsd.conf strings cause another issue:


Regards,

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Do NOT use vwdial style initialization because it sets the modem to data mode. Use AT+CPMS="SM","SM","SM". Make sure the modem is reset before trying to read the messages.

If you still have problems, show the report_device_details output too.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
keke wrote
Do NOT use vwdial style initialization because it sets the modem to data mode. Use AT+CPMS="SM","SM","SM". Make sure the modem is reset before trying to read the messages.

If you still have problems, show the report_device_details output too.

Hello @keke, thank you for your assistance.
Despite there are some few errors on the logs:



It seems working with the new initialization string!


I will keep monitoring for the next days, just in case.

Regards,

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Use also a modem setting memory_start = 0.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Sorry, what's the goal of that settings?

Member
Registered:
Nov 2022
Location: Japan
Topic owner
And where to set it?

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Nevermind, I have set memory_start = 0 to the correct section and I am monitoring the status.
Thanks again, @keke!

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Hello guys,

After 1 day, it seems there is an issue.
Specifically the device seems stuck to "Receiving" mode, but it doesn't receive any SMS.
Here are some detail:



And also the log file:


I had a similar issue with an Huawei E176 device. I suspected being related to the power on the USB, but I have noticed it on multiple servers (with and without Docker), and also using a powered USB Hub.
Restarting the service doesn't help always, as an HW reboot can fix it on most cases.

Any suggestions?

Regards,

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Again, it looks like more than one process is using the modem at the same time. Since you have already fixed a similar situation before, I hope you can fix it now as well. If the smsd startup method is different from the sms3 script, that might be the reason. It would be a good idea to check the log to see how the processes are started.

Your previous log showed that the modem responds with an error message to the command AT+CMGR=20. When there are 20 memory locations, and the number 20 gives "invalid memory index", most obviously the first location is the number 0. This is why a setting memory_start = 0 is required. And if you use a Huawei modem, they also start with the number zero.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Hello @keke,

Thank you for your support.
Indeed, you are correct, I have checked and there were multiple smsd services running.
Checking the logs, it seems that smsd it's getting automatic started every 2hours:



I don't really know why this happens (there is nothing on cron, etc.), but the behaviour is regular, so it's very suspicious. I am proceeding to recreate the container and raising loglevel to see if the logs can explain why this happens.
I think I can temporary fix it by setting a cron job to stop the service and kill all the PID of smsd by executing every 1h or less, but it would be tricky.

Again, any suggestions are more than welcome!

Regards,

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
That is, when you reboot the system, smsd works for some time without any problems. Later a message is received and then the problems begin.

Your event handler says: "Restarting SMSd service". Whatever is going on there, take it out. There is no need to restart smsd from within the script, nor should you do so.

Smsd should regularly check if there are any extra processes running, and stop if necessary. I don't know why it doesn't work in your case. Anyway, forget about stopping processes with cron, just remove starting new processes.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
keke wrote
That is, when you reboot the system, smsd works for some time without any problems. Later a message is received and then the problems begin.

Your event handler says: "Restarting SMSd service". Whatever is going on there, take it out. There is no need to restart smsd from within the script, nor should you do so.

Smsd should regularly check if there are any extra processes running, and stop if necessary. I don't know why it doesn't work in your case. Anyway, forget about stopping processes with cron, just remove starting new processes.

Well, the "Restarting SMSd service" is just the output of an echo I put in the event handler to eventually restart SMSd but I didn't put any command after so it's just a message.
Here is what is going on after some hours:







Very strange.... :|

Regards,

Member
Registered:
Nov 2022
Location: Japan
Topic owner
I think I have found the root cause.
Testing a workaround now.

Member
Registered:
Nov 2022
Location: Japan
Topic owner
Working with no issues for weeks!
Thank you for your assistance @keke, very appreciated

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.