SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 20:44
SMSTools3 Community » Help and support Bottom

[answered] Sending SMS with MTCBA-G-U-F2 multitech modem

  This topic is locked

Page:  1

Author Post
Member
Registered:
Oct 2009
Location: santiago, Dominican Republic
Hi! I have installed a debian kernel patch to use my multitech modem with etch4.
Now my question is what should I do to test my modem GSM?

Debian Etch with patched kernel
3.5
From source
Multitech modem MTCBA-G-U-F2 usb
USB

If somebody use this modem to send SMS please can you address me to rigth direction to continue with this.

Thks In Advance!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have not used this modem, but it seems that it's manual is listing all of the necessary AT commands. I think this modem should work fine.

First find out the port: connect the modem and use dmesg to see what port it is using. You will get something like this as an output:

[n.n] usb 2-2: new full speed USB device using uhci_hcd and address 4
[n.n] usb 2-2: configuration #1 chosen from 1 choice
[n.n] pl2303 2-2:1.0: pl2303 converter detected
[n.n] usb 2-2: pl2303 converter now attached to ttyUSB1


Next use this very simple configuration ( /etc/smsd.conf ) with the correct device name:

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/ttyUSB1
incoming = yes
report = yes

Then start the daemon using /etc/init.d/sms3 start. Using your handset, send a SMS to your server. You should see in the log how smsd is receiving a message and there should be message file in the /var/spool/sms/incoming folder.

Create a message file /var/spool/sms/outgoing/test1 with the following content:

To: number of your handset in international format

This is a test message.

You should receive a message into your handset. If a status report works without additional settings, smsd will receive it as a message file.

If something does not work, show the log file here.

Member
Registered:
Oct 2009
Location: santiago, Dominican Republic
Topic owner
I did everything as you said but it didnt work.
I sent a sms to my modem but it didnt appear in incoming folder but there were another sms past old.
I sent one sms but it never arrived.
I put a file SMS in outgoing folder and it disappear from this folder but the SMS didnt arrive never

The log is this


The server says that it sent the SMS but never come!!!


« Last edit by keke on Thu Oct 29, 2009 09:40, 177 months ago. »
Member
Registered:
Oct 2009
Location: santiago, Dominican Republic
Topic owner
I can receive SMS but I havent sent yet..!! :(

I wanna activate a script when a SMS arrive. I can do this in any place?

I wanna get the SMS incoming to save to my database and delete the file after

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
macaruchi wrote
I put a file SMS in outgoing folder and it disappear from this folder but the SMS didnt arrive never

The log does not contain information about sending. Probably the message was failed, you could show part of the log which contains details of sending.

macaruchi wrote
I can receive SMS but I havent sent yet..!! :(

Ok. The log shows normal, when nothing is received. Anyways, there was no errors shown which is good.

macaruchi wrote
I wanna activate a script when a SMS arrive. I can do this in any place?

I wanna get the SMS incoming to save to my database and delete the file after

You need to set up an eventhandler. In the global part of smsd.conf, define:
eventhandler = /usr/local/bin/smsd_eventhandler.sh

Create that script and make it executable for smsd.

Please view this post: Sample eventhandler to store messages into SQL database for more details.

In the eventhandler you can run any commands needed. Because the smsd does not touch the message file after eventhandler is executed, you can delete the message file using rm command.

There is also some sample eventhandler in the scripts directory of a package.

Member
Registered:
Oct 2009
Location: santiago, Dominican Republic
Topic owner
I could send the SMS today. ! Really , I dont know why yesterday didnt work. Maybe the network was slow becasue they come 2 hours lately.

I added a line to smsd.conf and I get an error. I added in global sections

failed = /var/spool/sms/failed

the log says command not reconigzed.


Can I do the eventhandler in other language different to bash. I use perl and PHP and I 'd like to do a few scripts in these languages. Cant I?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
macaruchi wrote
I could send the SMS today. ! Really , I dont know why yesterday didnt work. Maybe the network was slow becasue they come 2 hours lately.

From the log you can see how long it takes to send a message and if it is sent successfully or not. When a message is sent successfully, it's up to the GSM network how long it takes to deliver. Usually networks are fast, but sometimes there can be delays. Also, if a destination phone cannot be reached, a message is not delivered, of course.

macaruchi wrote
I added a line to smsd.conf and I get an error. I added in global sections

failed = /var/spool/sms/failed

the log says command not reconigzed.

Global "sections"? Did you create a section like "[global]"? That's not what to do. I wrote "global part", which means the top of a file, before any sections starting with [...

There is no "command not reconigzed" message. There is "Unknown global setting" or "Unknown setting for modem". Probably you got the second message?

The syntax of a command itself is correct and should work.

macaruchi wrote
Can I do the eventhandler in other language different to bash. I use perl and PHP and I 'd like to do a few scripts in these languages. Cant I?

Any language can be used, it's up to you.

Member
Registered:
Oct 2009
Location: santiago, Dominican Republic
Topic owner
U rigth!
was in thye global section. Fisrt part of the file and I get the second message

"Unknown setting for modem".

failed= /var/spool/sms/failed

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Not sure if I understood your answer :(

You still have this problem?

This kind of smsd.conf should work:

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7
failed = /var/spool/sms/failed

[GSM1]
device = /dev/ttyUSB0
incoming = yes

And, of course, the /var/spool/sms/failed directory must exists and must be writeable for smsd. If it's not, you will get another error message in startup.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.