SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 20:33
SMSTools3 Community » Help and support Bottom

[solved] Falcom Twist Serial - Not Clear to send / Put_command error

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2010
Location: Slovak Republic
Operating system: Linux 2.6.22
Version of smsd: 3.1-2+lenny1
Smsd installed from: debian lenny package repository
Name and model of a modem / phone: Falcom Twist Serial
Interface: serial - connected via RS232 <-> USB [PC side]


First we used this 2 modems successfuly. Then upgraded to smstools 3.1 but using USB Falcom modems. Now we need
also these 2 old modem [ serial ] but they have problem:

2010-01-27 11:49:06,7, MODEM_TMOBILE: put_command expected (OK)|(ERROR), timeout occurred.
2010-01-27 11:49:06,7, MODEM_TMOBILE: <-
2010-01-27 11:49:06,7, MODEM_TMOBILE: -> AT
2010-01-27 11:49:06,7, MODEM_TMOBILE: Command is sent, waiting for the answer

I've tried different baudrates, now config is:

init = ATE0
device = /dev/ttyMODEM_TMOBILE
incoming = yes
queues = SK_TMOBILE
pin = 1111
mode = new
#mode = ascii
smsc = 421903333000
baudrate = 19200
cs_convert = yes
report = yes
eventhandler = /usr/local/bin/smshandler.pl
rtscts = no



Thats all , thak you

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
With what version of smsd you used those old modems successfully? And was there the same USB-Serial adapter used, or was there a real RS-232 port?

Perhaps you could try with baudrate = 115200. In some cases adapters work better with this speed.

Member
Registered:
Jan 2010
Location: Slovak Republic
Topic owner
problem solved - it was my fault - thanx for prompt reply.
It was named usb mapping mis-match chaoss [ with UDEV ] so ... now both modems working OK

falcom is super - very reliable

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok.

Are you still running with rtscts = no setting? In general, the handshaking should be used if at all possible.

Member
Registered:
Jan 2010
Location: Slovak Republic
Topic owner
ok a set rtscts = yes and working ok ... thanx

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.