SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 21:36
SMSTools3 Community » Help and support Bottom

[solved] SE M600i can not receive message

  This topic is locked

Page:  1

Author Post
Member
Registered:
Mar 2010
Location: depok, Indonesia
Operating system name and version: WinXP SP2
Version of smsd: 3.1.6
Smsd installed from: sources
Name and model of a modem / phone: SE M600i
Interface: USB

SE M600i cannot receive messages there is error like this:



I was read from FAQ that some SE with SymbianOS cannot received msg. So I try other way with send cmd at+cmgl work and can list some messages, but i don't know how to convert PDU to text.

Any Idea, please help. Thanks :)
-alfin-

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
SE M600i is based on Symbian OS v9.1 and may work, as it's listing it's memory like +CPMS: "ME",1,512,"ME",1,512,"ME",1,512. Devices based on S40 (3rd edition) or S60 are listing +CPMS: ,,,,,,,, and do not work.

In your case there is one message, but index 1 gives an error. You could try a modem setting memory_start = 0.

As the command AT+CMGL works, you could try to use check_memory_method = 31. With this setting smsd will get all messages directly from the CMGL list. You do not have to take care about the PDU's. If this method works with your device, it's better than default method and memory_start = 0 is not required.

Member
Registered:
Mar 2010
Location: depok, Indonesia
Topic owner
that works... thanks keke :)

i adds check_memory_method = 31 and cmgl_value = 0 for control incoming msg that only new msg are copied.

this is my smsd.conf :


Member
Registered:
Mar 2010
Location: depok, Indonesia
Topic owner
sorry ask again :)

How to keep msg in memory phone? in some projects maybe need this. Because value in check_memory_method that support cmgl (3, 4, 31, 41, 5) are deleted message after it is read.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
There is a global setting keep_messages = yes available. But it's for testing purposes only and smsd will stop after messages are read.

You could modify the sources, if you want that smsd does not delete messages, but continues running. I may include this kind of setting to the next version too.

Member
Registered:
Mar 2010
Location: depok, Indonesia
Topic owner
thanks keke :)
let smstools3 efflorescent step by step

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
In the 3.1.7beta2 there is now a modem setting keep_messages = yes which works as you expected.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.