SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 21:54
SMSTools3 Community » Help and support Bottom

[answered] Modem tag is not working

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2010
Location: Portugal
Hello.

I created an SMS message with the line:

Modem: GSM2

I was expecting that this message be sent via modem GSM2. However, it is sent via modem GSM1 and the message I receive is "encrypted". GSM2 is configured on smsd.conf but the modem is offline (on purpose).

Is it a bug, or am I doing anything wrong?

Best regards,
Carlos

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Carlos wrote
I created an SMS message with the line:

Modem: GSM2

I was expecting that this message be sent via modem GSM2.

Smsd does not read Modem header from outgoing file. When a message is sent, there is a Modem header which tells what modem was used for sending, but it's a different thing.

Modem should be selected using Provider or Queue header. Both do the same.

First you need to define queues. In your case provider sorting is not required, so the configuration can be like:

[queues]
GSM1 = /var/spool/sms/GSM1
GSM2 = /var/spool/sms/GSM2

[providers]
GSM1 = 0,1,2,3,4,5,6,7,8,9,s
GSM2 = 0

Create those folders and make them writable for smsd.

In the modem sections of smsd.conf, define:

[GSM1]
queues = GSM1

[GSM2]
queues = GSM2

With these definitions all outgoing messages are targeted to GSM1 because it's provider list will match with all destination numbers. If you want to send some SMS using GSM2, just include Queue: ( or Provider: ) header in it, for example:

To: 358401234567
Queue: GSM2

This is a test message from Smstools3.


You can define multiple queues, but remember that any queue will need it's own directory. One modem can serve more than one queue and the same queue can be served by multiple modems. I have not included outgoing Modem header in the smsd, just because it would not be sufficient, queue must still be defined.

Carlos wrote
However, it is sent via modem GSM1 and the message I receive is "encrypted".

You could show your setup and what you sent, as well as what you received. Perhaps you have troubles with portuguese characters? What is the version of smsd you are running?


« Last edit by keke on Wed Apr 14, 2010 19:22, 171 months ago. »
Member
Registered:
Apr 2010
Location: Portugal
Topic owner
Hello.

In my configuration I have 2 modems (GSM1 and GSM2). If I don't configure queues/providers, when I send a large number of messages, both modems are used to send those messages (if sending is enable on both).
If I configure queues how do I do that? I saw a script that does some king of load balance. However it does not check if the modem is enable...

Best regards,
Carlos

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Carlos wrote
In my configuration I have 2 modems (GSM1 and GSM2). If I don't configure queues/providers, when I send a large number of messages, both modems are used to send those messages (if sending is enable on both).
If I configure queues how do I do that?

As said, one modem can serve more than one queue and the same queue can be served by multiple modems. (fixed that typo in the previous post, should be "can be served", not "can be server"... :( )

You could define:


[queues]
ALL_MODEMS = /var/spool/sms/all_modems
GSM1 = /var/spool/sms/GSM1
GSM2 = /var/spool/sms/GSM2

[providers]
ALL_MODEMS = 0,1,2,3,4,5,6,7,8,9,s
GSM1 = 0
GSM2 = 0

Modems can serve queues like this:


[GSM1]
queues = ALL_MODEMS, GSM1

[GSM2]
queues = GSM2, ALL_MODEMS

The order of definition of queues is just an example. With this setup, all messages without Provider (or Queue) header are placed into the ALL_MODEMS queue. Accordingly, messages with Provider: GSM1 are placed into the queue GSM1 and messages with Provider: GSM2 are placed into the queue GSM2.

The modem GSM1 will serve the queue ALL_MODEMS first. After there are no more messages to send, it will serve the queue GSM1. From this queue GSM1, only GSM1 can send messages.

The modem GSM2 will serve the queue GSM2 first. And after it's empty, GSM2 will serve the queue ALL_MODEMS.


Disabling sending in the setup causes troubles. Instead of disabling the sending, the setup should be modified or the modem should be removed from the devices list. Usually this has not been a problem, because all modems have been used for messaging. If you disable sending for GSM2, but still target messages to it, smsd cannot do very much...

Carlos wrote
I saw a script that does some king of load balance. However it does not check if the modem is enable...

If you disable or remove some modems from the setup, you should change the script...

keke wrote
Carlos wrote
However, it is sent via modem GSM1 and the message I receive is "encrypted".

You could show your setup and what you sent, as well as what you received. Perhaps you have troubles with portuguese characters? What is the version of smsd you are running?

Is this issue still active?

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.