SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 20:32
SMSTools3 Community » Help and support Bottom

[solved] TC35: serial port access

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2010
Location: Germany
Operating system name and version: HP ProLiant / Debain Lenny
Version of smsd: 3.1
Smsd installed from: debian repository
Name and model of a modem / phone: Siemens TC35
Interface: serial

Hello,

I have a problem accessing the TC35 via serial port on Debian Lenny. However, I am able to access the modem on Windows via Hyperterminal and send SMS sucessfully with the same serial cable. Hence, the problem has to be Linux configuration related.
I suspect that the serial port configuration is broken and I have to admit that I am a Linux novice and just followed several tips on the internet to solve the problem. I am aware that my question is a bit off topic, but after trying for a long time I would appreciate any help.

I tried the tips here to check if the modem is connected http://axion.physics.ubc.ca/modem-chk.html but no modems got recognized.

Also, I tried to access the modem via minicom but there is no reaction from the modem (I type some characters in but they do not appear in minicom though minicom says "connected").

The /dev/ttyS0|1 is readable and writeable.







Thanks!
Erik

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have to say that I do not know how to resolve this problem. :(

As you have tried both ports with smsd and with minicom, the baudrate could be changed if it was different when testing with Hyperterminal.

I'm running Ubuntu on HP ProLiant ML110 and there was no problem with a serial modem:







Erik wrote
Also, I tried to access the modem via minicom but there is no reaction from the modem (I type some characters in but they do not appear in minicom though minicom says "connected").

Perhaps you could try to type ATE1 (and Enter), if there is "echo off" in the modem. But if you type just something (and Enter), the modem should answer ERROR. Or if you type AT, the answer should be OK. However, I do not think that this helps...

Member
Registered:
Apr 2010
Location: Germany
Topic owner
SOLVED.

I did a complete reset of the BIOS as well as the iLo2 configuration to factory settings.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.