SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:43
SMSTools3 Community » Help and support Bottom

[outdated] Connecting Modem ONDA N101E

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2010
Location: Verona, Italy
Operating system name and version: Debian
Version of smsd: 3.1.6
Smsd installed from: sources
Name and model of a modem / phone: ONDA N101E
Interface: USB

Hi I'm new of this site and I would like to say hallo to all!
Next, here my question: I have to connect my USB Modem ONDA N101E to my machine, for receiving SMS. When I connect it to the USB port, dmesg says:



Next, I configure the device to smsd.conf file:

[GSM1]
device = /dev/ttyUSB0
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 300
#regular_run_cmd = AT+CSQ?
regular_run_logfile = /var/log/smsd_run.log
#regular_run_loglevel = 7
#init=AT
#SPECIFY INCOMING PRIORITY 0 disable 1 low 2 High
incoming = 2
queues = master
baudrate = 115200
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
#NEVER EDIT UNDER THIS LINE
eventhandler = /etc/sms/scripts/eventhandler
'smsdconf' Syntax Highlight powered by GeSHi


Then I restart smsd daemon, and when I receive a SMS to that device, I read these lines on smsd.log file:



What can I do to configure my modem?
Have I to change the smsd.conf file?

Thanks in advance
Bye


« Last edit by keke on Mon May 03, 2010 14:50, 171 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The version of your smsd is not 3.0, it's at least 3.1.5, right?


That kind of a device should just work without any special settings required. You could try with a different baudrate, like 19200, if it makes any difference.

PPAAOOLLOO wrote
Then I restart smsd daemon, and when I receive a SMS to that device, I read these lines on smsd.log file:

Do you mean that all of the communication is ok after starting the smsd (using loglevel = 7), but when a message is received, the modem stops answering? This sounds strange, and may mean that your device is somehow broken, or has a bad firmware.

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi. Thanks for your help.
I attached the device once again, and dmesg says:



Next I set the log level to 7, and baudrate to 19200. That's what log files says when I start smsd:



What can I do? Thanks a lot

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Try with baudrate = 230400. If it does not help. I do not know what to do... :(

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Great! It works!!!!!!!
Thanks thanks thanks!

Now I try with something more difficult: connecting more than 1 ONDA N101E!
I have a Hub USB that allows me to connect up to 7 usb using only 1 usb port. It's the "D-LINK DUB-H7 USB 2.0 Hub".
Do you think that I will do it? Stay tuned! :D

Thanks a lot ...

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi. I tryed to connect more than 1 ONDA N101E, and when I try to connect 4 modem it says:



How can I fix it?
Thanks in advance
Best Regards

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You have not changed the src/Makefile? There is a NUMBER_OF_MODEMS setting which defaults to 64.

What is your devices setting? Is it like devices = GSM1, GSM2, GSM3, GSM4 ?

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
No, I have not changed it. Where can I find that file?
And Yes, My devices are sets like GSM1, GSM2, GSM3 and GSM4.

Thanks a lot
Bye

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Sorry, Let me explain about src/Makefile:

I have not compiled the SmsTools3, a friend of mine compiled it (and I don't know if he used the options NUMBER_OF_MODEMS). Have I to re-compile it using the properties NUMBER_OF_MODEMS=64?
Thanks in advance
Best regards

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
PPAAOOLLOO wrote
I have not compiled the SmsTools3, a friend of mine compiled it (and I don't know if he used the options NUMBER_OF_MODEMS). Have I to re-compile it using the properties NUMBER_OF_MODEMS=64?

If that was changed, you have to change it back or bigger and then recompile.

Sources are under /usr/local/src directory, or somewhere else. If you cannot locate where the sources are, download a new package or ask from your friend. ;)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Is your system working now?

If the sources are still lost, you can find them with a command updatedb; locate -b '\smsd.c' ...

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi. I have re-compiled it, and I have a new error message that block smsd daemon.
I have try to connect a 4th modem, and it is well connected to ttyUSB2. So the situation on my machine is this:

1 internal modem mounted on ttyS1
1 external modem Falcom Twist mounted on ttyUSB0
1 external modem ONDA N101E mounted on ttyUSB1
1 external modem ONDA N101E mounted on ttyUSB2

When I try to configure 4 modem on smsd.conf, the daemon smsd does't start. It says:



I try to use only 3 modems and it works (both with ttyS1-ttyUSB0-ttyUSB1 or ttyS1-ttyUSB0-ttyUSB2). I try to connect the modem ttyUSB1 on ttyUSB2 (and viceversa) and works only with 3 modems (it does'nt work when in smsd.conf I write to work with 4 modem).

What can I do? Where can be the problem?

Here is the smsd.conf file:

devices = GSM1,GSM2,GSM3,GSM4
logfile = /var/log/smsd.log
loglevel = 5
internal_combine = yes
outgoing = /mnt/flash/spool/outgoing
incoming = /mnt/flash/spool/incoming
sent = /mnt/flash/spool/sent
failed=/mnt/flash/spool/failed
mypath = /mnt/flash/etc/sms/
autosplit = 3
blocktime = 3
errorsleeptime = 3

[GSM1]
device = /dev/ttyS1
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 300
regular_run_cmd = AT+CSQ?
regular_run_logfile = /var/log/smsd_run_1.log
incoming = 2
queues = master
baudrate = 115200
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes

eventhandler = /etc/sms/scripts/eventhandler

[GSM2]
device = /dev/ttyUSB0
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 300
regular_run_cmd = AT+CSQ
regular_run_logfile = /var/log/smsd_run_2.log
incoming = 2
queues = master
baudrate = 115200
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
eventhandler = /etc/sms/scripts/eventhandler

[GSM3]
device = /dev/ttyUSB1
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 300
regular_run_cmd = AT+CSQ
regular_run_logfile = /var/log/smsd_run_3.log
incoming = 2
queues = master
baudrate = 230400
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
eventhandler = /etc/sms/scripts/eventhandler

[GSM4]
device = /dev/ttyUSB2
voicecall_hangup_ath = yes
hangup_incoming_call = yes
voicecall_ignore_modem_response = yes
regular_run_interval = 300
regular_run_cmd = AT+CSQ
regular_run_logfile = /var/log/smsd_run_4.log
incoming = 2
queues = master
baudrate = 230400
rtscts = yes
cs_convert = yes
decode_unicode_text = yes
internal_combine = yes
eventhandler = /etc/sms/scripts/eventhandler

[queues]
master = /mnt/flash/queues/master
[provider]

master = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9
 
'smsdconf' Syntax Highlight powered by GeSHi


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
PPAAOOLLOO wrote
*ERROR: smsdaemon failed to start

There is no that kind of a message by the package. How do you start the smsd and are you using the sms3 script?

The smsd.log should contain information about the failure, what is in there?

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.