SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 12:11
SMSTools3 Community » Help and support Bottom

[outdated] read_timeout doesnt work

  This topic is locked

Page:  1

Author Post
Member
Registered:
Mar 2010
Location: Mexico
Operating system name and version: Windows XP
Version of smsd: 3.1.6
Smsd installed from: sources
Name and model of a modem / phone: Sierra 885
Interface: USB

Hello everyone!

I have a high volume server and i encountered a problem that i dont know how to solve, there are sometimes when the modem (any modem, its really random) will try and send a sms but the smsd will say (in the log) "Command sent, waiting for answer" and then it just sits there for ever (until I restart the whole smsd daemon actually), I have in the config of each modem the parameter read_timeout = 6, but seems like the server its ignoring it, and I also have regular_cmd = AT, but after the modem gets stuck in waiting for answer the AT command it's not being sent to the modem anymore

Note: regular_cmd = AT, i have this just for testing issues.

Any ideas how can I overcome this issue??

Thanks in advance

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Okay, you have found the reason for your "performance issue"...

The setting read_timeout defines how long smsd will wait if there is no expected answer received from the modem. In your case the problem is that the device driver freezes for some reason. Because it does not return, smsd cannot continue and cannot check the timeout.

As you are running smsd on Windows XP, are you sure that there is no any other process which may use modem ports? Other process could cause this kind of problem.

Member
Registered:
Mar 2010
Location: Mexico
Topic owner
Im possitive about no other process using the drivers, and the weird thing is that it happens randomly from modem to modem and if i dont kill the smsd all of the modems will eventually get into that dumb state :(

I was thinking on a possible solution, like when the main smsd process detects if any modem its not working properly to reset only that modem but i cant figure out how to do that, and i am not good at coding in C.

I havent seen anyone else having this issue, and i think thats weird, or maybe part of my configuration or server is causing this, any clues on how to address this?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could try a modem setting keep_open = no, but I think that it will not help because you have a serious problem with your serial port driver.

There are systems which are running on Cygwin without any problems. In your case, I do not know how to fix this problem. Perhaps you could check the version of Cygwin and re-install it. Also, as you are running a medium-sized setup, you could consider to move to the GNU/Linux.

The smsd could be changed to check the status of modems, but it cannot restart just one modem process. Usually monitoring is done using an external process and in the case of a failure whole smsd is restarted. With the script sms3 this is safe and takes not too much time. If you define stats directory, you will get a status file which contains a timestamp for all modems. Your external process can check that timestamp and restart smsd if the timestamp for some modem is too old.

Member
Registered:
Mar 2010
Location: Mexico
Topic owner
Thanks for the replies

But indeed the

, does not help my problem, i tried reinstalling the whole cygwin but it didnt help, i might try a fresh XP install or Windows 7 perhaps, unfortunately linux its not an option at this time =(, i would do it but i didn't got clearance from above *gets angry*

Has anyone else had this issue before, that a modem stucks at sending and never answer again?

Any clues how to fix it?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have no clues for fixing, but you could test your hardware and modems using Live GNU/Linux:

- Download Ubuntu image and burn the CD.
- Start your computer from this CD with no modems connected.
- There are options "try" and "install". Choose "try".
- Open a Terminal.
- Become a root: sudo su
- Install smstools: apt-get install smstools
- Stop it if it tried to run: /etc/init.d/smstools stop
- Connect modems.
- Wait a little bit, and use dmesg to see what are the ports.
- Edit the /etc/smsd.conf and start the daemon.

From the /var/log/smstools/smsd.log you can see how the system is running.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Have you found any solution for this freezing? Re-installing drivers or Cygwin, replacing hardware, or anything?

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.