SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu May 23, 2024 02:42
SMSTools3 Community » Help and support Bottom

[fixed in 3.1.9] Cannot receive SMS from Huawei E620 GPRS Modem

  This topic is locked

Page:  Previous  1  2

Author Post
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have shortened your log...

You could set log_unmodified = no, or remove the line. Those linebreaks are not needed anymore.

You should also change "E1" to "E0", or remove it from the init2 setting. Actually I think that your init settings are not required. You could try without any init or init2 settings.

Your message got CMS 500 from the network. This error is undefined. Later the modem has dropped from the network, which may mean that there has been some network failure or service break. You could try again later.

If you still cannot send SMS, move to the previous version of smsd and retry. This will tell if the version makes any difference.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Still no luck with the latest version

I found this error in the log file:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
"Bit Error Rate: not known or not detectable" is not a bad failure. Because the signal strength is good, and the modem is registered to the network, sending should work.

Are you telling that there is a difference between versions of smsd? Have you checked that you can send with the previous version?

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Something is really wrong with

the modem or config

even the very first version cannot send any text messages.

I will try again later..

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Ok one good news. I can send messages again with 3.1.8 like last time. The problem is the SMSC number. I think, one of Singtel's smsc I used is not working for today (may be). I used the another smsc number and now it works.

I will try out with the new version again. I hope I can do both send and receive this time.

:)

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Sending SMS is fine with the latest version now. The problem is I can't receive messages.

When I reply from my phone, my phone show me error (Like: cannot be sent or red exclamation mark beside the message). Could this be the config ? or just the modem simply doesn't accept the incoming files?

Here is my configs:


Thanks.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
alexanderfuture wrote
When I reply from my phone, my phone show me error (Like: cannot be sent or red exclamation mark beside the message). Could this be the config ?

The config cannot cause this. Probably this means that there are no connection (or is a connection which fails) between two service centers currently. But I do know this for sure.

alexanderfuture wrote
or just the modem simply doesn't accept the incoming files?

In you first post in this topic there was couple of incoming messages available. But it's of course possible, that they were received using some other device, and then the SIM with messages was moved into the modem.

You could try to send SMS (using smsd) to your own modem, so soon after a message is sent, smsd will receive it and you know that your modem is working.

  This topic is locked

Page:  Previous  1  2

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.