SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:30
SMSTools3 Community » Help and support Bottom

[solved] ERROR: 28 (Unindentified subscriber)

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jun 2010
Location: Switzerland
Operating system name and version: Arch Linux 2.6.33-ARCH
Version of smsd: 3.1.8
Smsd installed from: sources
Name and model of a modem: Teltonika ModemUSB/G10
Interface: USB

Hello there :)

I'm having a problem that I don't quite understand and it seems no one has had it so far or it wasn't documented ... at least I couldn't find anything.

What I'm trying to do, is sending SMS messages from my notebook (as soon as it works it'll be from a server) to my mobile. The above mentioned modem is connected via USB to my notebook and gets mapped to /dev/ttyUSB0.

With my current config the modem responds to the sms daemon and tries to send the message. To create the message I use the sendsms script that comes with the source.

Now the problem:
I get the error mentioned in the title. It seems to me, that I don't deliver the right IMSI Number to my provider. I've been calling my provider and asking for the IMSI number, though he won't give it out :/
Strange is, that the IMSI number shown in the log is the same as the serial number of the SIM card, can that be?

Recieving SMS works fine by the way... when I set the incoming option in the config to 1, I can send SMS from my mobile to the GSM modem.

Any help would be very apprechiated.

Thanks in Advance,
Air

Below you'll find my current config, a complete log for sending 1 message and an failed sms file:
(Numbers [mobile,csms,imsi] have been changed)

Config


Log


SMS file


Member
Registered:
Jun 2010
Location: Switzerland
Topic owner
The problem is solved. Another call with the provider made clear, that the number of the SMS center was wrong... I'm gonna try that now on the server, but I'm confident it'll work.

Thanks anyway :)

Cheers,
Air

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Just came to mind, you could remove the init = ATZ setting from the configuration. It causes that "echo" goes back on. Or if your modem really needs that ATZ, define it as a start string: start = ATZ.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.