SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 11:59
SMSTools3 Community » Help and support Bottom

[answered] 2 Modems setup round robin problem

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jul 2010
Location: Arad, Romania
Operating system name and version: Ubuntu 9.10
Version of smsd: 3.1.11
Smsd installed from: sources
Name and model of a modem / phone: Huawei E220
Interface: USB

Hi all,

I have a 2 USB Huawei modem setup and now I'm sending only on one provider and I don't want to set any queues or complex setups.

All is working perfectly BUT I don't know why smsd is not sending simultaneously on both modems using the default setup (no queues, no providers). The server is sending using GSM1 and reading incoming on GSM2, after max send on GSM1 the behaviour is switched: reading incoming on GSM1 and sending on GSM2.

The only way of sending on both modems simultaneous was to implement 2 queues GSM1 and GSM2 and specify in the SMS file what queue to use.

Any ideas?

The config:




« Last edit by keke on Fri Jul 09, 2010 18:10, 168 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
There is a bug in the smsd :(. The setting trust_spool is used in the wrong place and incorrectly. Previously this setting was undocumented and defaults to no, but after 3.1.9 it was documented and the default was changed to yes. The next version 3.1.12 will fix this issue. In the meanwhile, use the modem setting trust_spool = no as a workaround.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.