SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 11:00
SMSTools3 Community » Help and support Bottom

[solved] Registration is denied for Modem Tango864-2

  This topic is locked

Page:  1

Author Post
Member
Registered:
Nov 2009
Location: Alto Parana, Paraguay
Operating system name and version: Ubuntu 10.04 LTS
Version of smsd: 3.1.11
Smsd installed from: sources
Name and model of a modem / phone: Falcom Tango864-2
Interface: serial

Hello..
I'm from south America Paraguay and I'm very happy and grateful with you for the smstools software, I have successfully implement it, in a school with playsms as frontend for notice service with 3 modem USB HUAWEI E226 with udev rules all fine, but sometimes I have troubles when I want to send many sms about 1000 at one it's like the modem crash and I need to stop/sms3 unplug modem then plug again and run sms3 for to continues sending.
Therefore I read that you recommend real AT serial modem like Falcom, and I bought one Tango864-2 modem from Germany and now I would like some help to understand my problem with it, because I don't know why I get in the log the message: "Registration is denied". I'm sure that is not a SIMCARD or coverage problem because the same SIM works fine with the usb modem HUAWEI.

smsd.conf

# Example smsd.conf. Read the manual for a description

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/ttyS0
incoming = yes
#pin = 1111

smsd.log
2010-08-18 14:27:48,2, smsd: Smsd v3.1.8 started.
2010-08-18 14:27:48,2, smsd: Running as root:root.
2010-08-18 14:27:48,7, smsd: Running startup_check (shell): /tmp/smsd_script.8mpe7T /tmp/smsd_data.2thVo4
2010-08-18 14:27:48,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2010-08-18 14:27:48,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2010-08-18 14:27:48,5, smsd: Outgoing file checker has started. PID: 3519.
2010-08-18 14:27:48,5, GSM1: Modem handler 0 has started. PID: 3521.
2010-08-18 14:27:48,5, GSM1: Using check_memory_method 1: CPMS is used.
2010-08-18 14:27:49,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_WQOyic
2010-08-18 14:27:49,6, GSM1: Sending SMS from to xxxxxxxxxxx
2010-08-18 14:27:49,6, GSM1: Checking if modem is ready
2010-08-18 14:27:49,7, GSM1: -> AT
2010-08-18 14:27:49,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:50,7, GSM1: <- AT OK
2010-08-18 14:27:50,6, GSM1: Pre-initializing modem
2010-08-18 14:27:50,7, GSM1: -> ATE0+CMEE=1
2010-08-18 14:27:50,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:50,7, GSM1: <- ATE0+CMEE=1 OK
2010-08-18 14:27:50,6, GSM1: Checking if modem needs PIN
2010-08-18 14:27:50,7, GSM1: -> AT+CPIN?
2010-08-18 14:27:50,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:51,7, GSM1: <- +CPIN: READY OK
2010-08-18 14:27:51,7, GSM1: -> AT+CSQ
2010-08-18 14:27:51,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:51,7, GSM1: <- +CSQ: 7,0 OK
2010-08-18 14:27:51,6, GSM1: Signal Strength Indicator: (7,0) -99 dBm, Bit Error Rate: less than 0.2 %
2010-08-18 14:27:51,6, GSM1: Checking if Modem is registered to the network
2010-08-18 14:27:51,7, GSM1: -> AT+CREG?
2010-08-18 14:27:51,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:52,7, GSM1: <- +CREG: 0,3 OK
2010-08-18 14:27:52,6, GSM1: Modem said: registration denied. Retrying.
2010-08-18 14:27:53,7, GSM1: -> AT+CSQ
2010-08-18 14:27:53,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:53,7, GSM1: <- +CSQ: 7,0 OK
2010-08-18 14:27:53,5, GSM1: Signal Strength Indicator: (7,0) -99 dBm, Bit Error Rate: less than 0.2 %
2010-08-18 14:27:53,7, GSM1: -> AT+CREG?
2010-08-18 14:27:53,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:54,7, GSM1: <- +CREG: 0,3 OK
2010-08-18 14:27:54,6, GSM1: Modem said: registration denied. Retrying.
2010-08-18 14:27:55,7, GSM1: -> AT+CSQ
2010-08-18 14:27:55,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:55,7, GSM1: <- +CSQ: 7,0 OK
2010-08-18 14:27:55,5, GSM1: Signal Strength Indicator: (7,0) -99 dBm, Bit Error Rate: less than 0.2 %
2010-08-18 14:27:55,7, GSM1: -> AT+CREG?
2010-08-18 14:27:55,7, GSM1: Command is sent, waiting for the answer
2010-08-18 14:27:56,7, GSM1: <- +CREG: 0,3 OK
2010-08-18 14:27:56,3, GSM1: Error: registration is denied.
2010-08-18 14:27:56,2, GSM1: Modem handler 0 terminated abnormally. PID: 3521.

Thanks in advance

Fabio

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Thanks for choosing this software.

falupy wrote
...for notice service with 3 modem USB HUAWEI E226 with udev rules all fine, but sometimes I have troubles when I want to send many sms about 1000 at one it's like the modem crash and I need to stop/sms3 unplug modem then plug again and run sms3 for to continues sending.

Huawei devices have this kind of issues, but currently it is not known for sure what causes this and how to resolve it permanently. Some device just disconnects itself, and reconnects after a while. It may be caused by the EMI (Electromagnetic Interference) from the modem, and in that kind of a case the USB extender might help. Also a modem setting keep_open = no may help little bit, but it does not fix the basic problem and is not a solution.

falupy wrote
Therefore I read that you recommend real AT serial modem like Falcom, and I bought one Tango864-2 modem from Germany and now I would like some help to understand my problem with it, because I don't know why I get in the log the message: "Registration is denied". I'm sure that is not a SIMCARD or coverage problem because the same SIM works fine with the usb modem HUAWEI.

Perhaps you could check the antenna and connectors. The signal -99dBm is very poor. However, something like -91dBm should still work, and your modem says "denied" instead of "searching". Have you checked that the frequencies of a device are compatible with the GSM network in your country?

Member
Registered:
Nov 2009
Location: Alto Parana, Paraguay
Topic owner
Thanks Keke for your quick anwser I will check the antenna an connectors because the modem is Quatribanda 850/900/1800/1900 and the people from Falcon are sure that it should works in my country, also I will put the keep_open = no in my smsd.conf file. Then I will tell you the results.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok. You could also try another SIM from different GSM operator, if possible.

Also try this:

Stop the smsd if it's running.
Start it in communication mode:
smsd -C GSM1
Follow the instructions on screen.

Type ATE1 (and Enter) to set "echo on".

Type a command:
AT+COPS=?

It may take a while until you get the list of available networks.

Type a command:
AT+COPS?

You can see the currently selected operator. Is it correct?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Is this problem still active?

If it is, what was the result for AT+COPS commands? I thought that the modem is trying to register to the wrong network, since the error message was "registration denied".

Member
Registered:
Nov 2009
Location: Alto Parana, Paraguay
Topic owner
Sorry Keke
I was out of office by some days, you were right my problem is with the antenna I don't have the correct one, and the modem can't connect to the right network, and I'm searching for a GSM antenna with 900/1900 Mhz the other was only 850 Mhz unfortunately in my location I can't find it in this moment, when I have news I will tell you, Thanks for your assistance.

Member
Registered:
Nov 2009
Location: Alto Parana, Paraguay
Topic owner
Hello Keke

Well I get an antenna GSM for 800/900/1800/1900 MHz but with the same bad results, registration denied from the modem, so I wrote a help request for FALCOM team and they send me these instructions:

you can configure the modem with:
AT#AUTOBND=1
AT+COPS=0
AT#BND=3
AT&W0
AT&P0

Then restart the modem and it should work

I do it, and now my modem is working very good.

This is the log file


  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.