SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 11:05
SMSTools3 Community » Help and support Bottom

[solved] cannot make the Listing of incoming sms in playSMS interface

  This topic is locked

Page:  1

Author Post
Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Operating system name and version: linux ubuntu 9.10
Version of smsd: 3.1.11
Smsd installed from: sources / package repository
Name and model of a modem / phone: sony ericsson
Interface: USB


Hello there,
My problem now is that the SMSs i sent are still pending in the Ougoing queue but they are sent with some delay and it seems that it's when i restart the server the job is done.
On the other hand, I want to get the incoming sms in PlaySMS page when i click on the incoming link but they can't.Can Someone please help me if there is some other configuration do be done.
Best Regards!

Masterxunil

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Any SMS file from the /var/spool/sms/outgoing directory is handled in 10 seconds (if you have not changed the delaytime setting in the smsd.conf).

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
i didn't change anything but the delaytime in mine is 6. The problem is that it still showing in the outgoing queue in playSMS and when it is sent it doesn't appear in the sent queue.Other thing it takes a long time before it send the sms.I don't know why!

Best regards!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could show your complete smsd.conf here, and the listing of:

ls -ltrR /var/spool/sms

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
Thanks It helps. But is it a problem it i am using one phone to create a queue for it.I my config i have created a GSM1 queue.Have a look to my smsd.conf configuration:

# Global configuration

devices = GSM1

loglevel = 4

logfile = /var/log/sms/smstools.log

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

delaytime = 6
errorsleeptime = 12
blocktime = 180

autosplit = 3
receive_before_send = yes

# Modem configuration

# iTegno 3000 USB
[GSM1]
device = /dev/ttyACM0
incoming = yes
#pin =
baudrate = 115200
smsc = +18763808853

[queues]
GSM1 = /var/spool/sms/GSM1

[default]
queues = GSM1
 
'smsdconf' Syntax Highlight powered by GeSHi



I f you have some suggestions please feel free I am a newby who really need advise to get it ready for my presentation. THANKS A LOT for ADVISING!
;)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
masterxunil wrote
Thanks It helps. But is it a problem it i am using one phone to create a queue for it.I my config i have created a GSM1 queue.

It's not a problem, but with one modem only you could run smsd without any queue settings. If you later add more modems to your setup, you can define queues if necessary.


I need to see the listing of:

ls -ltrR /var/spool/sms

Can you post it?

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
OK Here you are but my phone is not connected yed should i try to send some and send it again , please let me know!:

/var/spool/sms:
total 24
drwxr-xr-x 2 www-data root 4096 2010-08-21 13:10 checked
drwxr-xr-x 2 www-data root 4096 2010-08-24 13:37 incoming
drwxr-xr-x 2 www-data root 4096 2010-08-24 13:37 failed
drwxr-xr-x 2 www-data root 4096 2010-08-24 17:45 outgoing
drwxr-xr-x 2 root root 4096 2010-08-24 17:45 GSM1
drwxr-xr-x 2 www-data root 4096 2010-08-31 10:50 sent

/var/spool/sms/checked:
total 0

/var/spool/sms/incoming:
total 0

/var/spool/sms/failed:
total 0

/var/spool/sms/outgoing:
total 0

/var/spool/sms/GSM1:
total 4
-rw-r--r-- 1 root root 82 2010-08-24 17:45 out.PV.1.18

/var/spool/sms/sent:
total 0


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Just do this:

mv /var/spool/sms/GSM1/out.PV.1.18 /var/spool/sms/sent

and then check with playSMS what "outgoing SMS" says. Perhaps you need to run "Administration / Manual refresh" first, if the status is still something else than "Sent".

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You also wrote:

Quote
I want to get the incoming sms in PlaySMS page when i click on the incoming link but they can't.

But there is no any incoming SMS in the /var/spool/sms/incoming, so playSMS will have nothing to show... ;)

Try to send at least one SMS to the own number of a modem...

Also check the number of smsc, are you sure that it's correct?

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
I have already send a sms but it can't be shown on playSMS.i will try again but i am sure i won't work.How can i handle this!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Did you do this?:

Quote
Just do this:

mv /var/spool/sms/GSM1/out.PV.1.18 /var/spool/sms/sent

and then check with playSMS what "outgoing SMS" says. Perhaps you need to run "Administration / Manual refresh" first, if the status is still something else than "Sent".

I'm asking this again, because when there is SMS sent using playSMS, it will check the sent directory and will find the file and will mark it as sent. It should work... Before changing anything, or doing any other test, please move the file to sent directory and check what your playSMS says about it...

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
ok i did it.We will talk another time i going to be disconneted.If everything is good i will let you know soon.Thanks!

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
Hello there sorry for my abscence.I am back with the same problem.the one concerning the incoming queue in the playsms.I cannot get the incoming sms display in the web interface(playsms).I just get it on the phone but not in the interface.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
masterxunil wrote
I cannot get the incoming sms display in the web interface(playsms).I just get it on the phone but not in the interface.

As far as I remember, with default permissions playSMS should be able to show incoming messages. What do you have in the incoming directory, show the ls -l /var/spool/sms/incoming.

Assuming that it's empty, you may have a problem while trying to read incoming messages from the phone. What is the model of your Sony Ericsson?

Perhaps it does not show messages to the external interface. Change the loglevel to 7, restart smsd and check if there are any errors in the log when smsd is trying to read messages. If there are messages in the phone, but your incoming directory remains empty, show the piece of a log here.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Is this problem still active?

Member
Registered:
Aug 2010
Location: Port-au-prince, Haiti
Topic owner
Problem no more active.TX! :lol:

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.