SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 11:07
SMSTools3 Community » Help and support Bottom

[answered] +CME ERROR: 772

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2010
Location: Verona, Italy
Operating system name and version: DEBIAN
Version of smsd: 3
Smsd installed from: sources
Name and model of a modem / phone: ONDA N101E
Interface: USB

Hi I'm Paolo.
I have a problem with a SIM of my operator (ITALY H3G). When I connect the modem ONDA N101E with that SIM to my SMS SERVER, and start application, the log file tells me this:

PIN handling: expected READY, modem answered +CME ERROR: 772

I find that error 772 means "SIM POWERED DOWN". What can I do? The sim works well on my phone, but it gives this answer in N101E modem. Maybe is it because the SIM is a 3G sim? But it goes by default on roaming GSM network on my phone. Have I to set the roaming procedures directly on the SIM?

Thanks in advance
Best regards
Paolo

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi.
This is the reply to CGREG AT command:



Thanks in advance
Paolo

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could try with AT+ZSNT? to see what is the current setting for network selection. Then, if it works, try if AT+ZSNT=1,1,0 helps.

Do you have a manual of AT Commands for your device?

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi keke, thanks for your reply.
Unfortunatly, the device reply to my with an "ERROR" response.
Here it is:


I don't have a "AT command manual" for my device.
I have to find the way to set the roaming mode on my device ...

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Have you found a manual and got this problem solved?

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
No, I haven't find it in the phone's manual.
I think the problem is that the modem can't switch (or maybe "ROAM") to the normal GSM network. The SIM is a 3G SIM, but in normal phones (my cellular phones, a NOKIA 6070, that can't handle 3G network) it goes naturally to the 2G network (the GSM ones).
And I can't find the AT command to force this roaming procedure.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I was assuming that this device might be the same as ZTE, but it does not seem to be.

Some identification might be useful:

AT+CGMI (Manufacturer identification)
AT+CGMM (Model identification)
AT+CGMR (Revision identification)

But it's not sure if any information is still found. :(

Perhaps you should buy a modem which has documentation available.

Member
Registered:
Apr 2010
Location: Verona, Italy
Topic owner
Hi keke!
That's the info:



Thanks
Paolo

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Still did not find much more information, but it looks like you device is somehow old and incompatible with your current SIM card. If you cannot get older SIM, throw the stick away and buy a new one... (which has manuals available ;) )

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.