SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:46
SMSTools3 Community » Help and support Bottom

[answered] Sudden Error 500

  This topic is locked

Page:  1

Author Post
Member
Registered:
Oct 2010
Location: Sweden
Operating system name and version: Ubuntu 10.04 64-bit
Version of smsd: 3.1.6
Smsd installed from: apt-get
Name and model of a modem / phone: Huawei e1750
Interface: /dev/ttyUSB0

Hi,

I'm having some weird issues... this morning my modem was working fine, sms and flashes was going out proper... but now in the afternoon it hangs when post AT+CMGS...

This is what the logfile tells me.



Message file



configuration file:



I can seem to find what has gone wrong... I've tried everything from changing baudrates, to trying national_prefixes and even trying to write the file in a non-UTF8 format. If I understand the AT commands properly, shouldn't AT+CMGS= be the phonenumber? why does it fill in "32" instead?

I've rebooted and moved my modem from USB slots...

The same issue arises when trying to send via minicom.

Best regards
Fredrik Eriksson

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
fredrikeriksson wrote
I can seem to find what has gone wrong... I've tried everything from changing baudrates, to trying national_prefixes and even trying to write the file in a non-UTF8 format. If I understand the AT commands properly, shouldn't AT+CMGS= be the phonenumber? why does it fill in "32" instead?

I've rebooted and moved my modem from USB slots...

The same issue arises when trying to send via minicom.

The command AT+CMGS gets a phonenumber when ASCII mode is used. Smstools is using PDU mode and in this case length of PDU is given to the AT+CMGS.

It may be possible that your SIM is expired or broken. You could put it into your handset and try to send some SMS. Also, try to receive SMS using the SIM in Huawei with smstools. You need to define incoming = yes in the configuration for the test.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.