SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu May 23, 2024 02:16
SMSTools3 Community » Help and support Bottom

[solved] MODEM IS NOT REGISTERED

  This topic is locked

Page:  1

Author Post
Member
Registered:
Nov 2010
Location: United States of America
Operating system name and version: suse linux 11
Version of smsd: 3.1.11
Smsd installed from: sources
Name and model of a modem: Teramis (?!)
Interface: serial

please let me know if more information than this one is need...

thanks...


here below a the conf file and some log. apparently the machine is talking to the modem as far as AT commands. but can't figure out the "2010-11-21 22:22:15,5, GSM1: MODEM IS NOT REGISTERED, WAITING 1 SEC. BEFORE RETRYING 1. TIME" part. i have been using a sim card that is working on a normal phone hardware. double and triple checked...

conf:


and here is the log file:



would appreciate and input...


thanks....


« Last edit by nerdo on Mon Nov 22, 2010 18:43, 164 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Your modem says that the quality of signal is unknown or not measurable. This may mean that the antenna is broken, or the modem tries to register to the wrong network or with the wrong frequency. It's still trying to register, but without success.

I do not know that Teramis (?!) modem. Do you have a manual (link) for it, including specifications and AT command set? If you have, it might be helpful.

You could use the modem setting report_device_details = yes and then restart smsd. Show the log here. It may show some important information about your modem.

When you tested the SIM on a normal phone, what was the model of a phone, what was the network and frequency of it?

Member
Registered:
Nov 2010
Location: United States of America
Topic owner
hey thanks for the reply....

the modem is brand new out of the box Terminus gsm 864q. here is a link to it:

http://secure.conwin.com/cgi-bin/store/cp-app.cgi?usr=51H1964371&rnd=7961674&rrc=N&pg=prod&ref=53360

the sim card is works on a droid device model HTC Hero on the AT&T in the us. the frequencies (for quad band) are:

Quad-band GSM/GPRS/EDGE: * 850/900/1800/1900 MHz

(http://www.htc.com/www/product/hero/specification.html)


according to the modem user guide (http://www.janus-rc.com/Documentation/terminus_gsm864q_user_guide_.pdf) the AT commands need to specify the set are:

AT#SELINT=2 //use of most recent AT command set
AT#ENS=1 // AT&T/Cingular configuration

i believe that was done connecting directly to the modem via ttyv and entering those commands...

apparently the report_device_details = yes didn't add much to the log. here is a new piece of log:



thanks....

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
nerdo wrote
according to the modem user guide (http://www.janus-rc.com/Documentation/terminus_gsm864q_user_guide_.pdf) the AT commands need to specify the set are:

AT#SELINT=2 //use of most recent AT command set
AT#ENS=1 // AT&T/Cingular configuration

i believe that was done connecting directly to the modem via ttyv and entering those commands...

As the ENS functionality is disabled by default, you could check what are the current values.

Stop the smsd if it's running. Start it in communication mode: smsd -C GSM1. Follow instructions on the screen.

Type ATE1 (and Enter) to set "echo on".

Check those settings:

AT#SELINT?

AT#ENS?

If you need to change those settings, I assume that also saving is required:
AT&P0
AT&W0


Member
Registered:
Nov 2010
Location: United States of America
Topic owner
thanks keke. ENS was returning 0. it had to be 1. thanks...

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.