SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat Apr 17, 2021 17:45
SMSTools3 Community » Help and support Bottom

[solved] Delivery Reports Not Arriving

  This topic is locked

Page:  1

Author Post
Member
Registered:
Nov 2010
Location: Lohja, Finland
Operating system name and version: Debian Linux 5.0.6
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: WAVECOM Fastrack Xtend GPRS
Interface: USB

Having written my own eventhandler and regular_run scripts, I can now send and receive messages stored in a MySQL database. However, delivery reports are never seen, and looking at the configuration options I haven't found anything wrong.

My eventhandler has been set up to report the [filename] and <message_id> it gets as parameters $2 and $3 when SENT fires. These are present:


However, no REPORT events ever occur. Does this modem need special treatment with AT commands to have the delivery reports work? Looking through other threads the relevant commands seem to be:


Do these require tweaking?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Use the modem setting report_device_details = yes, restart smsd and show the log...

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner


Another head scratcher is why the device reports being registered in a roaming partner network. Makes no sense.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Your device has different memory for status reports.

Try with these modem settings:

primary_memory = SM
secondary_memory = SR


cyanshade wrote
Another head scratcher is why the device reports being registered in a roaming partner network. Makes no sense.

As you have +358451100100 as SMSC, your SIM is from Saunalahti. This operator runs on the Elisa network. No matter how companies are owned.

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner
Changing the memory setting had no effect. :(

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Are you sure that reports are requested? Can you show the PDU of one outgoing message?

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner
Here's the latest test:
Hidden private text.



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Okay, use this setting (and keep those memory settings):

init = AT+CNMI=1,0,0,2,0

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner
That did the trick, thanks! :)

I now have send/receive/report working and can replace the ludicrously expensive content gateway. Hurray.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.