SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:55
SMSTools3 Community » Help and support Bottom

[outdated] part of message garbled

  This topic is locked

Page:  1

Author Post
Member
Registered:
Nov 2010
Location: Austria
Operating system name and version: suse linux 10.2
Version of smsd: 3.1.14
Smsd installed from: sources (all standard by installscript)
Name and model of a modem / phone: modem PSI-GSM
Interface: serial


sent messages are garbled after approx 80 signs at destination-phone.
(tested with various phones)
is this a setup problem ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
This sounds like an alphabet problem. What kind of message file you have sent?

Member
Registered:
Nov 2010
Location: Austria
Topic owner
hi
just a normal text message

file:
To: 0043...........
Flash: yes
Alphabet: GSM

das ist eine testsms. weitere koennen noch folgen.
aber keine anderen mehr.
l.g.
hs

end file:

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The alphabet is not GSM. Remove that line.

Member
Registered:
Nov 2010
Location: Austria
Topic owner
hi
done.
problem still exists.

received result at mobile:

das ist eine testsms. weitere koennen noch folgen.
aber keine anderen kAJc&N4bA0rf"


the smsd.log just says: SMS sent, Message_id: 26,.........


do you hafe any testmobile ?
if yes i can try to send this message to youi from our system directlly.


« Last edit by hstein on Mon Nov 29, 2010 13:21, 164 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, actually your text can be sent with alphabet GSM, because it contains latin letters only.

Have you disabled handshaking (rtscts = no)?

You may have a communication problem with your modem. You could use the modem setting verify_pdu = yes and try again after restarting smsd. With this setting smsd checks if the PDU string is echoed back correctly from the modem. If there is no error, but received message is still garbled, you could show the PDU so I can check if it's correct or not.

Member
Registered:
Nov 2010
Location: Austria
Topic owner
hi
this is /etc/smsd.conf:
devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/ttyS0
incoming = yes
rtscts = yes
verify_pdu = yes
#pin = 1111


this is log-output after restart:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The PDU is broken. Perhaps you should try with a lower baudrate, for example 9600. If it does not help, try the setting send_handshake_select = no.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Is this problem still active?

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.