SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:45
SMSTools3 Community » Help and support Bottom

[solved] Timeouts while receiving SMS

  This topic is locked

Page:  1

Author Post
Member
Registered:
Dec 2010
Location: Chisinau, Moldova
Operating system name and version: Gentoo linux, kernel gentoo-sources-2.6.36-r5
Version of smsd: 3.1.14
Smsd installed from: unofficial ebuild
Name and model of a modem / phone: Huawei E1750 HSPA USB Stick
Interface: USB

I am a first time user of smstools and I experience sporadic problems with my modem. Ocasionally it stops responding on AT+CMGL=0 commands. Below is the log excerpt:



Is it hardware problem or is it related to my config?

Thanks in advance.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Bad to say anything for sure...

After it does not respond to CMGL, do you need to reset the stick, or does it continue and next time CMGL works?

Have you tested if sending of messages (containing more than almost 160 latin characters) works properly?

You could also test receiving with check_memory_method = 1 and memory_start = 0.

Have you changed the settings baudrate or rtscts?

Member
Registered:
Dec 2010
Location: Chisinau, Moldova
Topic owner
Here's my config:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, the baudrate is same as it defaults, and handshaking is not disabled. With these settings USB sticks usually work very fine.

keke wrote
After it does not respond to CMGL, do you need to reset the stick, or does it continue and next time CMGL works?

What I was meaning with this question, was that is the problem permanent (modem freezes), or just happens some times?

keke wrote
Have you tested if sending of messages (containing more than almost 160 latin characters) works properly?

Have you? If you have sent and received lot of long messages properly, it means that there is no problem in communication between smsd and modem.

keke wrote
You could also test receiving with check_memory_method = 1 and memory_start = 0.

Can you test with those settings? If this problem is related to the CMGL command, with those settings CMGL is not used.

Member
Registered:
Dec 2010
Location: Chisinau, Moldova
Topic owner
Hi!

Addition of 2 lines (check_memory_method = 1 and memory_start = 0) to config seems solved my problem. At least it works last 24 hours.

I'll post success story later, expecting many SMSes in a few days.

Thank you, keke, for excellent support provided!

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.