SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
Locations of visitors to this page
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Tue Sep 16, 2014 02:54
SMSTools3 Community » Help and support Bottom

[answered] Update Explanations

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2011
Location: Arezzo, Italy
Operating system name and version: Ubuntu 8.10
Version of smsd: 3.1.14
Smsd installed from: sources
Interface: serial


Hello,
I've upgraded SMS Server Tools from version 3.1.8 to 3.1.14 (only one step).
When I upgrade the SMS Server installing a new version, I have to overwrite configuration files with my settings every time?
Are all the settings of version 3.1.8 compatible whit version 3.1.14?

Thanks.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
All settings are backward compatible. If some setting has changed, for example some value is not accepted anymore, error is printed to screen and to the log and smsd does not start.

Member
Registered:
Jan 2011
Location: Arezzo, Italy
Topic owner
Thank you for you answer.

I have just another question...
When I upgrade SMS Server Tool, are old configuration files overwrited (.sh files on /usr/local/bin/ and /etc folders)?
Is it necessary to make a back-up copy of .sh files before upgrading and then replace them or are they preserved?


Thank you again.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
make install does not overwrite existing scripts or settings. It also does not check whether any script is changed.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

  Time in this board is UTC.
The forum engine is based on UseBB 1 Forum Software  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.