SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu May 23, 2024 04:09
SMSTools3 Community » Help and support Bottom

[answered] SMSD -S not working in Cygwin

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jun 2010
Location: Singapore
Operating system name and version: Windows 7 (64 bit)
Version of smsd: 3.1.14
Smsd installed from: downloaded the source from website (installed in cygwin)
Name and model of a modem / phone: Wavecom WMOD2
Interface: USB

Hi,

I have installed smsd based on above details; followed the manual from the website for windows environment.

When I run smsd by using "smsd -s", I get this message "Status monitor is not included in this compilation", also the server doesn't seems working coz I can't find the log file anywhere, and the text file under outgoing folder is not being sent out. :(

Please help. Thanks in advance.

Just for your info;
I did not install smsd as a service.

below is my smsd.conf:

# Example smsd.conf. Read the manual for a description

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

os_cygwin = yes
delaytime = 10
incoming_utf8 = yes
receive_before_send = yes
trust_outgoing = yes

checked = /var/log/ssmd/checked
failed = /var/log/ssmd/failed
incoming = /var/log/ssmd/incoming
outgoing = /var/log/ssmd/outgoing
report = /var/log/ssmd/report
saved = /var/log/ssmd/saved
sent = /var/log/ssmd/sent

#eventhandler = filename

[GSM1]
#device = /dev/ttyS0
device = /dev/ttycom10
incoming = yes
smsc = +6596845999
#pin = 1111
'smsdconf' Syntax Highlight powered by GeSHi


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Status monitor function is disabled by default. You need to install the OSSP mm Shared Memory Library, also called mm or libmm. Then you need to enable statistics in src/Makefile and recompile the source code.

When you got a message "Status monitor is not included in this compilation", smsd stopped and therefore did not create a log, or sent anything.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi,

As suggested, I installed the OSSP mm, enable statistics in src/Makefile and recompliled the code again but I am having the same problem.

Quote
For your info:
- OSSP mm installation steps:
-- Downloaded from
http://www.ossp.org/pkg/lib/mm/

-- Installed via following command
$ ./configure --prefix=/usr/src/
$ make
$ make test
$ make install

- enabled statistics as follow:
# Comment this out, to enable statistics
#CFLAGS += -D NOSTATS

Did i missed out anything?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
After editing the Makefile, did you run make clean smsd? Or first make clean, and then make which will do the job too.

Check with ls -ltr if your smsd.exe is updated or no. You also will need to replace the executable: cp -p smsd.exe /usr/local/bin

If you did not replace the executable, you can test smsd with ./smsd -s in the src directory.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi,

Thanks for your prompt reply but it is still not working.

This time, I noticed a message after I ran "make install".

Quote
Installing start-script
I do not know where to copy scripts/sms3. Please find out yourself.

Does it means that installation was not successful?

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Does it relating with 64 bit OS architecture?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
alexanderfuture wrote
Does it relating with 64 bit OS architecture?

No, this is not related with 64bit Windows.


You have executed make install in the smstools3 directory. It talks about scripts/sms3, because on Cygwin there is no init.d directory which is usual place for this script. You have to decide where to put this script, and then use it to start and stop the daemon. For example it can be in the /usr/local/bin directory. However, when running smsd with -s, this script is not required.

The error message is still the same "Status monitor is not included in this compilation"?

What you need to do, is: go to the smstools3/src. Then run make clean smsd. You should see how smsd is compiled. After the compilation, with ls -ltr you should see that smsd.exe has later timestamp than Makefile has. If everything is okay, replace the executable: cp -p smsd.exe /usr/local/bin

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi Ke Ke,

Thanks for your reply again.

I tried recompiling again and it is still having the same error message. So I uninstall smstools3 and re-install again. This time, when I compile I have got the following error (I ran "make clean smsd" and "make" in "/smstools3/src"):



Is it relating with OSSP mm?
I suspected that it is because of OSSP mm. Therefore, I do the re-installation of OSSP mm but still seeing the above error.

For your info, I installed OSSP mm under "/usr/src/mm-1.4.2/" and I installed smstools3 under "/usr/src/smstools3/".

(I found mm.h under /usr/src/mm-1.4.2/ .)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
alexanderfuture wrote
Is it relating with OSSP mm?
I suspected that it is because of OSSP mm. Therefore, I do the re-installation of OSSP mm but still seeing the above error.

For your info, I installed OSSP mm under "/usr/src/mm-1.4.2/" and I installed smstools3 under "/usr/src/smstools3/".

(I found mm.h under /usr/src/mm-1.4.2/ .)

alexanderfuture wrote
-- Installed via following command
$ ./configure --prefix=/usr/src/

Sorry, I did not notice that until now... :(

Prefix for installation of libmm means target directory tree, not a tree of sources. That prefix defaults to /usr/local, which can be used. Files are then placed to the /usr/local/include and /usr/local/lib directories.

So just reinstall libmm once again, but you do not need to reinstall smstools3. Just compile it after files of libmm are in the correct place.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi Ke Ke,

Thanks for your suggestion.

As suggested, I reinstall the libmm again with



Now I can start the sms server but another problem come up again.

Here is the error from the smsd.log
Quote
2011-01-12 21:53:37,3, GSM1: Couldn't open serial port /dev/ttyS0, error: No such file or directory, waiting 30 sec.

I have a problem with finding my device. I am not sure which one to write. From my device manager program, I can see the device, (WAVECOM WMOD2),at COM10

Can you suggest the which one to write in the device path?

Thanks so much..


« Last edit by alexanderfuture on Wed Jan 12, 2011 14:02, 162 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
alexanderfuture wrote
I have a problem with finding my device. I am not sure which one to write. From my device manager program, I can see the device, (WAVECOM WMOD2),at COM10

Can you suggest the which one to write in the device path?

It's device = /dev/com10.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi,

Now start sending the AT commands to the modem but I got following error in its log:

Quote
2011-01-12 22:34:09,6, GSM1: Checking if modem is ready
2011-01-12 22:34:09,7, GSM1: -> AT
2011-01-12 22:34:09,7, GSM1: Command is sent, waiting for the answer
2011-01-12 22:34:15,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-01-12 22:34:15,7, GSM1: <-
2011-01-12 22:34:15,7, GSM1: -> SUB


Thanks.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Allow me to correct the error log coz there is no such thing called SUB.... I guess it must be the number and it shows as SUB in my notepad++ editor...

in stead of SUB, it should be a rectangle

Quote
2011-01-13 00:22:15,6, GSM1: Checking if modem is ready
2011-01-13 00:22:16,7, GSM1: -> AT
2011-01-13 00:22:16,7, GSM1: Command is sent, waiting for the answer
2011-01-13 00:22:21,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-01-13 00:22:21,7, GSM1: <-
2011-01-13 00:22:22,7, GSM1: ->  rectangle 
2011-01-13 00:22:22,7, GSM1: Command is sent, waiting for the answer
2011-01-13 00:22:27,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 2.
2011-01-13 00:22:27,7, GSM1: <-
2011-01-13 00:22:28,7, GSM1: -> AT
2011-01-13 00:22:28,7, GSM1: Command is sent, waiting for the answer
2011-01-13 00:22:33,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 3.
2011-01-13 00:22:33,7, GSM1: <-
2011-01-13 00:22:34,7, GSM1: ->  rectangle 
2011-01-13 00:22:34,7, GSM1: Command is sent, waiting for the answer
2011-01-13 00:22:39,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 4.
2011-01-13 00:22:39,7, GSM1: <-
2011-01-13 00:22:40,7, GSM1: -> AT


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
That "rectangle" is Ctrl-Z character, which is used to terminate the PDU string. When smsd is checking if modem is ready, after the first AT with no answer smsd tries if modem is waiting for termination character.

In your case the modem does not answer anything. You could try with a different baudrate, like baudrate = 38400, if it helps. If lower baudrate does not help, check if more than one port is provided for your modem. With networking devices "control port", application interface" and "networking interface" may be provided. In some cases all ports are not visible in device manager, but still exists. If this is the case, you just should try some different ports around the com10.

If possible, you could also try to communicate with a modem using some terminal program on Windows.

Member
Registered:
Jun 2010
Location: Singapore
Topic owner
Hi Ke Ke,

Thanks very much for your help along the way. Now I can send the SMS successfully after the hassles. :D

I found the wavecom smsd.conf sample from the following link and add the init and baud_rate in my config; then everything is working like charm:
http://smstools3.kekekasvi.com/topic.php?id=406

Thanks millions to Ke Ke (for the exceptional support) and techniker (for the sample config).

After the hassles I had run through, I would like to contribute my setup steps for windows + cygwin environment so that people will not take very long period to kick start the sms server. Steps are as follow;

 CYGWIN SETUP 


1. Go to www.cygwin.com, download it and click on Install Now.

2. Click on Next until you can select a download server. Select one that is near to you and click on Next

3. After the list of cygwin packages is received you can select the parts that you want to install. Do not deselect anything.

4. Open the Devel list and

5. select gcc and

6. make by clicking one time on them.

7. If you want to use statusmonitor feature, a gcc-g++ package is also needed.

8. After the version 3.2, libiconv is also needed if iconv is used. It's used by default.

9. Then click on Next until you can see the progress bar and follow the instructions to finish the setup.



 OSSP MM SETUP 


10. Go to http://www.ossp.org/pkg/lib/mm/

11. Download the desired version under  Distribution files  section (I downloaded mm-1.4.2.tar.gz )

12. move that downloaded file to  [CYGWIN FOLDER PATH]/usr/src/ 

13. now, start the cygwin from start menu

14. Install OSSP MM via following steps:
14.1 $./configure --prefix=/usr/local
14.2 $ make
14.3 $ make test
14.4 $ make install



 Installing SMSTools3 


15. Download the SMS Server Tools 3 into the directory [CYGWIN FOLDER PATH]\usr\src.
(Some windows versions store the file with a wrong filename (*.tar.tar) instead of *.tar.gz but this does not cause any problem.)

16. Enter the following commands to extract the archive:
16.1 $ cd /usr/src
16.2 $ tar -xzf smstools3*

17. Enable the status monitor:
17.1 Go to  [CYGWIN FOLDER PATH]\usr\src\smstools3\src\  from windows browser
17.2 find this file "MakeFile" and open it in notepad
17.3 Find this section:
# Comment this out, to enable statistics
CFLAGS += -D NOSTATS

17.4 Change to become like following:
# Comment this out, to enable statistics
#CFLAGS += -D NOSTATS

17.5 close notepad and return to CYGWIN BASH SHELL (COMMAND PROMPT / TERMINAL)

17.6 enter following commands:
17.6.1 $ cd /usr/src/smstools3
17.6.2 $ make
17.6.3 $ make install



 Preparing for SMSD Config 


18. make sure the modem is connected to computer

19. check the COM port number for the modem
19.1 right click on My Computer/Computer menu from start menu
19.2 click Properties on pop-up menu
19.3 Find Device Manager link/button/tab and click on it
19.4 Find "Port (COM & LPT)" and expand it
19.5 You will see "Universal Serial Port (COMxx)" [in my case, Universal Serial Port (Com10)]
19.6 note the com port number

20. check the SMS Service Center Number of ISP:
20.1 You can find it in this web page http://modmymobile.com/wiki/index.php/SMS_Service_Center_List
20.2 Note down your sms service center number



 Configuring SMSD for WAVECOM WMOD2 

Refer to this link:
http://smstools3.kekekasvi.com/topic.php?id=406

or here is my config

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

os_cygwin = yes
delaytime = 10
incoming_utf8 = yes
receive_before_send = yes
trust_outgoing = yes

checked = /var/log/ssmd/checked
failed = /var/log/ssmd/failed
incoming = /var/log/ssmd/incoming
outgoing = /var/log/ssmd/outgoing
report = /var/log/ssmd/report
saved = /var/log/ssmd/saved
sent = /var/log/ssmd/sent

#eventhandler = filename

[GSM1]
init = AT+CMEE=1
pin = 2537
baudrate = 9600
rtscts = yes
memory_start = 1

device = /dev/com10
incoming = no
outgoing = yes
smsc = +6596845999

 
 
'smsdconf' Syntax Highlight powered by GeSHi


All the best. :)

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.