SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 06:56
SMSTools3 Community » Help and support Bottom

[solved] Sending & receiving Problem

  This topic is locked

Page:  1

Author Post
Member
Registered:
Feb 2011
Location: New Delhi, India
Operating system name and version: Debain Lenny 6
Version of smsd: 3.1.14
Smsd installed from: sources / package repository / from elsewhere...
Name and model of a modem / phone: Itegno USB 3800
Interface: USB

Hello,

I have installed SMStools 3 with playsms GUI on Debian Server using the following link;

http://www.howtoforge.com/installation-of-playsms-and-sms-server-tools-3-on-debian-server

I can login to play SMS & made SMStools3 Gateway as Active but can not send or receive SMS though it shows in PlaySMS, SMS put in queue & showing Pending in reports

I also checked ls /dev/tty & my modem connected on ttyUSB0


My smsd.conf is as under;

# Global configuration
devices = modem1
loglevel = 4
logfile = /var/log/sms/smstools.log
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes
# Modem configuration #
[modem1]
#init = device = /dev/ttyUSB0
incoming = yes
#pin = baudrate = 115200


Please advice


thanks

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
What is in the /var/log/sms/smstools.log?

You have a modem setting "#init = device = /dev/ttyUSB0", which makes no sense. Perhaps smsd said that modem1 has no device specified. If this is the case, fix it to:

#init =
device = /dev/ttyUSB0


Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Dear Sir,

It's working now after fixing #init as directed.

Further, I get the following Error when I give following command;
/var/log/sms/smstools.log

The error is

-su /var/log/sms/smstools.log :Permission denied

I am logged in with root user & also tried with user : playsms

Please advice

Thanks & regards,

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
/var/log/sms/smstools.log is not a command, it's a regular file. To view it's content you have to use a command like:

su less /var/log/sms/smstools.log

Of course, su is not required if you are root.

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
It's working now.

Thank you so much for your prompt support

regards,

Tummy

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.