SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat Feb 27, 2021 13:06
SMSTools3 Community » Help and support Bottom

Modems won't send sms

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Mar 2010
Location: Mexico
Operating system name and version: Ubuntu 11.04
Version of smsd:
Smsd installed from: package repository
Name and model of a modem / phone: Multitech SF800G
Interface: Network

I have 9 Modems configured but only the first one is sending messages, for some reasons the others won't, when I check the logs I can see they are all at "Waiting for messages to send..."

I don't know how should I proceed, the config is the same for all nine modems, the first one works fine

Thanks

Member
Registered:
Mar 2010
Location: Mexico
Topic owner
Here's an update with my config and part of the logs:


This is part of the log showing some strange behavior by one modem, but after getting to the waiting for messages to send, no sms is sent



This is the config file:



Member
Registered:
Sep 2011
Location: Brusturoasa, Romania
Maybe the second modem is defective. Have you tried with out it?

Member
Registered:
Mar 2010
Location: Mexico
Topic owner
Thanks for your answer, I have tried several configurations but for the second device modems (m2m1 though m2m8 ), they don't seem to be working, sometimes the logs show that its all good and its ready to send messages but they just sit Idle all the time



And that happens with several modems, sometimes I get this errors





I would appreciate any kind of help, thanks so much

Member
Registered:
Mar 2010
Location: Mexico
Topic owner
I have also found this, that applies to my device

Quote
- Wireless Modem Initialization Sequence: The initialization sequence performed in versions 1.44 and older is insufficient in some screnarios (certain 64k SIM cards, SIM card configuruation, etc). The key to the modem being functional is to wait for a “+WIND:#” (1, 4 sometimes 9) status before issuing other commands. The time needed to wait for a +WIND response will vary depending on the SIM and/or network. Waiting a minute is usually sufficient, but up to 3 or 4 minutes may be required. “515” errors are an indication that commands were issued before +WIND 1/4 was reached.

The new logic is:
--1)Send AT+CFUN=0 (graceful shutdown).
--2)Wait for “OK”.
--3A)If no “OK” received within 15 seconds, do a hardware reset of the modem and proceed to step 4.
--3B)If “OK” received within 15 seconds send AT+CFUN=1 (soft reset of modem) and proceed to step 4.
--4)Wait for +WIND response before proceeding with remaing modem commands.
--5)Proceed with remaining hard coded AT commands used to setup text mode, character set and etc.
--6)Proceed with any User defined Initialization Strings defined on the Cellular Modem setup menu.

But I'm not sure how to configure smstools to wait for that incoming +WIND

Member
Registered:
Sep 2011
Location: Brusturoasa, Romania
As I can undestand you have two Multitech SF800G. Which is a 8 port SMS server. Right?
The first one has only one port active?
The second has all the ports?

I have never worked with Multitech SF800G but I think that you could try setting the second one with only one port enabled.
And see what happens.
Maybe you can start from here.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.