Smsd installed from: ports
Name and model of a modem / phone: Sierra wireless GL6110
Interface: USB

I cannot access to my modem GSM to send SMS

when I plug it i've got on /var/log/messages:

the device created:

lrwxr-xr-x 1 root wheel 9 Dec 13 17:15 ugen0.3 -> usb/0.3.0
# ls -lt /dev/usb|head -1
crw-rw---- 1 root usb 0, 136 Dec 13 17:15 0.3.0

smsd run under owner uucp

uucp belongs to usb group so he's have the right on the device:


Configuration of smsd

devices = GSM1
logfile = /var/log/smsd/smsd.log
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
loglevel = 7

device = /dev/ugen0.3
incoming = yes
mode = new
#smsc = 4#####
baudrate = 115200
pin = 2587
rtscts = yes
cs_convert = yes
report = yes
sending_disabled = no
memory_start = 1
device_open_retries = 1
'smsdconf' Syntax Highlight powered by GeSHi

I start smsd and I ve got this log:

I take differents baudrate but I've got the same result.

I don't really understand how can I access to my my GSM through the device /dev/ugen0.3 (baudrate etc.. )

I try to access to my Iphone plugged on an USB ports but I got the same result

I put my GL6110 on a windows machine with the software delivered by Sierra and I could send a sms ( so the hardware works.) But I want to use it on Freebsd.

If someone has a clue on this problem, thanks in advance.