SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 00:28
SMSTools3 Community » Help and support Bottom

[solved] AT init string does not look correct.

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2011
Location: Israel
Operating system name and version: Fedora 14
Version of smsd: 3.1.8
Smsd installed from: package repository
Name and model of a modem / phone: Nokia 7270 phone
Interface: USB


When initializing the phone, smsd sends a weird character instead of an AT command. adding AT command string to the conf does not change the behaviour. The modem does not respond to this. What am I doing wrong?

My smsd.conf:

devices = ACM0
logfile = /var/log/smsd/smsd.log
loglevel = 7
user = smstools
group = dialout
infofile = /var/spool/sms/smsd.running
smart_logging = yes

[ACM0]
device = /dev/ttyACM0
incoming = yes
 
'smsdconf' Syntax Highlight powered by GeSHi



A portion of the log file below:

2011-01-26 15:00:21,2, smsd: Smsd v3.1.8 started.
2011-01-26 15:00:21,2, smsd: Running as smstools:dialout.
2011-01-26 15:00:21,7, smsd: Running startup_check (shell): /tmp/smsd_script.fBGKhX /tmp/smsd_data.rWTy7n
2011-01-26 15:00:21,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2011-01-26 15:00:21,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-01-26 15:00:21,5, smsd: Outgoing file checker has started. PID: 9573.
2011-01-26 15:00:21,5, ACM0: Modem handler 0 has started. PID: 9574.
2011-01-26 15:00:21,5, ACM0: Using check_memory_method 1: CPMS is used.
2011-01-26 15:00:21,6, ACM0: Checking device for incoming SMS
2011-01-26 15:00:21,6, ACM0: Checking if modem is ready
2011-01-26 15:00:22,7, ACM0: -> AT
2011-01-26 15:00:22,7, ACM0: Command is sent, waiting for the answer
2011-01-26 15:00:22,7, ACM0: <- O
2011-01-26 15:00:22,7, ACM0: -> .
2011-01-26 15:00:22,7, ACM0: Command is sent, waiting for the answer
2011-01-26 15:00:27,7, ACM0: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-01-26 15:00:27,7, ACM0: <-

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Your Fedora probably runs on 64bit Intel processor?

This looks like a 64bit problem which is fixed in 3.1.9. You need to upgrade at least to that version, or to latest 3.1.14 if possible.

Member
Registered:
Jan 2011
Location: Israel
Topic owner
Yes, it is running on a 64bit processor.
Does this means I have to install from source instead of using an RPM?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I do not know about Fedora RPM. If there is no 3.1.9 or later available, you have to install from sources.

Member
Registered:
Jan 2011
Location: Israel
Topic owner
Thanks. Installed 3.1.14 from source.

Problem solved :-)

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.