SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 01:38
SMSTools3 Community » Help and support Bottom

[answered] Samba 3G and Delivery Report

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2011
Location: Germany
Operating system name and version: Linux (Ubuntu 10.10)
Version of smsd: tested with 3.1.14 and 3.1.12
Smsd installed from: sources
Name and model of a modem: Samba 3G
Interface: USB

Hello everybody

We have some Samba 3G and use it to send SMS. Without any init command the modem can send and receive standard SMS only. If i send a SMS with report = yes, no Delivery Status will be receive.

the configuration file:
[1]
device = /dev/ttyUSB_1-2.3
incoming = high
pin = 0000
queues = modem1
cs_convert = 1
baudrate=115200


If i use some init commands, i can receive "some" Delivery Reports:

init=AT+CPMS="ME","ME","ME";+CSMS=1
init2=AT+CNMI=1,2,0,1
device = /dev/ttyUSB_1-2.3
incoming = high
pin = 0000
queues = modem1
cs_convert = 1
baudrate=115200

And now the problem:
Some Samba 3G works fine and get all Delivery Reports, but for the most modem i can find in the log file "The modem answer was not OK: +CMS ERROR: 322 (Memory full)". All Samba 3G use the same init commands.

How can i receive Delivery Reports reliably?

Thx for your help

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
It seems that this modem is based on module from Telit, but I'm not 100% sure. You could use the modem setting report_device_details = yes, which will write details to the log file. Restart smsd and show those details here. If you have some modem which works and some which does not, show details from both devices.

Member
Registered:
Jan 2011
Location: Germany
Topic owner
Hello

Here is the output with "report_device_details = yes". All modem (working or not) has the same information.



The modem, that are working, are used on 1 server with smsd 3.1.11. The other modem work with smsd 3.1.12 or 3.1.14. On one server i had made a downgrade to 3.1.11 and a reset of the modem with AT command "AT&F1". After power off and on of the modem it has received Delivery Reports:



On my first test it works a few days. Do you know about problems with delivery reports on modules with Telit chipset?

thx for your help

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I run several GM862-QUAD-PY, but they do not have "SR" memory available. Delivery reports are stored to the SM memory and are read like normal messages.

In your device there is "SR" memory existing. Perhaps it's filled up and therefore you get CMS 322.

Your init2 causes that reports are routed. You could disable the routing with init2 = AT+CNMI=1,0,0,0,0 (or reset the modem and remove init2 from the configuration).

Then, try the following settings for a modem:

primary_memory = ME
secondary_memory = SR


Member
Registered:
Jan 2011
Location: Germany
Topic owner
Hello

Now it seems to work. I use the following configuration:

init=AT+CPMS="ME","ME","ME"
primary_memory = ME
secondary_memory = SR
device = /dev/ttyUSB_1-2.3
incoming = high
pin = 0000
queues = modem1
cs_convert = 1
baudrate=115200

Thanks for your help.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.