SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 06:12
SMSTools3 Community » Help and support Bottom

[solved] Trying to make a Huawei E1552 work

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2011
Location: Philippines
Operating system name and version: Ubuntu 10.10 Desktop x386
Version of smsd: 3.1.10
Smsd installed from: repository
Name and model of a modem / phone: Huawei e1552
Interface: USB

Would anyone have config file for a Huawei E1552? I tried sending an SMS by placing the following in a text (randomfeb5) in /var/spool/sms/outgoing:
Quote
To: 0902XXXXXX (mobile number was placed here)
Flash: no
Alphabet: ISO

Hello Stefan, how are you?

After a couple of seconds, the file was then transferred to /var/spool/sms/checked but no SMS was sent. Nothing was in /var/spool/sms/sent nor did anything arrive in the recipient's mobile phone.

Notice though that I am an absolute newbie (I even copied the sample SMS text message file from http://smstools3.kekekasvi.com/index.php?p=fileformat) so I may be doing something wrong.

I haven't touched the /etc/smsd.conf though so I may doing something wrong. :mrgreen:

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
With Huawei device you have to use a modem setting init = AT^CURC=0, or init2 if init is already used. But this has nothing to do with your current problem.

You could define a global setting failed = /var/spool/sms/failed, and create this directory. Then restart the smsd. Next time when sending fails, message is moved to this directory and there is a header Fail_reason which tells why sending has failed.

Your To: 0902XXXXXX may be a sample, but it does not look correct. Number should be presented using international format, in your country it should start with 63. This may be a reason for the failure, but if the sending with international number still fails, show a piece of log here so I can check what actually is happening.

Member
Registered:
Jan 2011
Location: Philippines
Topic owner
Thanks for the tips. :)

I modified my /etc/smsd.conf and the GSM1 setting is now:

[GSM1]
init = AT^CURC=0
device = /dev/ttyS0
incoming = yes
#pin =
baudrate = 19200
'smsdconf' Syntax Highlight powered by GeSHi


I also changed the To part to To: 63902XXXXXX, but still no luck. The /etc/smsd.conf already had a "failed" setting, but even though the message wasn't sent, nothing went into the "failed" folder. :(

The latest logs show the following:

I really appreciate all the help. I look forward to sending my first SMS. :)

Member
Registered:
Jan 2011
Location: Philippines
Topic owner
Small update: I changed my smsd.conf to

[GSM1]
init = AT^CURC=0
device = /dev/ttyUSB0
incoming = yes
#pin =
baudrate = 19200
'smsdconf' Syntax Highlight powered by GeSHi


And I was able to get something in the failed folder. :) Still no sent SMS though. :(

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You had started smsd many times, even when it was already running. If you have some script which does this, please disable it.

The device setting was changed. As it was the first serial port, you likely had communication errors (modem does not answer... ) in the log and therefore no SMS was sent.

Now with the correct device setting communication works. As you have something in the failed folder, what kind is a failed message? What is the Fail_reason? If the reason is not clear, show a piece of log when smsd tries to send a message.

Member
Registered:
Jan 2011
Location: Philippines
Topic owner
I looked at the smsd logs again (I was surprised that it reached almost 100++MB in less than 30 mins) and saw that it had some errors when writing to the folders. I changed the permissions to 777 (along with changing the baudrate of the E1552 to 9200 or 9600 - I forgot the exact value) and SMS Tools now works perfectly. :)

I'm going to post another topic though on how to make the folders more secure. Keeping them at 777 doesn't seem like a good idea. :)

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.