SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 13:53
SMSTools3 Community » Help and support Bottom

[outdated] Timeout Errors

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2011
Location: Sheffield, United Kingdom
Operating system name and version: ubuntu 10.10
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: Samsung D900e Phone
Interface: USB


Have been using this phone for 4 months now - moved servers from an old HP G3 to a Dell Pc
this has been working for about 4 weeks - now I started to get the following problems



smsd.conf is

# Global configuration

devices = modem1

loglevel = 7

logfile = /var/log/sms/smstools.log

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

delaytime = 6
errorsleeptime = 12
blocktime = 180

autosplit = 3
receive_before_send = yes

# Modem configuration

# Samsung D900e
[modem1]
device = /dev/ttyACM0
incoming = yes
send_delay = 1
send_handshake_select = no
 
'smsdconf' Syntax Highlight powered by GeSHi


I added the send_delay and Send_handshake to try and fix the problem

Also as I spent years working under change control - ~I am sure that no updates on the system
have taken place in the last two weeks


« Last edit by pjaway on Fri Mar 04, 2011 09:31, 121 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
As everything has been working in the past, I cannot imagine what is causing the problem now.

After the PDU is sent, the modem stops answering. Do you know if that SMS was received or not?

You could add a modem setting verify_pdu = yes. This causes that smsd will check what is echoed back from the modem, when the PDU is sent. In some cases this may detect if there is a problem with communication, but it's not sure if this helps in your case.

Member
Registered:
Jan 2011
Location: Sheffield, United Kingdom
Topic owner
I have added that to smsd.conf

restarted

sent a test message - here is the output

tail -f /var/log/smsd.log


Does this give anyone any ideas ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Does this happen with all other outgoing messages too?

And can you receive messages?

I think that the modem or SIM may be broken. After the PDU is sent, nothing is received within a one minute, and then the PDU is received but no information about sending of failure. There should be +CMGS: 23 OK, or some ERROR.

Member
Registered:
Jan 2011
Location: Sheffield, United Kingdom
Topic owner
This is the same for all out going messages;

Will try and send some messages now - to see what happens

Thanks

PJ

Member
Registered:
Jan 2011
Location: Sheffield, United Kingdom
Topic owner
No messages are being received - they arrive on the phone - but are not being picked up

Have restarted smsd and server

Still the same

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Sorry, I forgot this topic :(. Is this problem still active?

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.