SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat Apr 17, 2021 16:58
SMSTools3 Community » Help and support Bottom

[outdated] Huawei E170 and SMS delivery report

  This topic is locked

Page:  1

Author Post
Member
Registered:
Mar 2011
Location: Spain
Operating system name and version: Debian Lenny
Version of smsd: v3.1.14
Smsd installed from: sources
Name and model of a modem / phone: Huawei E170
Interface: USB

I use smstools with USB modem Huawei E170 to send and receive SMS. All work well but I cannot get SMS delivery report. I've tried numerous configurations and it doesn't work.
I need help, thanks.

My smsd.conf:

[GSM1]
report_device_details = yes
init = ATE0+CNMI=2,0,0,2,1
device = /dev/ttyUSB0
incoming = yes
pin = ****
mode = new
baudrate = 19200
rtscts = yes
cs_convert = yes
report = yes
memory_start = 0
sending_disabled = no
 
'smsdconf' Syntax Highlight powered by GeSHi


/var/log/smsd.log:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have to say that I do not know why you do not receive delivery reports :(.

Assuming that report was not disabled in the SMS file, and assuming that SMS was delivered to the receivers phone, report should be received. My Huawei E1552 is using CNMI=0,0,0,0,0 and I also tried with 2,0,0,2,1. With both settings report was received as expected.

Have you tried the current SIM in the handset, is the report received when it's asked?

Member
Registered:
Mar 2011
Location: Spain
Topic owner
keke wrote
I have to say that I do not know why you do not receive delivery reports :(.

Assuming that report was not disabled in the SMS file, and assuming that SMS was delivered to the receivers phone, report should be received. My Huawei E1552 is using CNMI=0,0,0,0,0 and I also tried with 2,0,0,2,1. With both settings report was received as expected.

Have you tried the current SIM in the handset, is the report received when it's asked?

This is the problem, the SMS was delivered to the receivers phone. I've tried with CNMI=0,0,0,0,0 and with 2,0,0,2,1 but I never get the report.

The SIM is ok and it gets the report in Nokia phone.

What can i try ?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
ibercom wrote
keke wrote
I have to say that I do not know why you do not receive delivery reports :(.

Assuming that report was not disabled in the SMS file, and assuming that SMS was delivered to the receivers phone, report should be received. My Huawei E1552 is using CNMI=0,0,0,0,0 and I also tried with 2,0,0,2,1. With both settings report was received as expected.

Have you tried the current SIM in the handset, is the report received when it's asked?

This is the problem, the SMS was delivered to the receivers phone. I've tried with CNMI=0,0,0,0,0 and with 2,0,0,2,1 but I never get the report.

The SIM is ok and it gets the report in Nokia phone.

What can i try ?

There is one more thing to try, a dual-memory handler:

primary_memory = SM
secondary_memory = SR


My E1552 also has SR memory available, with 10 slots, but it still stores reports into the SM memory. Perhaps your device uses SR memory.

Member
Registered:
Mar 2011
Location: Spain
Topic owner
I have done the changes and it does not work.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Is this issue still active?

But in any case I don't know the solution, other than replace the stick.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.