SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 06:42
SMSTools3 Community » Help and support Bottom

[answered] SMSTOOLS3 without any log! Cant's send or receive SMS!

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2011
Location: Viseu / Viseu / Portugal, Portugal
Operating system name and version: Linux [ELASTIX] - Apache
Version of smsd: SMSTools3
Smsd installed from: sourceforge.net
Name and model of a modem / phone: Huawei E220
Interface: USB


Greetings to ALL, and thanks for your efforts!

At first, it seems that i don't have any file at /var/log/sms/smstools.log! It's allways empty! I've already changed chmod sms folder to 777
I can login at the main page! SMSTools is active in Gateway "Manage smstools"
- Which number should i introduce in the gateway question, on main configuration?
- Every number should or must be with international format (+xxxxxx....)?
- Already searched for Maximum SMS count, but dind't find any information! what does it means?
- In preferences menu, Mobile (sender number) must be with or without the international format?

For the last, here is my smsd.conf:
# Global configuration

devices = GSM1

loglevel = 10

logfile = /var/log/sms/smstools.log

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

delaytime = 6
errorsleeptime = 12
blocktime = 180

autosplit = 3
receive_before_send = yes

# Modem configuration

[GSM1]
device = /dev/ttyUSB1
smsc = +35193121314
incoming = yes
init = AT^CURC=0
report = yes
baudrate = 9600
______________________________
LSusb command says:
[root@srv ~]# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
______________________________
Dmesg command says:
drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
option 2-1:1.0: GSM modem (1-port) converter detected
usb 2-1: GSM modem (1-port) converter now attached to ttyUSB0
option 2-1:1.1: GSM modem (1-port) converter detected
usb 2-1: GSM modem (1-port) converter now attached to ttyUSB1
usbcore: registered new driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1
SCSI subsystem initialized
hdc: ATAPI 48X DVD-ROM drive, 256kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.

Thankyou once more for any help! By the way:
I'm writing from Portugal! I would like to work about translating to portuguese, your manual and some things that could be helpfull in the future!
Best regards to all
MareAlta


« Last edit by MareAlta on Sun Apr 03, 2011 13:13, 120 months ago. »
Member
Registered:
Apr 2011
Location: Viseu / Viseu / Portugal, Portugal
Topic owner
Adding some information that can be analized:

2011-04-04 11:44:39,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-04-04 11:44:40,2, GSM2: PIN handling: expected READY, modem answered +CPIN: SIM PIN OK
2011-04-04 11:44:40,2, GSM2: Modem handler 1 terminated abnormally. PID: 7765.
2011-04-04 11:44:40,2, GSM1: PIN handling: expected READY, modem answered +CPIN: SIM PIN OK
2011-04-04 11:44:40,2, GSM1: Modem handler 0 terminated abnormally. PID: 7764.

Now all sms are going to queue! I don't understand why!?
still don't have the file smstools.log in /var/log/sms/smstools.log

Best Regards

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
MareAlta wrote
I can login at the main page! SMSTools is active in Gateway "Manage smstools"
- Which number should i introduce in the gateway question, on main configuration?
- Every number should or must be with international format (+xxxxxx....)?
- Already searched for Maximum SMS count, but dind't find any information! what does it means?
- In preferences menu, Mobile (sender number) must be with or without the international format?

It sounds that you are trying to use playSMS, right? You could check issues from it's documentation. Also some howto's are available, as far as I know. Try to search them with Google ("playsms smstools3", for example).

From smsd's point of view, always use numbers in the international format, and without the plus sign.

MareAlta wrote
Now all sms are going to queue! I don't understand why!?
still don't have the file smstools.log in /var/log/sms/smstools.log

Messages are going to the queue, because the mainprocess is still running. It is normal.

Your current configuration does not match to the configuration shown in post #1. Please show the current configuration.

Answer to the PIN was incorrect from the modem. You could ensure that PIN is disabled, and then use a modem setting: pin = ignore.

If you do not have a file /var/log/sms/smstools.log, you probably have changed the configuration. Smsd does not start if it cannot create a log file. In this case an error message is shown while smsd is trying to start. However, as you have shown a piece of log, from where did you get it?

What is the actual version of smsd, 3.1.something? Type smsd -V to see it.

Member
Registered:
Apr 2011
Location: Viseu / Viseu / Portugal, Portugal
Topic owner
Hi and thanks for your Reply KEKE!

It seams that all the system is trying to work now.
I've made some SMSD reset commands and i start seeing in log, changes and trying to send messages! All i'm gone doo is add the line pin and ist numbers! Possibily its going to work!

Thanks anyway for your answer!
I'll see and report here the status!
Best Regards
MareAlta

Member
Registered:
Apr 2011
Location: Viseu / Viseu / Portugal, Portugal
Topic owner
Ok! Everything seams to be running ok!
I can send SMS but can't receive!
All is running even the log files!
I made a tail -f /var/logs/smsd.log and saw this:
SMS received, From: 3519363xxxxx
2011-04-04 18:28:57,6, GSM1: Wrote an incoming message file: /var/spool/sms/incoming/GSM1.YvjM6f
But i can't see it in incoming folder on playsms! Nor even in INBOX. And reports can't see in same!

Any ideas what is missing?
Thank you

Member
Registered:
Apr 2011
Location: Viseu / Viseu / Portugal, Portugal
Topic owner
Why this messages are pending when they have already been delivered in destination phones?
Something is missing (to me) but i can't find what! I'm goin to rest a while and come back sooner!

Thanks in advance!
Best Regards
MareAlta

admin 2011-04-04 19:34:37 smstools 35193xxxxxxx xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Pending

2. admin 2011-04-04 19:24:54 smstools 3519363xxxxx
(Rui Silva) Hi, good night and have a sweet dream :* - A.N.V

Pending

1. admin 2011-04-04 19:22:09 smstools 9363xxxxx
(Rui Silva) Hello! A.N.V

Pending

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.