SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Tue Apr 13, 2021 14:20
SMSTools3 Community » Help and support Bottom

[outdated] GUI Status Monitor

  This topic is locked

Page:  Previous  1  2

Author Post
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
And you now have a file /var/spool/sms/stats/status, what is in it? Just want to be sure before continuing...

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

Thank you very much for your reply.

The output for " root@server1:/var/spool/sms/stats# vi status" is as under


Status: 11-05-20 22:21:50, i---------------------------------------------------------------
modem1: 11-05-20 22:21:47, Idle, 22, 0, 8, ssi: -83 dBm (Good), ber: ??


Thanks & regards,

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Okay, now it's time to create your own theme for playSMS.

I used the name smsdtheme, but you can select whatever name you want to use. The new theme is based on default theme, others will not work. Create only one new theme which is using the code shown below.

...



« Last edit by keke on Sat May 21, 2011 17:03, 120 months ago. »
Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

Thank you for advice & I have installed successfully as per instructions

The Output in PlaySMS under SmsdTheme is as under;

Current status

Status: 11-05-21 12:47:03, i---------------------------------------------------------------
modem1: 11-05-21 12:46:59, Idle, 33, 0, 11, ssi: -87 dBm (Workable), ber: ??


Thanks & regards,

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
As your device does not support Bit Error Rate, you could use the modem setting:
signal_quality_ber_ignore = yes

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
tummyg wrote
It stopped sending/receiving messages 2 times in month

As this original problem is still unresolved, can you examine your log like instructed in the post #12?

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

I added
signal_quality_ber_ignore = yes

in Modem Configuration in file smsd.conf


Now the output in PlaySMS under SmsdTheme is as under;

Status: 11-05-21 16:34:29, r---------------------------------------------------------------
modem1: 11-05-21 16:34:29, Receiving, 39, 0, 1, ssi: -83 dBm (Good)

Thanks & regards

Tummy

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

I have copied few lines from smsd.log & most other lines about AT commands I have deleted so the content of the file should be relevant.

Another, very funny thing is happening, If I reboot my Server then there are 4 messages Automatically starts sending to recipients. Two of these messages I sent using my Mobile with BC followed by message(PlaySMS feature) & 2 other messages also starts sending

regards,

Tummy

Here is the Output from /var/log/smsd.log


2011-03-31 10:40:20,2, smsd: Smsd v3.1.14 started.
2011-03-31 10:40:20,2, smsd: Running as root:root.
2011-03-31 10:40:20,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-03-31 15:44:56,3, modem1: Modem did not accept the pre-init string
2011-03-31 15:44:57,3, modem1: write_to_modem: error 5: Input/output error
2011-04-04 10:46:17,2, smsd: Smsd v3.1.14 started.
2011-04-04 10:46:17,2, smsd: Running as root:root.
2011-04-04 10:46:17,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-04-05 10:37:56,2, smsd: Smsd v3.1.14 started.
2011-04-05 10:37:56,2, smsd: Running as root:root.
2011-04-05 10:37:57,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-04-06 10:49:54,2, smsd: Smsd v3.1.14 started.
2011-04-06 10:49:54,2, smsd: Running as root:root.
2011-04-07 16:33:58,3, modem1: Unexpected input: RING
2011-04-07 16:34:07,3, modem1: Unexpected input: RING RING
2011-04-07 19:32:29,2, smsd: Smsd mainprocess is awaiting the termination of all modem handlers. PID: 2202.
2011-04-07 19:32:29,2, modem1: Modem handler 0 terminated. PID: 2228, was started 11-04-07 10:56:04.
2011-04-07 19:32:29,2, smsd: Smsd mainprocess terminated. PID 2202, was started 11-04-07 10:56:04.
2011-04-08 11:26:54,2, smsd: Smsd v3.1.14 started.
2011-04-12 17:32:52,2, smsd: Smsd mainprocess is awaiting the termination of all modem handlers. PID: 2332.
2011-04-14 17:54:18,3, modem1: Modem did not accept the pre-init string
2011-04-15 16:37:52,2, smsd: Smsd v3.1.14 started.
2011-04-15 16:37:52,2, smsd: Running as root:root.
2011-04-15 16:37:52,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-04-15 16:39:54,3, modem2: Modem is not ready to answer commands (Timeouts: 0)
2011-04-15 17:32:46,3, modem1: Unexpected input: RING
2011-04-15 17:41:35,3, modem2: Modem is not ready to answer commands (Timeouts: 0)
2011-04-15 17:42:50,2, smsd: Smsd mainprocess is awaiting the termination of all modem handlers. PID: 2830.
2011-04-16 12:10:53,3, modem1: Modem is not ready to answer commands (Timeouts: 0)
2011-04-16 12:17:45,3, modem2: Unexpected input: RING RING
2011-04-16 12:19:24,3, modem1: Modem is not ready to answer commands (Timeouts: 0)
2011-04-18 12:42:14,3, modem1: Unexpected input: RING
2011-04-18 12:43:00,3, modem1: write_to_modem: error 5: Input/output error
of all modem handlers. PID: 2664.
2011-04-18 19:29:25,2, modem1: Modem handler 0 terminated. PID: 2695, was started 11-04-18 11:27:18.
2011-04-18 19:29:25,2, smsd: Smsd mainprocess terminated. PID 2664, was started 11-04-18 11:27:18.
2011-04-29 17:00:50,3, modem1: write_to_modem: error 5: Input/output error
2011-04-29 17:01:02,3, modem1: write_to_modem: error 5: Input/output error
2011-05-01 13:28:10,3, modem1: Unexpected input: RING RING
2011-05-18 14:50:22,5, smsd: Moved file /var/spool/sms/outgoing/out.9.10.1116 to /var/spool/sms/checked
2011-05-18 14:50:23,5, modem1: SMS sent, Message_id: 155, To: 91xxxxxxxxxx, sending time 4 sec.
2011-05-18 14:59:54,5, smsd: Moved file /var/spool/sms/outgoing/out.9.10.1131 to /var/spool/sms/checked
2011-05-19 13:45:16,5, smsd: Moved file /var/spool/sms/outgoing/out.0.1.1169 to /var/spool/sms/checked
2011-05-19 14:39:53,2, smsd: Smsd v3.1.14 started.
2011-05-19 14:39:53,2, smsd: Running as root:root.
2011-05-19 14:43:07,5, modem1: SMS sent, Message_id: 1, To: 91xxxxxxxxx, sending time 4 sec.
2011-05-19 15:12:41,5, smsd: No destination in file /var/spool/sms/outgoing/out.0.1.1223
2011-05-19 15:39:11,3, modem1: The modem answer was not OK: +CMS ERROR: 2058
2011-05-19 15:39:11,5, modem1: Waiting 12 sec. before retrying
2011-05-19 15:39:11,5, smsd: Moved file /var/spool/sms/outgoing/out.9.10.1248 to /var/spool/sms/checked
2011-05-19 18:04:57,3, modem1: Modem did not accept the pre-init string
2011-05-19 18:04:57,3, modem1: Error: Unexpected answer from Modem after +CREG?, waiting 1 sec. before retrying
2011-05-20 15:06:06,5, modem1: SMS received, From: 91xxxxxxxxx
2011-05-20 15:07:18,5, smsd: Moved file /var/spool/sms/outgoing/out.0.1.1320 to /var/spool/sms/checked
2011-05-20 15:22:19,5, smsd: No destination in file /var/spool/sms/outgoing/out.0.1.1326
2011-05-20 15:22:20,5, smsd: Moved file /var/spool/sms/outgoing/out.0.1.1327 to /var/spool/sms/checked
2011-05-20 15:22:24,5, smsd: Moved file /var/spool/sms/outgoing/out.0.1.1334 to /var/spool/sms/checked
2011-05-21 13:31:29,3, modem1: The modem answer was not OK: +CMS ERROR: 49938
2011-05-21 13:31:29,5, modem1: Waiting 12 sec. before retrying
2011-05-21 13:31:48,3, modem1: The modem answer was not OK: +CMS ERROR: 2058
2011-05-21 16:34:03,5, modem1: SMS received, From: DM-xxxxxx
2011-05-21 16:34:27,5, smsd: No destination in file /var/spool/sms/outgoing/out.0.1.1388

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
What I wanted to see was the typical error which causes stopping, and some 50 lines around it... But this is going too difficult... :(

The log you posted does not show how smsd is stopped in the case of error. I have to assume that you have stopped it manually. There are some input/output errors, and I have to assume that it is behind the problem, and when the error starts, you need to unplug the modem before it gets working again. It seems that your system is not very good. There might be EMI (noise), which is not good for USB. You could try to use another, or shorter USB cable. Also, if possible, you could try with another modem, to see if the modem is bad.

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

Can We do this way, I delete smsd.log & create new one & from Now I monitor.

I would also take care of Modem Noise as you suggested.

Further, Sir, I was looking at the smsd_trouble.log in /var/log/ which is as under;



thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
When posting log, please use the Log tag.

You should take care about the phone numbers. Basically international format should be always used, but there are setting for the automation of format, see prefixes and national_prefixes. Also see the sample at the bottom of fileformat.

You was trying to send to 9198100XXXXX (India), which looks correct but smsd cannot know if that number is in use. Another number was 98996XXXXX (Iran?), or it probably has country code missing. And there was 3891 used, which looks incorrect. If it is a "short" number, it must be given with 's', like s3891.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
tummyg wrote
Another, very funny thing is happening, If I reboot my Server then there are 4 messages Automatically starts sending to recipients. Two of these messages I sent using my Mobile with BC followed by message(PlaySMS feature) & 2 other messages also starts sending

From the log of smsd you should see what messages were sent, and especially what messages were received after restarting the server, and just before playSMS sent those BC messages. Also, in "Incoming SMS" and "Outgoing SMS" of playSMS you should see what messages are received and sent at that time. Incoming SMS has a keyword BC, and outgoing SMS has the group set, so those can be located easily.

I now assume that you, or anyone else, did not send SMS from your mobile to your server at that time when the server was rebooted. Is this correct?

Assuming that the previous assumption was correct, you likely have a bad or broken modem, and you should replace it with another one, which is not based on chipset from Wavecom.

At least in some countries and with some operators, modems based on Wavecom chipsets have serious problems with status reports. And as playSMS forces to use status reports, this issue is important.

 You could do the test:

1. First check and write down what are the latest messages in folders of playSMS.

2. Be very careful, and especially do not whack with any thing ;).

3. Send an SMS from your mobile to your gateway, using a different text which is not used before (for verification).

4. In playSMS check that this message exists.

5. Send an SMS from playSMS to your mobile.

6. From the log of smsd, check how this SMS is sent, and how status report is received.

7. If no status report is received in five minutes, it is an important thing to know too.

8. Send an SMS from your mobile to your gateway, again using different text than any other SMS had.

9. From the log of smsd, check how this SMS is received.

10. Is it received, or is a status report with previous message id received again? Or nothing?

11. If status report is received again, and no new SMS from your mobile, the modem works faulty.

12. If new SMS is received, the modem has no problem and the reason for your "phantom messages" is somewhere else, and I cannot imagine where it is.

13. If nothing is received in five minutes, stop the smsd, disconnect the modem, connect it back and restart smsd. Is something received after those actions? 



« Last edit by keke on Tue May 24, 2011 09:37, 120 months ago. »
Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

Thank you so much for your reply,

"I now assume that you, or anyone else, did not send SMS from your mobile to your server at that time when the server was rebooted. Is this correct?"

Sir, This is correct

Now, I do not see any Pending Messages in Que of PlaySMS " Statistics "

Now I have taken a GSM Tracker which sends SMS to SMSTOOLS3 server periodically & smsd.log is as under;

Hidden private text.



regards,

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
GSM tracker has nothing to do with your current problem.

It is not important if you have pending messages in playSMS. It is important to do the test which is presented in the post #37. Each item of it, and carefully. Can you do it, and comment result for each item? I have now numbered items in test, for easier answering, and highlighted the test to help you see it in the post.

If you do not want to follow the instructions, please say it, and I can then close this topic, and stop asking questions which may lead to solving your problems.

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

I am extremely sorry for mentioning about tracker, I just wanted to show you the log

I would take care to follow the instructions, maybe I am trying to do many things at a time, once again sorry.

Please feel free to ask Questions

regards,

Tummy

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
keke wrote
From the log of smsd you should see what messages were sent, and especially what messages were received after restarting the server, and just before playSMS sent those BC messages. Also, in "Incoming SMS" and "Outgoing SMS" of playSMS you should see what messages are received and sent at that time. Incoming SMS has a keyword BC, and outgoing SMS has the group set, so those can be located easily.

This one was important too. Do you still have that log, and can you verify message in the log and playSMS at that time?

Member
Registered:
Feb 2011
Location: New Delhi, India
Topic owner
Sir,

Thank you for your reply.

I am putting down the log file for your reference.

My server got rebooted 2 times last evening & 2/3 times today because of Power Failure

I am putting below the log file for your reference


Hidden private text.




« Last edit by keke on Wed May 25, 2011 08:56, 120 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
What did you mean to show with that log? I do not understand. :(

Please read the post #41 again, and especially notice the phrase "at that time".

To resolve if there was "phantom" messages or not, we need to see the log from that time, not from any time.

  This topic is locked

Page:  Previous  1  2

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.