SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Feb 28, 2021 15:05
SMSTools3 Community » Help and support Bottom

[answered] Trying to get stored message ERROR

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jul 2011
Location: Tomsk, Russian Federation
Operating system name and version: FreeBSD 7.2-RELEASE #4
Version of smsd: Version 3.1.14
Smsd installed from: ports
Name and model of a modem / phone: Motorola C380
Interface: USB

Hello, I did not receiving the SMS. Sending SMS is fine.

Log file:


Settings:


Thanks. (c) Google tranlsation

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
First, you have disabled handshaking (rtscts), why is that? Usually handshaking should be used, and if it is not used, lower baudrate is often required. You could try with 9600 or 19200. In many cases there is "A" letter missing from the answer, and it does not look very good.

Remove init = ATZ setting. It causes that "echo" is set to "ON", which usually should not be done.

Pre-initialization gets an error. To see if it is caused by CREG=2, use the modem setting loglevel_lac_ci = 8.

It seems that indexes of messages in your phone are not numbers starting from zero or one. In that case you should try a modem setting check_memory_method = 31 which gets list of indexes.

Also, use the modem setting report_device_details = yes and show those details from the log (all between ## Start of device details and ## End of device details).

Member
Registered:
Jul 2011
Location: Tomsk, Russian Federation
Topic owner
Great work! SMS received normally, but...

Details without "init = ATZ":


With "init = ATZ"


Settings:


Without "init = ATZ" SMS not received


(c) My translate :)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Your device is bad, if it really needs ATZ every time when communication is started. But it looks bad anyway, as it still cuts characters from echoed answers, even when ATZ was used.

You could try with the following modem settings:

pre_init = no
init = ATZ
init2 = ATE0


  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.