SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Mar 07, 2021 12:06
SMSTools3 Community » Help and support Bottom

ZTE 160 conf script

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Aug 2011
Location: Uruguay
Operating system name and version: Ubuntu 11.04 64 bits
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: ZTE 160
Interface: USB/MicroUSB

I want to use a ZTE 160 GSM phone to send and receive SMS, it send OK and receive, but SMSTOOLS can't read SMS in phone memory.

smsd.log

: Checking memory size
2011-08-25 13:39:58,7, GSM0: -> AT+CMGD=?
2011-08-25 13:39:58,7, GSM0: Command is sent, waiting for the answer
2011-08-25 13:39:58,7, GSM0: <- +CMGD: (),(0-4) OK
2011-08-25 13:39:58,6, GSM0: No SMS received

smsd.conf:

devices = GSM0
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
report = /var/spool/sms/report
sent = /var/spool/sms/sent
logfile = /var/log/smsd.log
loglevel = 7
delaytime = 10
errorsleeptime = 10
executable_check = no
blocktime = 3600
eventhandler = /usr/bin/php -f /var/smstools3/scripts/eventhandler
receive_before_send = no
autosplit = 3
infofile = /var/run/sms/smsd.working
pidfile = /var/run/sms/smsd.pid
date_filename = no

[queues]
OTHER = /var/spool/sms/other

[provider]
OTHER = 0,1,2,3,4,5,6,7,8,9

[GSM0]
init= AT+CPMS="ME","ME","ME"
device = /dev/ttyUSB0
incoming = yes
queues = OTHER
mode = new
smsc = 13314258221
baudrate = 115200
rtscts = yes
cs_convert = yes
report = no
memory_start = 0
check_memory_method=2
 
 
'smsdconf' Syntax Highlight powered by GeSHi


I try check_memory_method 1/2/3/4/5
Any idea? Thank you!!!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
When your modem surely has at least one SMS received, try with a default check_memory_method and show a piece of log.

Also define report_device_details = yes and show those details.

You have disabled executable_check, probably because a definition of eventhandler is incorrect. Eventhandler must be single script, without any arguments. If you want to run PHP script directly, do it this way:

executable_check = yes
eventhandler = /var/smstools3/scripts/eventhandler.php


And in the script:

#!/usr/bin/php
<?php

$sms_type = $argv[1];
$sms_file = $argv[2];

// Your code here...

?>
 
'php' Syntax Highlight powered by GeSHi


Member
Registered:
Aug 2011
Location: Uruguay
Topic owner
Thank you keke for your help.
I made the changes you suggest, it seems SMSTools can't read phone sms memory area, may be wrong init?

Thankyou!!


Here are the results:

smsd.conf
devices = GSM0

outgoing = /var/spool/sms/outgoing

checked = /var/spool/sms/checked

failed = /var/spool/sms/failed

incoming = /var/spool/sms/incoming

report = /var/spool/sms/report

sent = /var/spool/sms/sent

logfile = /var/log/smsd.log

loglevel = 7

delaytime = 10

errorsleeptime = 10

executable_check = yes

blocktime = 3600

eventhandler = /var/smstools3/scripts/eventhandler.php

receive_before_send = no

autosplit = 3

infofile = /var/run/sms/smsd.working

pidfile = /var/run/sms/smsd.pid

date_filename = no



[queues]

OTHER = /var/spool/sms/other



[provider]

OTHER = 0,1,2,3,4,5,6,7,8,9



[GSM0]

init= AT+CPMS="ME","ME","ME"

device = /dev/ttyUSB0

incoming = yes

keep_messages = no

queues = OTHER

mode = new

baudrate = 115200

rtscts = yes

cs_convert = yes

report = no

report_device_details = yes

memory_start = 0

check_memory_method=1

eventhandler.php
#!/usr/bin/php
<?php
$sms_type = $argv[1];
$sms_file = $argv[2];

$codigo_pais = '1';
$carpeta_envio = '/var/spool/sms/outgoing/';

function regsms($tipo,$num_tel_envia,$num_tel_recibe,$msgtexto,$msgid,$msgidref)
{
$query_sms = "INSERT INTO sms (cli_tel_envia,sms_msg_texto) VALUES('$num_tel_envia','$msgtexto')";
$query_result_sms = @mysql_query($query_sms) or die(mysql_error());
return $query_result_sms;
}

$dbhost = "localhost";
$dbusuario = "sms";
$dbpassword = "smspsw";
$db = "sms";
$conexion = mysql_connect($dbhost, $dbusuario, $dbpassword) or die(mysql_error());
mysql_select_db($db, $conexion) or die(mysql_error());

if ($sms_type == "RECEIVED")
{
$num_tel_envia = system("formail -zx From: < $sms_file");
$msgtexto = system("sed -e '1,/^$/ d' < $sms_file");
regsms($num_tel_envia,$msgtexto);
}
mysql_close($conexion);
?>

smsd.log
2011-09-05 15:14:10,2, smsd: Smsd v3.1.14 started.
2011-09-05 15:14:10,2, smsd: Running as root:root.
2011-09-05 15:14:10,7, smsd: Running startup_check (shell): /var/spool/sms/incoming/smsd_script.NL3Jx2 /tmp/smsd_data.5nczXD
2011-09-05 15:14:10,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2011-09-05 15:14:10,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2011-09-05 15:14:10,5, smsd: Outgoing file checker has started. PID: 4501.
2011-09-05 15:14:10,5, GSM0: Modem handler 0 has started. PID: 4503.
2011-09-05 15:14:10,7, smsd: All PID's: 4501,4503
2011-09-05 15:14:10,5, GSM0: Using check_memory_method 1: CPMS is used.
2011-09-05 15:14:10,6, GSM0: Checking device for incoming SMS
2011-09-05 15:14:10,6, GSM0: Checking if modem is ready
2011-09-05 15:14:11,3, GSM0: Unexpected input: +GCAP: +CGSM,+DS,+ES OK
2011-09-05 15:14:11,7, GSM0: -> AT
2011-09-05 15:14:11,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:16,7, GSM0: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-09-05 15:14:16,7, GSM0: <-
2011-09-05 15:14:16,7, GSM0: -> .
2011-09-05 15:14:16,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:18,7, GSM0: <- +GCAP: +CGSM,+DS,+ES OK
2011-09-05 15:14:18,6, GSM0: Pre-initializing modem
2011-09-05 15:14:18,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:14:18,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:18,7, GSM0: <- OK
2011-09-05 15:14:18,6, GSM0: Checking if modem needs PIN
2011-09-05 15:14:19,7, GSM0: -> AT+CPIN?
2011-09-05 15:14:19,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:19,7, GSM0: <- +CPIN: READY OK
2011-09-05 15:14:19,6, GSM0: Initializing modem
2011-09-05 15:14:19,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:14:19,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:19,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:14:20,7, GSM0: -> AT+CSQ
2011-09-05 15:14:20,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:20,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:14:20,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:14:20,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:14:20,7, GSM0: -> AT+CREG?
2011-09-05 15:14:20,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:20,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:14:20,6, GSM0: Modem is registered to the network
2011-09-05 15:14:20,6, GSM0: Location area code: 6A29, Cell ID: 0680
2011-09-05 15:14:21,7, GSM0: -> AT+CSQ
2011-09-05 15:14:21,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:21,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:14:21,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:14:21,6, GSM0: Selecting PDU mode
2011-09-05 15:14:21,7, GSM0: -> AT+CMGF=0
2011-09-05 15:14:21,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:21,7, GSM0: <- OK
2011-09-05 15:14:22,7, GSM0: -> AT+CIMI
2011-09-05 15:14:22,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:22,7, GSM0: <- 310410407234551 OK
2011-09-05 15:14:22,7, GSM0: -> AT+CGSN
2011-09-05 15:14:22,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:22,7, GSM0: <- 359078033877231 OK
2011-09-05 15:14:22,5, GSM0: CGSN: 359078033877231
2011-09-05 15:14:22,5, GSM0: IMSI: 310410407234551
2011-09-05 15:14:22,6, GSM0: Checking if reading of messages is supported
2011-09-05 15:14:23,7, GSM0: -> AT+CPMS?
2011-09-05 15:14:23,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:23,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:14:23,7, GSM0: ## Start of device details
2011-09-05 15:14:23,7, GSM0: # Manufacturer identification:
2011-09-05 15:14:23,7, GSM0: -> AT+CGMI
2011-09-05 15:14:23,7, GSM0: <- ZTE Corporation
OK
2011-09-05 15:14:23,7, GSM0: # Model identification:
2011-09-05 15:14:24,7, GSM0: -> AT+CGMM
2011-09-05 15:14:24,7, GSM0: <- 19
OK
2011-09-05 15:14:24,7, GSM0: # Revision identification:
2011-09-05 15:14:24,7, GSM0: -> AT+CGMR
2011-09-05 15:14:24,7, GSM0: <- 1.3.0 1 [Aug 26 2010 22:00:00]
OK
2011-09-05 15:14:24,7, GSM0: # New message indications, list of supported modes:
2011-09-05 15:14:25,7, GSM0: -> AT+CNMI=?
2011-09-05 15:14:25,7, GSM0: <- +CNMI: (0,1,2),(0,1,2,3),(0,2),(0,1,2),(0,1)
OK
2011-09-05 15:14:25,7, GSM0: # New message indications, current settings:
2011-09-05 15:14:25,7, GSM0: -> AT+CNMI?
2011-09-05 15:14:30,7, GSM0: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-09-05 15:14:30,7, GSM0: <- NO CARRIER
2011-09-05 15:14:30,7, GSM0: # Preferred message storage, list of supported mem's:
2011-09-05 15:14:31,7, GSM0: -> AT+CPMS=?
2011-09-05 15:14:31,7, GSM0: <- +CPMS: ("ME","MT","SM","SR"),("ME","MT","SM","SR"),("ME","MT","SM","SR")
OK
2011-09-05 15:14:31,7, GSM0: # Phonebook storage, available mem's:
2011-09-05 15:14:31,7, GSM0: -> AT+CPBS=?
2011-09-05 15:14:31,7, GSM0: <- +CPBS: ("SM","DC","FD","MC","ME","RC","EN","ON")
OK
2011-09-05 15:14:31,7, GSM0: # List messages, list of supported stat's:
2011-09-05 15:14:32,7, GSM0: -> AT+CMGL=?
2011-09-05 15:14:32,7, GSM0: <- +CMGL: (0-4)
OK
2011-09-05 15:14:32,7, GSM0: # Delete message, list of supported values:
2011-09-05 15:14:32,7, GSM0: -> AT+CMGD=?
2011-09-05 15:14:33,7, GSM0: <- +CMGD: (),(0-4)
OK
2011-09-05 15:14:33,7, GSM0: # Phone activity status, list of supported stat's:
2011-09-05 15:14:33,7, GSM0: -> AT+CPAS=?
2011-09-05 15:14:33,7, GSM0: <- +CPAS: (0,3,4)
OK
2011-09-05 15:14:33,7, GSM0: # TE character set, list of supported charset's:
2011-09-05 15:14:33,7, GSM0: -> AT+CSCS=?
2011-09-05 15:14:38,7, GSM0: put_command expected (OK)|(ERROR), timeout occurred. 1.
2011-09-05 15:14:38,7, GSM0: <-
2011-09-05 15:14:38,7, GSM0: # TE character set, current setting:
2011-09-05 15:14:38,7, GSM0: -> AT+CSCS?
2011-09-05 15:14:39,7, GSM0: <- +CSCS: "IRA"
OK
2011-09-05 15:14:39,7, GSM0: ## End of device details
2011-09-05 15:14:39,6, GSM0: Checking memory size
2011-09-05 15:14:39,7, GSM0: -> AT+CPMS?
2011-09-05 15:14:39,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:39,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:14:39,6, GSM0: Used memory is 0 of 100
2011-09-05 15:14:39,6, GSM0: No SMS received
2011-09-05 15:14:49,6, GSM0: Checking device for incoming SMS
2011-09-05 15:14:49,6, GSM0: Checking if modem is ready
2011-09-05 15:14:49,7, GSM0: -> AT
2011-09-05 15:14:49,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:50,7, GSM0: <- OK
2011-09-05 15:14:50,6, GSM0: Pre-initializing modem
2011-09-05 15:14:50,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:14:50,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:50,7, GSM0: <- OK
2011-09-05 15:14:50,6, GSM0: Initializing modem
2011-09-05 15:14:50,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:14:50,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:51,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:14:51,7, GSM0: -> AT+CSQ
2011-09-05 15:14:51,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:51,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:14:51,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:14:51,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:14:51,7, GSM0: -> AT+CREG?
2011-09-05 15:14:51,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:52,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:14:52,6, GSM0: Modem is registered to the network
2011-09-05 15:14:52,6, GSM0: Selecting PDU mode
2011-09-05 15:14:52,7, GSM0: -> AT+CMGF=0
2011-09-05 15:14:52,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:52,7, GSM0: <- OK
2011-09-05 15:14:52,6, GSM0: Checking memory size
2011-09-05 15:14:52,7, GSM0: -> AT+CPMS?
2011-09-05 15:14:52,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:14:53,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:14:53,6, GSM0: Used memory is 0 of 100
2011-09-05 15:14:53,6, GSM0: No SMS received
2011-09-05 15:15:03,6, GSM0: Checking device for incoming SMS
2011-09-05 15:15:03,6, GSM0: Checking if modem is ready
2011-09-05 15:15:03,7, GSM0: -> AT
2011-09-05 15:15:03,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:03,7, GSM0: <- OK
2011-09-05 15:15:03,6, GSM0: Pre-initializing modem
2011-09-05 15:15:03,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:15:03,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:04,7, GSM0: <- OK
2011-09-05 15:15:04,6, GSM0: Initializing modem
2011-09-05 15:15:04,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:15:04,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:04,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:15:04,7, GSM0: -> AT+CSQ
2011-09-05 15:15:04,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:05,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:15:05,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:15:05,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:15:05,7, GSM0: -> AT+CREG?
2011-09-05 15:15:05,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:05,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:15:05,6, GSM0: Modem is registered to the network
2011-09-05 15:15:05,6, GSM0: Selecting PDU mode
2011-09-05 15:15:05,7, GSM0: -> AT+CMGF=0
2011-09-05 15:15:05,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:06,7, GSM0: <- OK
2011-09-05 15:15:06,6, GSM0: Checking memory size
2011-09-05 15:15:06,7, GSM0: -> AT+CPMS?
2011-09-05 15:15:06,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:06,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:15:06,6, GSM0: Used memory is 0 of 100
2011-09-05 15:15:06,6, GSM0: No SMS received
2011-09-05 15:15:16,6, GSM0: Checking device for incoming SMS
2011-09-05 15:15:16,6, GSM0: Checking if modem is ready
2011-09-05 15:15:16,7, GSM0: -> AT
2011-09-05 15:15:16,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:17,7, GSM0: <- OK
2011-09-05 15:15:17,6, GSM0: Pre-initializing modem
2011-09-05 15:15:17,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:15:17,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:17,7, GSM0: <- OK
2011-09-05 15:15:17,6, GSM0: Initializing modem
2011-09-05 15:15:17,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:15:17,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:18,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:15:18,7, GSM0: -> AT+CSQ
2011-09-05 15:15:18,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:18,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:15:18,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:15:18,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:15:18,7, GSM0: -> AT+CREG?
2011-09-05 15:15:18,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:19,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:15:19,6, GSM0: Modem is registered to the network
2011-09-05 15:15:19,6, GSM0: Selecting PDU mode
2011-09-05 15:15:19,7, GSM0: -> AT+CMGF=0
2011-09-05 15:15:19,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:19,7, GSM0: <- OK
2011-09-05 15:15:19,6, GSM0: Checking memory size
2011-09-05 15:15:19,7, GSM0: -> AT+CPMS?
2011-09-05 15:15:19,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:20,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:15:20,6, GSM0: Used memory is 0 of 100
2011-09-05 15:15:20,6, GSM0: No SMS received
2011-09-05 15:15:30,6, GSM0: Checking device for incoming SMS
2011-09-05 15:15:30,6, GSM0: Checking if modem is ready
2011-09-05 15:15:30,7, GSM0: -> AT
2011-09-05 15:15:30,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:30,7, GSM0: <- OK
2011-09-05 15:15:30,6, GSM0: Pre-initializing modem
2011-09-05 15:15:30,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:15:30,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:31,7, GSM0: <- OK
2011-09-05 15:15:31,6, GSM0: Initializing modem
2011-09-05 15:15:31,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:15:31,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:31,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:15:31,7, GSM0: -> AT+CSQ
2011-09-05 15:15:31,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:32,7, GSM0: <- +CSQ: 8,99 OK
2011-09-05 15:15:32,6, GSM0: Signal Strength Indicator: (8,99) -97 dBm (Marginal), Bit Error Rate: not known or not detectable
2011-09-05 15:15:32,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:15:32,7, GSM0: -> AT+CREG?
2011-09-05 15:15:32,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:32,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:15:32,6, GSM0: Modem is registered to the network
2011-09-05 15:15:32,6, GSM0: Selecting PDU mode
2011-09-05 15:15:32,7, GSM0: -> AT+CMGF=0
2011-09-05 15:15:32,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:33,7, GSM0: <- OK
2011-09-05 15:15:33,6, GSM0: Checking memory size
2011-09-05 15:15:33,7, GSM0: -> AT+CPMS?
2011-09-05 15:15:33,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:33,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:15:33,6, GSM0: Used memory is 0 of 100
2011-09-05 15:15:33,6, GSM0: No SMS received
2011-09-05 15:15:43,6, GSM0: Checking device for incoming SMS
2011-09-05 15:15:43,6, GSM0: Checking if modem is ready
2011-09-05 15:15:43,7, GSM0: -> AT
2011-09-05 15:15:43,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:44,7, GSM0: <- OK
2011-09-05 15:15:44,6, GSM0: Pre-initializing modem
2011-09-05 15:15:44,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:15:44,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:44,7, GSM0: <- OK
2011-09-05 15:15:44,6, GSM0: Initializing modem
2011-09-05 15:15:44,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:15:44,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:45,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:15:45,7, GSM0: -> AT+CSQ
2011-09-05 15:15:45,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:45,7, GSM0: <- +CSQ: 9,99 OK
2011-09-05 15:15:45,6, GSM0: Signal Strength Indicator: (9,99) -95 dBm (Marginal), Bit Error Rate: not known or not detectable
2011-09-05 15:15:45,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:15:45,7, GSM0: -> AT+CREG?
2011-09-05 15:15:45,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:46,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:15:46,6, GSM0: Modem is registered to the network
2011-09-05 15:15:46,6, GSM0: Selecting PDU mode
2011-09-05 15:15:46,7, GSM0: -> AT+CMGF=0
2011-09-05 15:15:46,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:46,7, GSM0: <- OK
2011-09-05 15:15:46,6, GSM0: Checking memory size
2011-09-05 15:15:46,7, GSM0: -> AT+CPMS?
2011-09-05 15:15:46,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:47,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:15:47,6, GSM0: Used memory is 0 of 100
2011-09-05 15:15:47,6, GSM0: No SMS received
2011-09-05 15:15:57,6, GSM0: Checking device for incoming SMS
2011-09-05 15:15:57,6, GSM0: Checking if modem is ready
2011-09-05 15:15:57,7, GSM0: -> AT
2011-09-05 15:15:57,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:57,7, GSM0: <- OK
2011-09-05 15:15:57,6, GSM0: Pre-initializing modem
2011-09-05 15:15:57,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:15:57,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:58,7, GSM0: <- OK
2011-09-05 15:15:58,6, GSM0: Initializing modem
2011-09-05 15:15:58,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:15:58,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:58,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:15:58,7, GSM0: -> AT+CSQ
2011-09-05 15:15:58,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:59,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:15:59,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:15:59,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:15:59,7, GSM0: -> AT+CREG?
2011-09-05 15:15:59,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:15:59,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:15:59,6, GSM0: Modem is registered to the network
2011-09-05 15:15:59,6, GSM0: Selecting PDU mode
2011-09-05 15:15:59,7, GSM0: -> AT+CMGF=0
2011-09-05 15:15:59,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:00,7, GSM0: <- OK
2011-09-05 15:16:00,6, GSM0: Checking memory size
2011-09-05 15:16:00,7, GSM0: -> AT+CPMS?
2011-09-05 15:16:00,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:00,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:16:00,6, GSM0: Used memory is 0 of 100
2011-09-05 15:16:00,6, GSM0: No SMS received
2011-09-05 15:16:10,6, GSM0: Checking device for incoming SMS
2011-09-05 15:16:10,6, GSM0: Checking if modem is ready
2011-09-05 15:16:10,7, GSM0: -> AT
2011-09-05 15:16:10,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:11,7, GSM0: <- OK
2011-09-05 15:16:11,6, GSM0: Pre-initializing modem
2011-09-05 15:16:11,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:16:11,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:11,7, GSM0: <- OK
2011-09-05 15:16:11,6, GSM0: Initializing modem
2011-09-05 15:16:11,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:16:11,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:12,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:16:12,7, GSM0: -> AT+CSQ
2011-09-05 15:16:12,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:12,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:16:12,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:16:12,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:16:13,7, GSM0: -> AT+CREG?
2011-09-05 15:16:13,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:13,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:16:13,6, GSM0: Modem is registered to the network
2011-09-05 15:16:13,6, GSM0: Selecting PDU mode
2011-09-05 15:16:13,7, GSM0: -> AT+CMGF=0
2011-09-05 15:16:13,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:13,7, GSM0: <- OK
2011-09-05 15:16:13,6, GSM0: Checking memory size
2011-09-05 15:16:14,7, GSM0: -> AT+CPMS?
2011-09-05 15:16:14,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:14,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:16:14,6, GSM0: Used memory is 0 of 100
2011-09-05 15:16:14,6, GSM0: No SMS received
2011-09-05 15:16:24,6, GSM0: Checking device for incoming SMS
2011-09-05 15:16:24,6, GSM0: Checking if modem is ready
2011-09-05 15:16:24,7, GSM0: -> AT
2011-09-05 15:16:24,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:24,7, GSM0: <- OK
2011-09-05 15:16:24,6, GSM0: Pre-initializing modem
2011-09-05 15:16:25,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:16:25,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:25,7, GSM0: <- OK
2011-09-05 15:16:25,6, GSM0: Initializing modem
2011-09-05 15:16:25,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:16:25,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:25,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:16:26,7, GSM0: -> AT+CSQ
2011-09-05 15:16:26,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:26,7, GSM0: <- +CSQ: 10,99 OK
2011-09-05 15:16:26,6, GSM0: Signal Strength Indicator: (10,99) -93 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:16:26,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:16:26,7, GSM0: -> AT+CREG?
2011-09-05 15:16:26,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:26,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:16:26,6, GSM0: Modem is registered to the network
2011-09-05 15:16:26,6, GSM0: Selecting PDU mode
2011-09-05 15:16:27,7, GSM0: -> AT+CMGF=0
2011-09-05 15:16:27,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:27,7, GSM0: <- OK
2011-09-05 15:16:27,6, GSM0: Checking memory size
2011-09-05 15:16:27,7, GSM0: -> AT+CPMS?
2011-09-05 15:16:27,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:27,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:16:27,6, GSM0: Used memory is 0 of 100
2011-09-05 15:16:27,6, GSM0: No SMS received
2011-09-05 15:16:37,6, GSM0: Checking device for incoming SMS
2011-09-05 15:16:37,6, GSM0: Checking if modem is ready
2011-09-05 15:16:38,7, GSM0: -> AT
2011-09-05 15:16:38,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:38,7, GSM0: <- OK
2011-09-05 15:16:38,6, GSM0: Pre-initializing modem
2011-09-05 15:16:38,7, GSM0: -> ATE0+CMEE=1;+CREG=2
2011-09-05 15:16:38,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:38,7, GSM0: <- OK
2011-09-05 15:16:38,6, GSM0: Initializing modem
2011-09-05 15:16:39,7, GSM0: -> AT+CPMS="ME","ME","ME"
2011-09-05 15:16:39,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:39,7, GSM0: <- +CPMS: 0,100,0,100,0,100 OK
2011-09-05 15:16:39,7, GSM0: -> AT+CSQ
2011-09-05 15:16:39,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:39,7, GSM0: <- +CSQ: 11,99 OK
2011-09-05 15:16:39,6, GSM0: Signal Strength Indicator: (11,99) -91 dBm (Workable), Bit Error Rate: not known or not detectable
2011-09-05 15:16:39,6, GSM0: Checking if Modem is registered to the network
2011-09-05 15:16:40,7, GSM0: -> AT+CREG?
2011-09-05 15:16:40,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:40,7, GSM0: <- +CREG: 2,1, 6A29, E220680 OK
2011-09-05 15:16:40,6, GSM0: Modem is registered to the network
2011-09-05 15:16:40,6, GSM0: Selecting PDU mode
2011-09-05 15:16:40,7, GSM0: -> AT+CMGF=0
2011-09-05 15:16:40,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:40,7, GSM0: <- OK
2011-09-05 15:16:40,6, GSM0: Checking memory size
2011-09-05 15:16:41,7, GSM0: -> AT+CPMS?
2011-09-05 15:16:41,7, GSM0: Command is sent, waiting for the answer
2011-09-05 15:16:41,2, smsd: Smsd mainprocess is awaiting the termination of all modem handlers. PID: 4501.
2011-09-05 15:16:41,7, GSM0: <- +CPMS: "ME",0,100,"ME",0,100,"ME",0,100 OK
2011-09-05 15:16:41,6, GSM0: Used memory is 0 of 100
2011-09-05 15:16:41,6, GSM0: No SMS received
2011-09-05 15:16:41,2, GSM0: Modem handler 0 terminated. PID: 4503, was started 11-09-05 15:14:10.
2011-09-05 15:16:41,2, smsd: Smsd mainprocess terminated. PID 4501, was started 11-09-05 15:14:10.

Member
Registered:
Aug 2011
Location: Uruguay
Topic owner
All is working now! finally found the solution changing the init string:

init= AT+CPMS="SM","SM","SM"

Now send an receive OK.

Thank you, keke,

Greetings from Uruguay.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.